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Osmose O-Calc® Pro Overview  
O-Calc® Pro Pole Loading Analysis 

Osmose O-Calc® Pro automates the calculation of structural loading on new and existing utility poles.  

Major applications of this innovative software are line design, pole replacement, and joint use loading 
issues.  

In many cases, non-structural personnel at a utility must decide whether more cables can be added, or 
larger conductors can be used on existing pole lines without overloading the pole or structure.  O-Calc® 

Pro was developed to help technical and non-technical staff alike perform structural load analysis in a 

simple, straightforward manner.  The calculations within O-Calc® Pro are complex, but the operator 
interface is designed for simplicity of use.  In addition to technical load calculations and statistics, the 

application provides a configurable, three-dimensional visual rendering of each structure’s load 

conditions.   

O-Calc® Pro can be used to evaluate whether any structure within a line is already overloaded.  O-Calc® 

Pro can quickly assess the impact of re-conductoring for upgrading line performance.  The O-Calc® Pro 
analysis of stress along the length of a pole can be used to consider cost-effective alternatives to 

replacing overloaded poles.    

O-Calc® Pro is a valuable resource in evaluating structural load for joint use, safety, network reliability, 

and network planning purposes.   

 

O-Calc® Pro Equipment Catalogs 

Osmose O-Calc® Pro allows you to model a utility structure (wood, steel, concrete, composite, fiberglass 
pole, or multi-pole structure) by defining the components of the structure using the Inventory panel or 

interactively constructing the structure through the 3D View.  Both methods can be used 

simultaneously.  The model of the structure is created by adding equipment you manually define or by 

utilizing predefined components from within the Master or User Catalogs.  

The Osmose Master Catalog is installed with the O-Calc® Pro application. It contains a predefined list of 

common poles, structures, and equipment which are utilized in the field.  Master Catalogs contain a list 

of all available Load Cases, used to add the applicable pole loading safety regulations to the model.   

Also included, is the User Catalog which offer the ability to compile your own storehouse of poles and 

equipment you have created in O-Calc® Pro.  The customized User Catalog is helpful for modeling 

future structures from templates you have stored into customized folders for easy access and repeat 

use.  Users can add up to eight equipment catalogs for use in pole modeling. 
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Understanding the O-Calc® Pro Workspace  
O-Calc® Pro provides you with a variety of options enabling you to view and interact with new or 

existing pole data. Each display panel can be moved to various monitors or docked within the same 

screen view. Multiple docking layouts can be named and saved for instant retrieval. 

  

 
 

Workspace Panel Descriptions 

 

Panel Description 

Catalogs Displays the available equipment and assemblies to add 

to the pole model. In addition to entire pole templates. 

Catalogs are the primary method used to add items to 

the pole inventory. Users can add up to eight different 

catalogs. 

Inventory Displays the inventory of the structure as you construct 

it. Additionally, the inventory offers functionality using 

basic windows commands, including the drag and drop 

method for substitution and copying.   

3D View Display  Displays a 3D view of the structure and the 

surroundings.  

Measure Allows the measurement of pole attachments from an 

image. This process is referred to as Digital 

Measurement Technology (DMT). 
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Charts A predefined list of charts which can be used to help 

complete a structural analysis. 

Reports A list of reports available to help complete a structural 

analysis. 

Line Design The ability to model, analyze loading data on an entire 

line of poles. Global edits are possible on multiple 

poles. See the “Line Design User Guide” for details. 

Schematic 

  

Displays the attachment heights of major equipment on 

the structure in an elevation view.  

Capacity  Displays the selected pole models loading capacity 

results based on the construction and load case added. 

Displays messages to alert user of loading thresholds.  

Data Entry Displays the selected equipment’s attribute details for 

the user to edit.  

Top View  Displays the pole model view from the top and provides 

access to the Gang Editor tool.  

 

 

Menu Functionality 

  

Menu  Description  

Toolbar  Provides the File, Edit, Tools, View, Options, and Help 

menus to interact with the pole model(s) and get access 

to the User Guides, Videos and WIKI articles.  

Selected Load Case  Displays the Load Cases that are currently added to the 

pole in the Inventory. Multiple load cases can be added, 

but only one can be active at a time. 

Named View  Enables switching to different docking layouts based on 

work tasks and/or user preferences. These may include 

the Catalogs, 3D View, Measure, Charts, Reports, Line 

Design, Schematic View, Capacity, Data Entry, and Top 

View windows. Previously saved layouts can be recalled 

for one screen or multiple screen layouts. 

Menu Search  Easily find and execute menu commands.  

Capacity Heat Map Located within the Capacity panel. Provides a color-

coded two-dimensional representation of specific load 

values for the selected pole.  

Status Bar  Displays the path information to the currently loaded 

PPLX file, the calculation status and the user’s access 

level.  



O-Calc® Pro 8.0                                                                                                  User Guide  

©2025 Osmose Utilities Services, Inc.                                                                                                  17  

“R” Reset “B” Birdseye 

View  

Located in the 3D View area, these tools allow you to 

quickly reset the selected pole to the center of the 

ground line compass. Or to toggle to/from the Birdseye 

view of the top of the structure.  

Save Copy Print 3D View  The grey button between the Reset (R) and Birdseye (B) 

buttons provides access to save, copy, and print 

capability for the 3D View panel. 

 

Working in the Inventory 
The O-Calc® Pro Inventory panel provides the ability to view and interact with the pole and its 

equipment. The pole Inventory includes the type of pole(s), equipment attached, plus the load case(s) 

for applying pole loading regulations for wind, ice, and safety factors. 

Inventory Toolbar Menu 

The Inventory toolbar menu provides a variety of tools described below. 

  
 

K offers additional ways to access the various functionalities in the tool bar menu.  

 

Sort the equipment in the inventory to match how it’s attached to the pole from top to bottom. 

  

Expand all the plus sign nodes for the equipment in the Inventory panel tree view to quickly see each 

piece of equipment attached.  

 

  

Collapse all the plus sign nodes for the equipment in the Inventory panel tree view to see only the pole. 

 

Insulator Rotation is used to align insulators to the same angle as their attached conductor.  
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Query the Inventory equipment list. 

  

Add (Insert key) attachments to selected equipment. 

  

Note: When using the keyboard shortcut keys for Delete, Add and Substitute the Edit > Undo option can be 

used to undo any changes that have been made using these shortcut keys. 

Delete selected equipment.  Multiple pieces of identical equipment can be deleted simultaneously. Two 

other delete options are: the Delete key on the keyboard or the right-click Delete option. 

 

Substitute (Alt + Insert key) selected equipment.  Multiple pieces of identical equipment can be 
substituted simultaneously. 

  

Edit selected equipment attributes.  

 
 
Note: Multiple pieces of identical equipment can be selected for editing simultaneously using the Data Entry panel. 

After all items are selected, use the Shift-Click option in any column to highlight an entire row of data. When the 

blue box surrounds the object attributes (as shown below) any edit made in a single column affects the entire row 

of data. When the blue box is presented, you need only to type in a value. 

 

 



O-Calc® Pro 8.0                                                                                                  User Guide  

©2025 Osmose Utilities Services, Inc.                                                                                                  19  

Set Owners is used to assign equipment ownership. 

 

 
 

 

 

 

Bulk Set Owner is used to assign ownership to all the equipment. Enter the Owner name in the box that 

contains the <undefined> name and click OK. 

 

  
 

 
 

Propagate to Children applies the assigned Owner to only those child objects associated (attached to) the 

parent object. First enter the Owner name in the Data Entry, then click Propagate to Children. 
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Set Owner on Selected is used to assign ownership to a selected object only. 

  
 

Description is used to edit an object description, or to clear the selected or all descriptions.  

 

 

Filter to display only the expanded inventory objects in the 3D View.  

 

 
 

Note: The sunglasses icon in the upper right corner of the 3D View indicates a filter is active. 

  

 

To disable the Inventory toolbar menu icon text go to the Options menu and select Misc. Options, click 

on the Show Text and Images in Inventory Menu. This option is enabled (check mark present) by default 

so you can see the names of the menu items next to the menu icons. 
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New Pole Using This Pole as Template 

This option in O-Calc® Pro puts the user in editing mode on the 'new' pole without affecting the already 

saved PPLX file. It works like opening an existing PPLX and then doing a "Save Pole as..." task.  Or within 
Windows, making a copy of the existing PPLX file and opening the copied file. 

To create a new pole as template in the Inventory, complete these steps:  

1. Open a pole from an existing .pplx file that is like the pole you now want to 

model. 

2. Right click on the pole in the Inventory or the 3D View and select the New 

option, click on Pole Using This Pole as Template.  

  
 

Add New Version of Pole 

While working with a pole in the Inventory it may be beneficial to compare multiple pole versions for 

different scenarios.  O-Calc® Pro provides the ability to create multiple versions of a pole with in the same 

.pplx file for convenience and to produce Make Ready engineering reports. For example you may want an 

existing pole model and a proposed design model.    

To create a new version of an existing pole in the Inventory panel, complete these steps:  

1. Right-click on the pole in the Inventory, select New, Version of This Pole. 

  

 

2. The new version is displayed in the Inventory. 

 

Note: To remove the new version, select Edit > Undo.  
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The ‘New’ version automatically becomes the active version in the Inventory panel.  The active version is 

identified with the pole icon outlined in red and highlighted cyan to easily identify which pole’s loading 

results are being displayed in the Capacity panel.  The Data Entry panel always displays the currently 
selected pole attributes. When saving a pole, all versions of the pole will be saved.  

 
Note: When creating a new version of the existing pole any images that are associated 

with the existing pole will not be copied to the new version.  

 

 

To create a new version of a pole without any attachments, go to the Edit menu, select New Version, 

select the various pole type available.  

 

 

To add a new version of the pole from the Inventory window using the current pole in the 3D View, 
complete these steps:  

1. Right click the pole in the 3D View and select New > Version of This Pole.  

Note: The pole is automatically highlighted in yellow once selected. Undo is not available.  

  
 

Set Active Version   

To identify which pole is the “active” pole version, a red outline surrounds the pole icon in the Inventory 

along with the cyan blue background for the icon.  The O-Calc® Pro calculation engine automatically 

recalculates and updates to reflect the active versions loading results.  

To set which pole is the “active” version, complete these steps:  

1. Right-click on the pole in the Inventory and select the Set Active Version option. 
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2. The red ring and cyan highlighting is now on the active pole. The Data Entry panel 

always displays the currently selected pole. 

  

 

File Menu Overview 

Add a New Pole  

The O-Calc® Pro New Wood Pole submenus are dependent upon the corresponding structure types in 

your equipment catalog(s). To model a new Wood, Steel, Concrete, Composite or Segmented Fiberglass 

pole in the Inventory panel, complete these steps:  

1. Select the structure type from the File > New Pole > select the pole type Wood Pole. 
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Methods for Adding a Pole 

Add a new pole from any O-Calc® Pro Catalog to the Inventory using the ‘drag and drop’ method. Poles 

can be added to the Inventory using a Master or User Catalog. To add a pole using the drag and drop 

method, complete these steps:  

1. Expand the Poles folder and subfolders until the pole is displayed. 

  

2. Drag and drop the pole into the Inventory panel. 
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3. The pole is added to the Inventory panel.  

 

4. The Pole attributes are automatically displayed in the Data Entry panel.  

 

Note: Undo is not available when a pole is added. It is not possible to Delete a pole in the 

inventory. Use File > Close Pole to remove the pole. Or use the drag and drop method from a 

Catalog, to substitute for a different pole. 
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Equipment Catalog Types 

Master Catalog  Displays a list of folders that contain structure types which coincide with 

the new pole type that you have selected.  

User Catalog  Displays a list of folders that contain structure types which coincide with 

the new pole type that you have selected.  

Attr Values  Displays an editable list of all the attribute values for the selected poles. 

After a pole is added to the Inventory panel these same attributes are 

available to edit in the Data Entry panel.  

Standards  Provides a quick way to manually select the species, length, and class of 

the pole based on the ANSI 05.1 Standards.  

  

Standards Catalog for ANSI 05.1 

The Standards tab for wood pole types contains the full complement of wood poles according to ANSI 

05.1 Standards. This O-Calc® Pro catalog offers drop-down menus for the various categories: Code, 

Species Type, Pole length, Pole Class. 
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2. Select a pole from Master Catalog, User Catalog or the Standards tab.    

3. Select the Attr Values tab to modify the selected poles attribute values and click OK. 

  

Setting Depth of Pole 

The Depth (ft) value automatically displays the default pole set depth when initially opened. In O-Calc® 

Pro the poles are generally set using the common 10 percent plus 2 formula for pole set depths. Use the 

You can choose to move the pole and its attachments to a new set depth or just the pole, keeping the 

attachments at the same height above groundline. To set the depth of a pole, complete these steps:  

1. Right-click on the Pole, select the Set Length and Depth option. 

2. Click the Setting Depth of Unset (or Pole Number displays).  

  

3. In the Setting Depth window, select the Mode from the drop-down list and enter 
the Depth in Feet, and click OK. 
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Above Ground Length of Pole 

To set the length of a pole above the groundline, complete these steps:  

1. Right click on the Pole you want to set the length for.  

2. Select Set Length and Depth > Above Ground Length of Unset (Pole name).  

 

  

 

3. Select the Mode from the drop-down list and enter the AGL in Feet, click OK. 

  
 

Length of Pole 

If a wood pole is “topped” (a section at the top of the pole has been cut off) in the field, it’s important to 
model the original manufactured length of the pole since it is tapered. Only the length is changed 

circumference and taper remain unchanged. Set the length of a pole using these steps:  

1. Right click on the pole, select Set Length and Depth > Length of Unset (or Pole 

number displays).  
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2. Select the Mode from the drop-down list and enter the Length in Feet. OK.  

                       

 

 

Delete Equipment 

There are three ways to delete equipment attached to a pole in O-Calc® Pro: Use the delete key on your 

keyboard, the Delete button in the Inventory tool bar, or the right-click Delete option. To use the Delete 
button option, complete these steps:  

1. Select the equipment to be deleted in the Inventory or 3D View. 

2. Click the Delete button in the tool bar. 

 
3. To use the right-click option, right-click on the object to delete and select the Delete 

option. 

 

 
 

4. To use the Delete key on your keyboard option, select the object to delete and press 

the Delete key on the keyboard. 
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Rotating Insulators 

To rotate an insulator to be aligned to match a span angle that has been edited, complete these steps:  

1. Select the insulator you want to rotate.  

 

2. Right-click the insulator and select the Rotate to Span Angles option. The 
selected insulator is automatically rotated to match the angle of the conductor. To 

undo the rotation, select Edit > Undo. 

 
 

3. Only one can be rotated at a time. Repeat for the other insulators. 
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Edit Equipment Description  

To change the description that displays next to a pole or attached equipment’s icon in the Inventory 

panel, complete these steps:  

1. Right click on the equipment you want to change the display description of.   

2. Select Description of (pole or equipment display name).  

   

3. Enter the Description you would like to be displayed. Or click Clear to accept the 

Default Value description. Click OK. 
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Modify the Spans Default Rated Strength % 

When a span is added from the O-Calc® Pro Master Catalog where the tension mode is “Static”, a default 

percentage of a spans rated strength is used to calculate the span’s tension.  The default percentage for 

each type of span can be changed at any time. Tension values are not applied if the span is a 

subcomponent of complex assembly. 

The amount of tension used in Static mode is a “User Defined” setting, based on a percent of the wire 

manufacturer stated rated strength value. You’ll need to modify the settings to values common in the 

industry for electrical and communication wire tension. This is because the default tension values are 
set to the NESC maximum tension threshold of 60% which causes spans to turn red in O-Calc® Pro in 

the 3D View and the Inventory indicating they are in violation of overloading.  

See the example below of overloading the spans and the reaction in the Inventory intended to alert 

the user of the overloaded spans issue. 
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See the example below of overloading the spans and the reaction in the 3D View intended to alert the 

user of the overloaded spans issue. 

 

 

Users can choose from different tension modes in O-Calc® Pro. Static Tension mode is the most used 
tension type. This is due to it being difficult to obtain exact wire tension amount values unless you are 

perhaps the pole owner and know the tension values used at the time the wires were strung. 

Below are the default setting values in the O-Calc® Pro application for Static Tension mode as well as 

an example of commonly used Static Tension values based on the percentage of rated strength for the 

different wire types. 

 

Follow these steps to edit the percent of span rated strength for Static Tension mode: 

1. Go to the Options menu, select Misc. Options, click on the Percent of 

Span Rated Strength to Apply as Tension option. 

2. Click in each of the rows in the Percent column to enter the common 

static tension values shown below, or enter your own values, and click OK. 
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3. Select the Export button  to save the currently displayed set of percent of 

tensions value to a file. 

4. Select the Import button and browse to the location of the file to load a 
previously saved Percent of Tension set. 

 Note:  To revert the entire listing of span percentages of Rated Strength back to their default values select 

Restore Default Values. 

Note: The default percent of maximum span tension in Static Tension Mode to be applied to 

conductors when they are selected from the Master Catalog. 

 

Add Equipment to the Pole  

O-Calc® Pro requires a connection point for all equipment on the pole; these connection points 

facilitate the calculation results. Only the pole can be added to the Inventory by itself, any additional 

equipment must connect to the pole or its attached equipment. The dotted lines in the Inventory help 

to illustrate how the equipment is attached. Only one piece of equipment can be added at a time. 

Equipment can be added to the pole using any of these 4 methods:  

Default Static Tension Values Common Static Tension Values 
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• Drag and Drop from a Catalog 

• Add button in the Inventory tool bar 

• Right-clicking on an object in the Inventory or 3D View 

• Dragging any equipment from the Inventory or 3D View back to the pole or its attachments  

To add equipment to the pole using the Drag and Drop method from a Catalog, complete these steps:  

1. Expand (click the plus sign by the folder) the Master Catalog folders 

containing the equipment you want to add.  

2. Select the object, hold down the mouse button and drag and drop the 

selected equipment to the pole in the Inventory or 3D View panel. 

3. Use the Collapse button to quickly navigate back to the subfolders list. 

   

 

Note: While dragging the selected equipment to the Inventory panel the cursor changes to an 

invalid cursor .icon unless the equipment is placed over the pole, then the cursor changes to 

indicate a valid move . . To undo the equipment you’ve added, select Edit > Undo.  

 

• To add equipment to the pole using the Add button method complete these steps:  

1. Select the Pole you want to add equipment to. 
2. In the Inventory tool bar menu, select the Add button. 
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3. Select the Add Spans and Related menu option. 

 
4. Select any crossarm from the Catalog folders. 

              
Note: If the Divide Add Menu Items by Category option is unchecked in Misc Options, the resulting 

menu items appear (as shown below) when right-clicking on the pole. 
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 Note: If the Divide Add Menu Items by Category option is checked in Misc Options, the 

resulting menu items appear by category (as shown below) when right-clicking on the pole. 
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Equipment Menus 

 

 

 

 

 

 

 
 

Note: Available tabs are dependent on the corresponding equipment displayed in your catalogs or 

Inventory panel.  

 

When utilizing the right-click method to add equipment to the pole, a window appears containing an 

Attribute Values tab which allows you to make attribute modifications. The attribute values tab displays 

the all the information available in the Data Entry panel when selecting an object. 

To add equipment to the pole using the Right-Click method and any Catalog, complete these steps: 

1. Right-click on the pole, select the Crossarm category.  
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2.  In the example below we see the “Create New Crossarm” window 

containing the Attribute Values tab. Select the Attribute Values tab to modify 

any of the crossarm’s attributes prior to adding it to the pole. 

 

3. Make any attribute edits and click OK.  

Note: Attribute edits can be made at anytime for any object in the Inventory or 3D View. Simply 

select the object and see the attributes displayed in the Data Entry panel. 

 

Different types of equipment can have additional attachments (Example: A crossarm can have 

insulators and spans attached to it).  To add additional attachments to equipment, complete these 

steps:  

4. Select the equipment in the Inventory panel you want to add additional 

equipment on.  

5. Select the Add button and select the equipment to be added from the 

equipment list.  



[Type here] 

 

 40                   ©2025 Osmose Utilities Services, Inc.  

 

Note: The list of available equipment can also be accessed by-right clicking on the equipment you 

would like to add additional equipment to. When multiple pieces of equipment are displayed in 

the list only one piece of equipment can be selected at a time.   

 
 

Note: Available tabs are dependent on the corresponding equipment displayed in your catalogs or 

Inventory panel.  

6. To add an insulator from one of the catalog tabs or the Inventory tab 

select the appropriate tab and select the insulator you want to add, select 

OK.  

7. Select the Attribute Values tab to modify any attribute values click OK.  
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Pole Loading Regulations – Load Cases 

Pole loading regulations are applied to the pole/structure based on the location/scenario. 

Regulations include Ice, Wind, and Safety requirements necessary for accurate pole loading 

results. The load case is required for the O-Calc® Pro pole loading calculation to produce results. 

A load case can be pre-set as a default for each pole type from within the Load Cases folder or 

any location inside of a Catalog (.pplc) file.  

To add a Load Case(s) to the pole in the Inventory panel using the Load Cases folder in the 

Master Catalog, complete these steps:  

1. Expand the Catalog Load Cases folder to display the regulations you need.  

 

2. Select the Load Case to be added to the pole and drag and drop it to the pole in the 

Inventory or 3D View panel. To undo the Load Case you added, select Edit > Undo. 

 

Note: When using the drag and drop method to add equipment to the Inventory panel the cursor 

changes to the invalid  cursor icon when the equipment is dragged over the white space in the 

Inventory. Once the cursor is dragged over the pole in the Inventory panel, the cursor changes to a 

plus sign indicating the ability to add the object . to the pole. 
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Setting a Default Load Case 

Default load cases can be set for each pole type: Wood, Multi-Pole, Metal, Concrete, Composite, 

Segmented. Defaults are set up one at a time. 

With the load cases folder open follow these steps using the “Set as the default Load Case” 

command to set up a default load case for all wood poles. 

1. Right-click on the desired load case in the Catalog, select the Set as the 

default Load Case option, click Wood Pole. 

 

 

2. View the confirmation message and click OK. 

 

 
 

3. Repeat the above steps to set a default load case for as many pole types as 

you need. 
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Removing a Default Load Case 

A default Load Case can be set for each Load Case category.  In addition, one extra Load Case is 

allowed to be set. This extra Load Case is the “Other” Load Case. Any Load Case set as the 

default can be changed or deleted at any time in Tools > Load Case > Defaults. Once a default 

load case is set it can be removed. Follow these steps: 

1. Go to the Tools menu, select the Load Case option, click on Defaults. 

 

2. Check the box in the Remove default column for any default load cases you 

need to remove. 

3. Click the Remove Selected Default Load cases button. 

 

Working with Sealed Load Cases 
  

The O-Calc® Pro Load Case element contains the environmental and convention parameters required to 
codify such things as the standards body being used, the local wind and ice conditions, overload factors 

to be applied in different conditions, and to different element types, etc.  Arguably the Load Case is the 
most critical element in O-Calc® Pro, and the one that must be controlled and manipulated with the most 

care, and by the most qualified personnel.  For this reason, O-Calc® Pro adds an extra layer of protection 

to Load Case elements referred to as Load Case Sealing.  

O-Calc® Pro provides a set of sealed Load Cases pre-shipped in the Master Catalog that contain the 

correct parameters for all commonly encountered NESC and GO95 conditions, including extreme wind 
and extreme load.  These Load Cases cannot be modified by any user regardless of their user level.  They 

are “Sealed” against modification.  
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A user of “Normal” or higher level can unseal a COPY of a sealed Load Case and make modifications to 

that copy.  The resulting custom Load Case can be placed in the User Catalog for future use or 
modification.  

A user of “Administrative” level can additionally re-seal a Load Case and place the newly sealed Load Case 
back into the Master Catalog for use by any other user(s).  Such a user may also re-seal a Load Case that 

is in the Catalog in an unsealed form.  

The remainder of this section details the steps involved in unsealing or re-sealing Load Cases.  

Unsealing a Load Case  

To unseal a Load Case in the O-Calc® Pro Inventory panel for modifications, complete the following steps:   

Note: Load Cases should only be unsealed and modified with extreme caution.  Modifying Load Case 

attributes will affect O-Calc® Pro calculations. Load Cases cannot be unsealed in the Master Catalog.   

1. Right click on the Load Case to be unsealed in the Inventory panel and select 
Unseal this Load Case.  

  

2. Select Yes to the confirmation message. 

3. The load case was displaying the sealed load case icon color of Blue, but now 
that it is unsealed, the icon color is changed to Red. 
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4. In the Data Entry the Load Case displays with the Name attribute User Defined 

Load Case. 

Note: To undo the unsealing of the Load Case, select Edit > Undo.  

5. Select File > Save.  

Once the Load Case is unsealed you can modify the Load Case attributes using the Edit option in the 

Inventory menu or in the Data Entry panel.   

If you need to use the unsealed Load Case for future use or modifications copy the Load Case to a specific 

User Catalog folder.  To copy the unsealed Load Case to a User Catalog folder, click on the Load Case in 

the Inventory Window and drag it to a specific User Catalog folder.  

Re-Sealing a Load Case   

Only users with Administrative privileges in O-Calc® Pro can re-seal an unsealed Load Case. To re-seal and 

prevent additional modification to the Load Case, complete these steps:   

1. Switch your User Level from Normal to Administrative in tool bar menu below 
the Capacity panel. You may not have this user privilege. 

2. Right click on the Load Case to be re-sealed in the Inventory Window and 
select Reseal this Load Case.  

3. Select File > Save.  

Working with Pole Substitutions 

To substitute a pole is to replace the one currently in the Inventory and 3D View with a 

different one. Poles cannot be deleted in the Inventory or Data Entry panels. You can remove a 

pole from the Inventory only by closing the .pplx file. To “substitute” a pole or its equipment in 

O-Calc® Pro you are offered a few different methods, as described below.  

• Manually  - From any Catalog drag and drop a pole over the top of the current pole in 

the Inventory or 3D View.  

• Right Click  - By right-clicking on a pole or its equipment in the Inventory or 3D View 
you can select the Substitute option from the menu options displayed. 

• Catalog  - Select the pole and click the Substitute button in the Inventory tool bar to 
select a pole from any of the Catalog options displayed.   
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• Use Pole Solver  - Select the pole and click the Substitute button. In the Substitute 

Wood Pole window, click the Use Pole Solver button. A pole is instantly selected that 

meets the minimum pole class requirements for the current pole model along with the 

estimated capacity results. 

To substitute the current pole using the Substitute button method, complete these steps:  

1. Select the pole in the Inventory or 3D View and click the Substitute button in the Inventory 
tool bar menu. You must first select the pole or the option to substitute is greyed out. 

 
2. Select a pole from any Catalog (Master, User, Standards) displayed in the Substitute Wood 

Pole window, the estimated capacity is automatically displayed, click OK. 

 

Note: The Substitute option can also be accessed by right clicking on the pole and selecting the 

Substitute (Pole’s display name) button. 

 

Height Adjustments 

Height adjustments can be made for the pole or the attached equipment. When a pole is 

substituted (changed out/replaced) and it has equipment attached, the Height Adjustments 

window automatically displays with options to adjust the new poles depth and the height of 
any attachments.  

Attachments can be adjusted relative to the poles tip or groundline, the choices are: Maintain 
Distance from Tip (the default) and Maintain Height from Ground.  
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To make height and setting depth adjustments complete these steps:  

1.  Perform a pole Substitution operation (shown above) on a pole that already has 

equipment attached. 

2. In the Height Adjustments window modify the Pole Setting Depth (ft) as needed. 

3. Select from each Maintain Distance from Tip (default) drop-down menu to change 

current attachment heights or click the All Tip Relative or All GL Relative button, click 
OK. 

Note: To undo the substitution change, select Edit > Undo. 

 

Standards Catalog 

To substitute the current pole using the Standards Catalog tab, complete these steps:  

1. Select a pole from the Standards tab in the Substitute Wood Pole window. Use the drop-

down menus to select a pole, the Estimated Capacity is automatically displayed, click OK. 
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Using the Pole Solver  

To substitute the current pole using the Use Pole Solver button, complete these steps:  

4. Select the current pole in the Inventory, click the Substitute button.  

5. Click the Use Pole Solver button, click OK. 
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Substituting Equipment 

To replace equipment attached to the pole in the Inventory using the Substitute button, complete these 
steps:  

1. Select the equipment to be substituted in the Inventory or 3D View. 

2. Click the Substitute button in the tool bar. 

 
Note: Multiple pieces of equipment can be substituted concurrently if they are all the same type of 

equipment.  Hold down the Ctrl key to select more than one piece of equipment at random within 

the Inventory list. 

 

3. The substitute window appears with various Catalog options to choose from. 

 

4. To use the right-click option, right-click on the object in the Inventory or 3D View 

window and select the Substitute option from the list.  
  

   

 Note: Available tabs are dependent on the corresponding equipment displayed in your catalogs or Inventory 

window. To undo the substitution change, select Edit > Undo. 
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5. To substitute equipment from the Catalogs or the Inventory tab, select the 

appropriate tab in the Substitute window and select the equipment you want to use 
as a substitution.   

6. Select the Attribute values tab to modify the equipment’s attributes.  

    
 

Working with Equipment Catalogs 
The Catalog panel provides the ability to efficiently assemble a pole and its equipment in the 

Inventory panel from ready made parts.  The Master Catalog contains a list of common poles, 

assemblies and equipment that are commonly constructed in the field. It also contains a 

complete listing of all the available Load Cases which are used to add the applicable pole loading 

regulations to the pole to apply the correct amount of wind, ice, and safety factors. The User 

Catalog contains your own storehouse of poles and equipment for you to use again in the future. 

  

  
  

Note: Edits can only be made in the Master Catalog (has blue folders) by an Administrative User User 

Catalog (has yellow folders) are available to edit at will. To make changes in the Load Case folder, the 

load case must be unsealed and cannot be resealed. Sealed load cases display a blue icon. Unsealed 

load cases display a red icon. 
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Catalog Menu   

The Catalog panel toolbar provides a variety of menu options.  

  

Collapse  Use to collapse all the objects in the current Catalog panel.  
New Pole  Use to create a new pole in the Inventory panel from the selected 

catalog.  
Preview  Use to view a pole or pole template in the Inventory panel from the 

Master or User Catalog.  
Query  Use to search for the data within the current catalog.  

Add  Use to add a sub folder to a User Catalog folder.  

Remove  Use to remove a selected folder or object within the User Catalog.  
 

Query the Catalog 

Perform a query within any Master or User Catalog to quickly locate equipment. Running a query 

performs a search through all folders in the catalog and highlights them found item(s) in blue. 

To use the Query complete these steps: 

1. From the Catalog panel, click the Query button in the menu tool bar. 

 

2. In the Select Catalog Query window enter the information for the query using the 

drop-down menus and click the Run button. 

 

3. View the highlighted items found in the Catalog. 
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4. Select any highlighted item and drag and drop it to the pole in the Inventory or 3D 
View.  

Note: Upon clicking the Query button the information from the last query is retained, until the User 

navigates away from the Query tool, at which time the query is cleared of any past information. 

 

Attribute Values 

Each piece of equipment in Master Catalog includes a unique set of attribute values. These values are 
used to define an object in detail and identify any manufacturer specifications which may be considered 

relevant to pole loading calculation results. Each attribute available for editing have white input fields, 

those which cannot be edited are greyed out. To edit equipment attribute(s), complete these steps:  

1. Select the equipment whose attribute you want to edit. 

 

 
 

2. Select the Edit button.  

Note: The Edit option can also be accessed by right-clicking on the equipment whose 

attributes need to be edited and selecting Edit (Pole or equipment display name). 

 

 Note: By selecting an object in the Inventory or 3D View areas, attributes can be easily 

edited in Data Entry panel. 
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Edit Icon Descriptions 

 Edit Icon  Description  

  Use to select a value or extend the default list.  

  Use to change the vertical value based on mouse movement.  

  Use to increase or decrease the rotation value based on 

mouse movement.  

  Use to select a value from a predefined list.  

  Use to increase or decrease the value.  

  Use to toggle the value to Yes or No.  

  

Other Editable Icons that are available when different attachments are selected:  

Editable 

Icon  

Description  

  Allows you to change the horizontal value based on mouse 

movement.  

  Found within a Note attachment.  When selected a calendar 

option is enabled, allowing you to select a specific date for a 

selected attribute.  

  Found within a Note attachment.  When selected the selected 

Note is displayed in edit mode.  

  Allows you to select the color.  

  Allows you to open a table and change values within the table. 
(Example: When a pole’s Moment Cap  

attribute table icon is selected it provides a table allowing you to 

change the values of the Moment Capacity vs. Height)  
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Working in Top View 
The O-Calc® Pro Top View panel displays a polar (North/South orientation) view of the pole with span 

angles. Changing the Gang Editor “G” icon or the Line of Lead can automatically change all the spans.    

         

  

  

Top View Icon Descriptions 

The Top View provides a variety of operations and options.  

Functionality Icons  Description  

  
Zoom-Out.  Click the plus sign icon to zoom the display out.  

Zoom-In. Click the minus sign icon to zoom the display in.  

  
Gang Editor.  Click the “G” button to set of spans in a single direction 

to edit. This also automatically select all the spans in the given 

direction.  

  
3D Compass.  Click the “C” button to cause the Top View panel and 

the 3D View panel to track in concert with one another.  The 

permanently enable simply check the 3D Compass box.  

  
Reset.  Check the Reset option to undo any display options that were 
selected.   

Note: This does not undo any changes completed in the Ganged Geometry 

Editor or to the Line of Lead.  
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  Line of Lead.  Click the Line of Lead option to change the line of lead 

by rotating the entire pole.  

  Angle Filter. Click and drag the Angle Filter button to set the area to 

be filtered.  

  Position the Angle Filter. Click and drag the Position Angle Filter 

button to reposition the Angle Filter.  

 

Zoom Level  

To change the zoom level in the Top View display, which is helpful in expanding/contracting the space 

between the “G” buttons, complete the following steps:  

1. Click the Zoom In button  to zoom in the view of the spans.  Click the Zoom 

Out button  to zoom out the view of the spans.   

Note: To remove the zoomed display level select the Reset button .  

Gang Editor “G” 

To edit the attributes for set of spans in a single direction, complete these steps in the Top View panel for 

the spans you want to edit. 

1. Select one of the “G” icons in the Top View. 

  .    

2. In the Gang Editor window, use the default Absolute Mode, or select the 

Relative mode option from the drop-down list.  
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3. Modify the Angle, Span Length, End Drop value.  

4. Modify the Rotate All option by changing the No radio button to Yes and enter a 
value in the Angle attribute or select the “+” sign at the center of Top View and 

input a LOL value. 

  

5. Click OK. Resulting in the entire structure being rotated to reflect the new Line 

Of Lead (LOL) value entered.  
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6. Click the Lat Lon button for a shortcut to the Geolocation information for the 

pole. 

  

Note:  To undo the Gang Editor change, select Edit > Undo.   

 

  

7. Enter the Latitude and Longitude information and click OK.  

 

Top View Display 
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Click the “C” button to cause the Top View panel and the 3D View panel to track in concert with one 

another.  The permanently enable tracking, simply check the box next to the “C” button. Complete these 
steps:  

1. Click the “C” button, the LOL is automatically rotated to match the 3D View. 

   

Reset Top View Display   

To undo any changes to the Top View display, complete these steps:  

1. Click the “R” button to Reset the LOL (Line Of Lead). 

 

Note: Resetting the Top View display does not undo any changes that have been completed in the 

Gang Editor or Line of Lead. 
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Line of Lead      

To change the line of lead, complete these steps:   

  

2. Enter a value for the Angle which will rotate the entire pole. Click OK. 

  
 

Angle Filters   

When working with a pole that has numerous spans attached at different angles, it may be beneficial to 

narrow the scope of the data displayed.  The Angle Filter allows you to set a filter so that only spans in a 

specific area are displayed.  

 

Using the red and purple buttons complete these steps:   

 
1. Complete the following steps to enable the Angle Filter, select Options > 

Options in 3D View > Angle Filtering.  
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2. Click and drag the purple Angle Filter icon to set the position of the filter. Blue 
background area will be filtered. 

 

 

3. Click and drag the red Position the Angle Filter icon to set the amount of area to 

be filtered. The grey background area will not be filtered. 

 
 

4. To reset the filter area click the “R” button.  
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5. Click the “Sunglasses” icon in the 3D View panel to remove all filters. 

 

End/Drop Rise 

To modify the drop or rise of span(s) on an adjacent pole, complete these steps:  

1. Click one of the “G” buttons in Top View.  

2. In the Gang Editor window End Drop/Rise (Ft) attribute, enter a value 

proceeded by a minus sign “-“ to make the spans Drop down at the adjacent 

pole. Without the minus sign the value is a Rise value. 

  
 

Working with Guying 
Stub Poles for Span Guys 

While working with a pole in O-Calc® Pro that has a span/head guy going to a stub pole 

attachment it is often the case that you may want to perform analysis on the stub pole as well.  O-

Calc® Pro provides a convenient method to perform stub pole analysis.  You can either create the 
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stub pole as a completely new pole analysis, or you can create the new pole as a version within 

the same pole analysis.  

Keep in mind interchangeable terms commonly used for the Stub Pole object are Stub Pole for 
Span Guy; Span/Head Termination; Anchor. Terms commonly used for the Span/Head Guy object 

are Guy Brace; Span/Head; Guy Wire; Span Guy. 

Stub Pole as a New Pole  

This functionality creates a separate .pplx pole file for the New Stub Pole which will be 
automatically guyed using the same guying used on the current Stub pole.  

Begin with a pole that already has a Stub Pole for Span Guy (see Catalog Assemblies > Guy and 
Anchor Assemblies folder) attached to the pole. To add a stub pole as a new pole within the 

Inventory panel, complete these steps:  

1. Left click to select the pole you would like to use as the Stub Pole for Span 

Guy pole in the Inventory.  

2. With the stub pole now selected, right-click on the stub pole and select 

the Stub Pole as New Pole option. 

 
 

3. Select a pole from the pole menus or select the Copy Current Pole option. 
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4. The New Stub Pole is guyed automatically, if a default Auto-guy assembly has 
been set.  

 
 

Note: Undo is not available for this operation. To disable the automatic guying of the new 

stub pole, see the Create as New Pole Enabled option below. 

 

Stub Pole as Version 

A stub pole version can also be added by right-clicking on the Span/Head Termination and selecting the 

Stub Pole as Version option. To add a stub pole as a version to the Inventory within the same .pplx file 

complete these steps:  

1. Left click to select the pole you would like to use to create a new version. 

 

2. With the stub pole now selected, right-click on the stub pole and select 
the Stub Pole as Version option. 
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3. Select a pole from the pole menus or select the Copy Current Pole option. 

 
 

4. The added Stub Pole Version is guyed automatically, if a default Auto-guy 

assembly has been set.  

    
Note: While dragging the selected pole to the Inventory panel the cursor will change to an invalid cursor  

 .  As the equipment is placed over the Span/Head Termination object in the Inventory panel the 

cursor will change to indicate a valid move .  

 

Stub Pole Menu Options  

While performing an O-Calc® Pro analysis on stub poles several options are automatically enabled.  O-

Calc ® Pro allows you to adjust which of these options you would like enabled or disabled.   
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Enabling Stub Pole Options 

At least one of the Stub Pole “Create” options needs to be enabled. When the’ Create as New Pole’ 
option is enabled a check mark will display next to the menu option.  When the option is disabled no 

check mark displays. To enable/disable complete these steps:   

1. Go to the Options menu, select Misc. Options, select Stub Pole Options, click the 

Create as New Pole, Create as Version, Auto Guy Stub Pole options to enable 

them.   

 

 

Communication Span Bundles 

A communication span bundle typically includes a messenger strand with additional 

communication wires lashed to it, attached to the pole by a bolt (insulator) object. A cross-

sectional configuration of the lashing is visible within the Bundle Editor option. The Span 

Bundle object represents the messenger strand as the object under tension. Bundles can be 
pre-assembled, to easily add to the pole, or they can be custom made (built from scratch) at 

any time. To add a span bundle to an attached insulator you first need to add the insulator, 
then the messenger wire.  To create a span bundle, complete these steps:  

1. With the pole selected, click the Add button in the Inventory panel, select the 

Add Spans and Related option, click the Insulator option. 
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2. From the Create New Insulator window, go to the Comm. Connectors folder 

and select the Three Bolt, click OK. 

 

3. In the Data Entry panel, enter the Install Height for the Insulator. 

 

  

4. Right-click on the Three Bolt and select Add Spans and Related > Span Bundle. 

5. Add the Messenger strand of your choice from the Catalog, click OK. 
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Once the messenger strand has been added you need to add the spans.  Complete these steps to add 

spans to the messenger:  

6. Right-click the Messenger strand in the Inventory, select Add Spans and Related, click 

on the Span option. 

 

7. Expand the Generic Communication folder, expand the CATV folder, click on the CATV 

.50 option, click OK. To add additional spans repeat the steps above or drag and drop 

the span to the messenger in the Inventory panel. 
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Note: Only one Span can be added at a time.  

   

Working with the Bundle Editor  
Use the Bundle Editor to edit the spans positions quickly and efficiently or to add additional spans 

to a span bundle.  The diameter value for a communication bundle is displayed in the description 

information of the messenger wire.  To open the Span Bundle Editor, complete these steps:  

1. Right click on the Messenger strand you want to edit.  

2. Select Bundle Editor for (bundle display name) option. 
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File. The following options are 
available from the File menu:  

Reset View. Select the Reset View 
option to set the Span Bundle editor 
back to the default view.  

Save.  Select the Save option to  

save any changes or additions. This 

is a test   

 Exit. Select the Exit option to close 

the Span Bundle Editor.  

  

Edit. The following options are 
available from the Edit menu:  

Add Span.  Select the Add Span 
option to add a span to the span 
bundle.  

Layout Vertical. Select the Layout 
Vertical option to automatically 
reposition all the spans vertically 
under the messenger wire.  

Layout Pack Under. Select the 
Layout Pack Under option to 
automatically reposition all the 
spans under the messenger wire.  

Layout Pack Around. Select the 
Layout Pack Around option to 
automatically reposition all the 
spans around the messenger wire.  

Auto Pack. Select the Auto Pack 
option to have the spans packed as 
close as possible given their size and 
layout.  

Un-Collide.  Select the Un-Collide 
option to position the spans so they 
are not overlaid.  

Dynamic Un-Collide.  Select the 

Dynamic Un-Collide option to 

automatically un-collide the spans 

while you’re dragging them into 

position.  
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Span Bundle Editor Toolbar 

The Bundle Editor toolbar menu provides you with a variety of operations and options.  

  

 

 

   

  
Circumscribe. Selecting the 

Circumscribe option tells you what 

the minimum circle would be that 

all the spans and messenger wire 

could fit into.  

  
Show Labels. Select the Show Labels 

option to display the spans 

descriptions next to each span in 

the bundle.  
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Add a Span  

To add a span to the Span Bundle using the Span Bundle Editor, complete these steps:  

1. Open the Edit dropdown menu and click the Add Span option. 

  
2. In the Create New Span window add a span from the Master Catalog or the User 

Catalog select the appropriate tab and select the span you want to add. 

  

Note: Only one span can be added at a time. Available tabs are dependent on corresponding spans 

displayed in your catalogs or Inventory panel. 
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3. Select the Attribute Values tab to modify any Span attributes.  

4. Select OK, then File > Save. 

Note: The span is automatically added to the span bundle and is displayed in the Span Bundle Editor. There 

is no Undo option available.   

Span Bundle Layout 

The Bundle Editor offers three layouts to reposition how the spans are configured within the 

bundle: Layout Vertical, Layout Pack Uder, Layout Pack Around.  

The bundle layout can affect the overall diameter of the bundle. To change the Span Layout in the 

Span Bundle Editor use one of the following options:  

1. In the Span Bundle Editor window, open the Edit menu, select Layout Pack Under.  

2. Results appear in the Bundle Editor. The Min Diam (in) has an overall diameter. 
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Edit Spans  

To edit span attributes from within the Span Bundle Editor, complete these steps:  

1. Right click on the span, select the Edit Span option. 

2. Select Edit Span from the drop-down menu.  

  

3. In the Edit window, enter changes to the Span Bundle attributes, click OK.  

  
Note: There is no Undo option available. 

4. Select File > Save. 

  

Delete Spans 

To delete a span within the Span Bundle Editor, complete these steps:  

1. Right click on the span in the Span Bundle Display window.  

2. Select Delete Span from the drop-down menu.  
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3. Select Yes to the confirmation message: Do you really want to delete the span?  

Note: There is no Undo option available.  

4. Select File > Save. 

   

 

Understanding Wire Tension 
O-Calc® Pro considers the change in conductor length (elongation) based on several physical parameters 

such as temperature changes, ice build-up on the conductors, and horizontal wind pressure blowing on 

the wires. This change in conductor length affects the tension of the conductor, which in turn affects the 
amount of sag. How O-Calc® Pro handles these various environmental effects on the conductor depends 

on what tension ‘mode’ the conductor is in. 

O-Calc® Pro has seven different mode options for calculating the tension and sags on each cable: 

 

Sag Table 

Means that the tension is calculated based on the measured sag (height difference between attachment 
height on the pole and span height AGL (Above Ground Level), cable weight, and loading (temperature, 
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wind, and/or ice) on the cable; span sag in inches is plotted against span length in feet. This method 

enables users to model “sag to tension” mode for various span lengths. 

Sag to Tension 

It is where the user selects the initial (unloaded) mid-span sag amount, and the program determines the 

final (loaded) tension and final mid-span sag of the cable.  This method is typically used when the mid-

span sags are being measured in the field at a nominal temperature. 

Slack 

Is the same as “Static” mode. Users can enter any value for slack tension, then easily change between 

static and slack mode. Note, despite the name “Slack” any tension value can be entered, including a value 

larger than the “Static Tension” value. 

Static 

Means that the tensions are statically determined based on a user defined percentage of the related 
strength of the cable.  O-Calc® Pro has an option that enables the user to set the static tension 

percentages based on the cable type. 

Table 

This means that the tensions are determined by a user-created graph, wherein tension in pounds is 

plotted against span length in feet. The user can determine the number of points in the graph, as well as 
the tension to be applied at each increment of span length. The tensions between any two points on the 

graph are linearly interpolated between the values on the graph. O-Calc® Pro will then apply a static 

tension value as determined by the span length and table values. 

Tens to Sag Table 

It means that the tensions are determined by a user-created graph, wherein the initial tension in pounds 
is plotted against span length in feet. The user can determine the number of points in the graph, as well as 

the tension to be applied at each increment of span length, like Table mode. However instead of 

calculating a single static tension, various initial (unloaded) tensions are calculated against environmental 

loading parameters to determine the final mid-span sag of the cable. The final tension value is derived 

from the final mid-span sags along with cable weight and loading (temperature, wind, and/or ice) on the 

cable. 

Tension to Sag 

It is where the user selects the initial (unloaded) tension on the cable and the program determines the 
mid-span final loaded tension and sag based on the cable length, tension, and loading parameters.  This 

method when they know what the original stringing tensions were. 

 

To access all the wire tension types complete these steps: 

1. Select any conductor or messenger strand (wire under tension) attached to 

the pole in the Inventory or the 3D View. 

 
2. In the Data Entry, change the Span filter drop-down to Tension Sag. 



[Type here] 

 

 76                   ©2025 Osmose Utilities Services, Inc.  

 
 

3. Open the Tension Type attribute drop-down to view and/or select any wire 

tension type. The default tension in O-Calc® Pro is Static tension. 

 
 

4. The seven different tension types are displayed. 
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Wire Tension Categories 

Wire tension type is relevant to the amount of sag results for conductors and communication messenger 
strands (the wire under tension) which can affect clearance analysis. To explore the tension types further 

it is helpful to note they fall into these three tension mode categories: Static, Table, and User.  

Tension type is dependent upon how the pole owner wants wire tension to be accounted for. For 

example, Static type is commonly used with a set Slack percentage value in the Catalog.  Table Tension 

mode is the second most common, it does require setting up. Sag to Tension mode is less common, it 
requires the Span Sag in feet value to be entered. 

Pole owners can exceed code requirements, which are minimum pole loading requirements. Pole owners 
may have tension or sag tables which offer a closer estimate of actual field tension. 

Listed below are the tension type modes by category available in O-Calc® Pro: 

Static Mode 

Slack 

Static 

Table 

Slack mode is based on User defined settings or as set in the 

Master Catalog. 

Static mode is based on User defined settings. 

Table is based on User defined input at various length 

increments per wire type. 

Table Mode 

Tens to Sag Table 

Sag Table 

Tens to Sag Table mode is based on User supplied table and 
the load case. 

Sag Table mode is based on the amount of sag at a given 

length, wire weight, and the load case. 

Both are based on the nominal values and the load case. 

User Mode 

Sag to Tension 

Tension to Sag 

Sag to Tension mode is used when the User measures the mid-

span sag amount at nominal temperature. 

Tension to Sag mode is used when the User knows what the 

original (initial tension at the time of installation) stringing 

tension value is/was. 

 

Creating Table Tension 

To create a custom table with tension values for a specified span length, complete the following:   

1. Select the span for which you are creating a custom tension table.   

2. In the Data Entry panel, change the filter to Tension Sag.   
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3. Under the Tension Type attribute, change the type to Table. 

 
 

4. Under the Table Tension attribute, click the radio button. 
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5. In the Span Tension vs Length window, the graph displays the outcome of the 

entered information. Namely span length (ft) and tension (lbs) values which 
are associated with an applied tension at a specified lengths along the span. 

   

5. Use the Value menu to Add or Remove values. Additionally, values can be Sorted, 

Exported for use by other users or Imported from another source.  

   

6. Once a list of lengths is created and the tension values are entered, the table can 
be saved using the File > Save option. 

Note: Tension tables must be saved each time they are adjusted to apply changes in tension. 
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Edit Menu Overview 

The Edit menu offer a variety of tools to efficiently assign equipment ownership, add images for use with 

the Digital Measurement Technology (DMT) and add Geolocation (GIS) coordinates for each pole and 

more. Complete the steps below to explore these features.  

 

Bulk Updated Owners 

The O-Calc® Pro Bulk Updated Owners feature allows for streamlined ownership assignments. You only 
need to assign ownership to the parent objects on the pole, see the tree control in the Inventory panel. 

Once the parent objects within each assembly have a designated owner, all the child objects inherit the 

parent ownership. Options are available to set the owners for a selected (only one) pole or an entire line 

design of poles. To set owners for the selected pole, complete these steps:  

1. Select the parent objects (first object of an assembly) in the Inventory. 

 



O-Calc® Pro 8.0                                                                                                  User Guide  

©2025 Osmose Utilities Services, Inc.                                                                                                  81  

2. In the Data Entry panel enter the name of the Owner. Once an owner’s name 

is entered, it becomes an available choice within the drop down list. 

 

 

 

3. Go to the Edit menu, click on the Bulk Updated Owners option. 

 
 

4. In the Bulk Updated Owners window, the default selection is the Set Owners 
for Selected Poles option, click OK. 

 
 

5. In the Bulk Updated Owners window, select Yes. 

 
6. When all the Owners are defined, the Bulk Updated Owners window displays 

the results. Use the Export button to export the results to a .csv file.  
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7. Click the “X” in the upper right corner to Close the window. 

 

Element 

Each menu option displayed for editing corresponds to the element you select. The first step is to select 

an element in the Inventory or 3D View panels. To view all elements, complete these steps:  

1. Select an element in the Inventory or 3D View panel. 

 
 

2. Select the Edit menu, click the Element option. 

  
3. The menu appears with all the options available for editing. 
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4. Select any element to edit within the list.  

 

Set Height 

To use the Set Height feature for an object on the pole, complete these steps:  

1. In the Inventory or 3D View select the piece of equipment attached to the pole you 

want to set the height for. 

 
 

2. Select the Edit menu and click the Set Height attribute. 

 
 

3. Select the Set at default option or select the Edit Height option. 
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4.  Enter the Height (ft) above groundline (GL), click OK. 

 
 

Relative Height 

To use the Relative Height feature for an object on the pole, complete these steps:  

 

1. Select the object to set the relative height for on the pole. 

2. Select the Edit menu, click the Relative Height option.  

   
  

3. The Set Height window offers these parameters, make edits as needed, click OK. 

a. Set - choose what part of the object to set at the relative height, the Center, 

Top, or Bottom of the object 

b. At - enter the value for the offset 

c. Relative to- choose the height or offset relative to; Groundline, Tip of Pole, Top 

Power, Bottom Power, Top Comm, Bottom Comm 

d. Saved settings- users can save the settings by entering a name to be used again 
in the future 
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Reference Origin 

Use this tool to set an object as a reference point in relationship to another object at the pole. 

Reference origins can be set at pole elevations or angles around the pole.  

When setting the Origin Elevation option, the reference object is highlighted yellow. Orange 

colored chevron markers are added around the reference object along with the height above 

groundline value, for elevation reference. 

Set Origin Elevation 

To use the Set Origin Elevation tool for a crossarm attached to a pole complete these steps:  

1. First select the crossarm you want to use as the reference origin. 

2. Select Edit > Reference Origin >  Set Origin Elevation. 

 

  

3. To clear a reference origin select the Clear Origin Elevation option from 

the Edit > Refence Origin menu. 

 

 

Set Origin Angle 

When setting the Origin Angle option, the reference object is highlighted yellow. An orange 

arrow is displayed at the ground line compass in the 3-D view to specify the location of the 

angle reference around the pole. You are required to input the angle value. 
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To us the Set Origin Angle tool for the pole complete these steps:  

1. First select the pole, then select Edit > Reference Origin > Set Origin 

Angle. 

 

2. In the Edit window input the angle value needed, click OK. 

 

4. The orange arrow is displayed at the groundline at the angle specified. 

 

3. To clear a reference origin select the Clear Origin Angle option from the 

Edit > Refence Origin menu. 
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Pole Images  

Select Images 

To select the image needed to complete measurements, complete these steps:  

1. Select Edit > Pole Images > Select Images.  

2. Select the image path by clicking the ellipsis button and browse to the location 
of images for the current pole. 

3. In the Select Folder window, select the folder that contains the images you 
want. Click the Select Folder button, the images will load in the Select Pole 

Images window.   

  

4. Select the images to be associated with the current pole. Click OK.  

 

Note: Hold down the ctrl key to select more than one image out of sequence.  Hold down the shift 

key to select a range of images that are next to each other. 

 

Add Images 

More images can be added to the current pole at any time. To select additional images to be added after 

the initial images are already in the Measure panel,  complete these steps:  

1. Select Edit > Pole Images > Add Images. 

  

2. Select additional images from the current Path or click the Ellipsis button to 
browse to a new location for images and click the Select Folder button.  

3. In the Select Pole Images window, select the images you want, click OK. 
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Paste Snapshot as Image  

Images can be embedded with the .pplx file or can be standalone files. You can paste images into the 
Measure panel as snapshots and save them as standalone files. To paste a snapshot as an image, 

complete these steps:  

1. Take a snapshot of an image and paste it to the clipboard; this can be done 

using a snipping or screen capture tool.  

2. Select the Edit menu, select Pole Images > Paste Snapshot as Image 

3. Select the Set Date and Paste option to save the images with a date stamp. 

 

4. Browse to the file location, select it and then enter the date in the Edit window. 

Click the radio button to utilize the calendar option. 

 

5. Click OK.  The image becomes available to use in the Measure panel. 

Add Image URL  

To add an image URL (Universal Resource Identifier), complete these steps:  

1. Select the Edit menu, select Pole Images > Add Image URL 

 
 

2. Optional: Select the Test button to test that the URL was entered correctly.  

3. In the Universal Resource Identifier window, enter the URI address, click OK.  
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Remove Images 

To remove all the images that are displayed in the Measure panel for the current pole, complete these 
steps:  

1. Select Edit > Pole Images > Remove All Images.  

  

2. Select Yes to the confirmation message. To undo select Edit > Undo.  

  
  

Remove Current Image  

To remove the current image that is displayed in the Measure panel for the current pole, complete these 

steps:  

1. Select Edit > Pole Images > Remove Current Image.  

 

2. Select Yes to the confirmation message.  

Remove All Except Current Image  

To remove all the images except for the currently selected image that is displayed in the Measure panel, 

complete these steps:  

1. Select Edit > Pole Images > Remove All Except Current Image. 

    

2. Select Yes to the confirmation message.  
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Print Current Image 

To print the currently displayed image in the Measure panel as a .pdf, complete these steps:  

1. Select Edit > Pole Images > Print Current Image. 

  
 

Print All Images 

To print all the images that are displayed in the Measure panel as a .pdf, complete these steps:   

1. Select Edit > Pole Images > Print All Images.  

 
 

Current Image as Primary 

The primary image appears on the first page of the Analysis Report. It is the thumbnail image in the top 

right corner of the Measure panel. To make another image the primary image, select it and complete 

these steps:  

1. Select the thumb nail image you want to be the Primary Image.  

2. Select Edit > Pole Images > Current Image as Primary. 

  

 

Reload Images   

To reload the images that are displayed in the Measure panel, complete these steps:  

1. Select Edit > Pole Images > Reload Images. Or click the button on the far right 

within the Measure tool bar. 

 
 

Use Standard File Open Dialog 

 Check this option to display the file details window showing the image(s) location on your device. 
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Pole Coordinates Geolocation 
O-Calc® Pro provides a variety of options for entering the pole coordinates. Pole coordinate information 

is used by additional functionality in O-Calc® Pro. For example pole coordinates are needed to view a 

3D rendering of the pole model on Google Earth, locate pole elevation and soil data. These unique tasks 

are possible with the use of custom built O-Calc® Pro Plugins.  

To manually enter longitude and latitude coordinates to the pole in the Inventory, complete these 

steps:  

1. Go to the Edit menu, select the Pole Coordinates option. 

2. In the Geolocation window enter the Latitude, Longitude, Elevation and click OK.  

 

 

Set Convention Lat Lon Format 

Enter and save the pole coordinates first as shown above, then you can use the Set Convention button to 

change the format in which the Geolocation coordinates are entered.  

Available Latitude Longitude formats are Signed Degrees, Degrees, Degrees and Minutes, Degrees 

Minutes Seconds. To edit the Latitude Longitude format complete these steps: 

1. Go to the Edit menu, select the Pole Coordinates option. 

 
 

2. In the Geolocation window, click the Set Convention button. 



[Type here] 

 

 92                   ©2025 Osmose Utilities Services, Inc.  

 
3. Select the Lat Lon Format option and select the needed format: Signed Degrees, 

Degrees, Degrees and Minutes, Degrees Minutes Seconds. 

 
4. Enter the data and click OK. 

Note: Select the Cancel option to close the Geolocation window without saving the changes. 

 

Set Convention Elevation Format 

Enter the pole coordinates first as shown above, use the Set Convention button to change the format in 
which the Geolocation coordinates are entered. Available Elevation formats are Meters, Decimal Feet, 

Feet and Decimal Inches, Feet and Inch Fraction. To change the format complete these steps: 

1. Go to the Edit menu, select the Pole Coordinates option. 

 
2. In the Geolocation window, click the Set Convention button. 

 
3. Select the Elevation Format option and select the needed format from the list. 
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4. Enter the data and click OK.  

 
Note: An additional way to access the pole coordinate information click the “G” button in the Top View 

panel and click on the Lat Lon button to access the Geolocation window. 

 

Reposition Pole 

This tool is used to reposition (move) the pole using distance and bearing values, with the option 

to move any guying as well. When the pole is repositioned (moved) the ends of the spans (to the 

adjacent pole(s) will not be moved. To begin you need to add a pole to the Inventory and enter 
its coordinates or select a location on the map to automatically load them. To use Reposition 

Pole feature, complete these steps: 

1. Add any pole in the Inventory and select it. 

 
2. Go to the Map area in Line Design and click on the Map to capture the latitude and 

longitude data or enter the pole location manually in Edit > Pole Coordinates. The 
pole appears at the map location, as shown below. 

 
3. Go to the Edit menu, select the Reposition Pole option. 
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4. In the Edit window enter a Bearing (deg) of 65, click OK. 

 
5. The results can be seen in the 3D View, Top View, and it the Inventory. 

 
 

Constrain All Elements 

This feature is used to constrain element movement, i.e. prohibit a Pin insulator from moving 

horizontally beyond the physical limitations of the crossarm length or prohibit a Post insulator 

from moving off the top of the pole. 

 

 

Re-Calculate Sag 

This feature is used to initiate a recalculation for any wire attached to the pole for the purpose of 

sag information. 



O-Calc® Pro 8.0                                                                                                  User Guide  

©2025 Osmose Utilities Services, Inc.                                                                                                  95  

 

 

Digital Measurement Technology (DMT) 

Working with Calibrated Visual Target (CVT) 

The O-Calc® Pro Measure panel allows you to take measurements from an image using Digital 
Measurement Technology (DMT) and the CVT (Calibrated Visual Target).  You can efficiently measure the 

pole height above groundline (and the resulting setting depth), all equipment attachment heights, 

arbitrary lengths, conductor diameters, and many angles.  

Before any measurements are taken from an image, the camera lens must be calibrated. Performing the 

lens calibration is a onetime task, then going forward the camera lens file will be found successfully. As 
each image measurement is completed, options are available to automatically update the measured 

value in the Inventory, 3D View, and Data Entry panels. Labels can also be placed on the image. Images 

can only be added to the O-Calc® Pro Measure panel after a pole has been added.  

Workflow Steps: 

1. Calibrate your Camera Lens (onetime task) for instructions go to Tools > Misc. > Photo Measurement 

> Lens Calibration and follow the 4 step process. 

 
2. Attach the CVT to the pole (lean the CVT with the pole lean if any) with the Velcro strap. 

3. Take the image (see tips below) including the tip and groundline of the pole. 

4. In the O-Calc® Pro Inventory panel, add the pole. 

5. Add the CVT/pole image to the Measure panel for instructions go to Edit > Pole Images > Select 

Images. 

 
 

6. Calibrate the CVT image for instructions see ‘Calibrating the CVT’ content in this O-Calc® Pro User 

Guide. 

CVT Image Tips: 

1. Step back from the pole approximately the length of the pole above ground for the best image. 
2. Stand at 45 degrees off the line of lead when taking the image for the best details. 

3. Hold the camera plum and in portrait mode (not landscape) for the best accuracy. 

4. Stand at the same elevation as the base of the pole for the best accuracy. 
5. Photograph the side of the pole that has the most attachments for the best details. 

6. Only one image can be calibrated at a time, choose your best image of the CVT. 
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Set Default Target Type  

Initially, when the Measure panel is opened Target Type default is set to CVT: White 13 Foot, displayed in 

the upper left corner of the Measure panel. The target type represents which Calibrated Visual Target 

(CVT) or Range (survey) Pole that was used when the image was taken.  

 

 

To change the default target type, complete these steps:  

1. Under the Image drop-down menu, select the Set Default Target Type option 
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2. Open the Type drop-down menu; select from one of the categories: Calibrated 

Reflectors, Range Pole, LiDAR or Tip Groundline Mode. 

 

3. Within the Type category select the specific target from the choices available 
and click Select. 
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Change Current Image Target Type  

To change the target type for only the current image in the Measure panel, complete these steps: 

1. From the Image menu, select Change Current Image’s Target Type.    

 

2. Select the Type of target to use for the current image, click Select. 

 

Image Menu 

The following options are available in the Image menu inside the Measure panel.  
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Save Image As…   Select ‘Save Image As’ to save the current image as a variety of file 
types (JPEG, BMP, GIF or PNG).  

Copy Image to Clipboard Select ‘Copy Image to Clipboard’ to copy an image to the 
clipboard and paste it directly to other applications such as 
Microsoft Word, E-mail, etc.  

Copy Viewport to 

Clipboard 

Select ‘Copy Viewport to Clipboard’ to copy the selected image as 
it is currently displayed to the clipboard.   The copied image can 
then be pasted directly to other applications such as Microsoft 
Word, E-mail, etc. 

Copy Annotations to 

Clipboard 

Select ‘Copy Annotations to Clipboard’ to copy measure labels 
from the image. The copied annotations can then be pasted 
directly to other applications such as Microsoft Word, etc. 

Set Default Target Type Select ‘Set Default Target Type’ to select the Calibrated Visual 
Target (CVT) used to get accurate measurements. 

Change Current Image’s 

Target Type 

Select ‘Change Current Image’s Target Type’ to change the 
currently selected (displayed) images target type. 

Display EXIF Information Select ‘Display EXIF Information’ to display the metadata in the 

image.  

 

Photo Edit Used to display other applications with which to view/edit the 
image. 

 

View Menu 

  

The following options are available inside the View menu in the Measure panel.  
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Magnifier Used to show or hide the magnification window.  With the 
magnification window displayed, move the mouse anywhere in 
the image to view that area in the magnification window. 

X Magnification Set the magnification level used in the Magnification window. 

Smooth Enabled by default to smooth hard edges of the image 

Reset Use Reset to undo display/enhancement options selected. 

Show Labels Enabled by default to show the results of the measured values. 

Show Label Background Enabled by default to show a white background to enhance label 
visibility. 

 

Measure Tool Bar Menu 

The following tools are available on the Measure tool bar. 

 

Zoom to Fit Click this option to fill the image frame to the maximum size. 

Bright Select this option to increase the brightness in the image. 

Dim Select this option to lessen the brightness in the image.  

Invert This option changes the image appearance to monochromatic. 

Greyscale This option changes the image appearance to black and white. 

Contr+ This option allows the image contrast to increase. 

Contr- This option allows a decrease in image contrast. 

Rotate Choose which direction to rotate the image: 

 

Target Type Displays the currently selected Target type category. 

Reload Initiate reloading of any images that are already added. 
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Image Navigation 

The following image navigation tools are available within the Measure panel to assist in the Digital 
Measurement Technology (DMT) process. 

Mouse Wheel  To zoom in or out move the mouse wheel to scroll forwards or 

backwards.   To pan right click.   

Added Images  All images associated with the selected pole are displayed as 
thumbnails on the upper right side of the Measure panel.   
Select any thumbnail to enlarge the image and display it in the 

main window area.  

Navigation Pane  Clicking a point in the Navigation Pane will center the image on 

that point in the Image View window.  

Zoom Scale Tool  

   

Click various levels on the scale to zoom-in or zoom-out on an 

image or use the roller wheel on your mouse. 

 

 

 

  

Measure Modes 

To complete measurements you need to select the corresponding measure mode.  Each mode uses a 

different visual tool to help you complete the measurements.    

 

Mode 

 

Click any Measure mode to activate the measurement capability.   
 

 

 
Note: The image must be calibrated first, then the other measure tools are 

available for use.   

Calibrate 

 

The Calibrate tool the cursor looks like a measurement sight 

for an accurate measurement.   

Height 

 

In the Height tool the cursor changes to crosshairs  for an accurate 

measurement of height relative to groundline.  

Arbitrary The Arbitrary tool cursor looks like crosshairs for an accurate 

measurement between two points in the plane of the target. Left 

click and drag the red line to the point to measure, release the click. 

Select Yes.  
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Cond Diam  

  

In the Cond Dia tool draw a line to accurately determine the conductor 

size by left click (1) and drag the yellow expanding band along any object 

(conductor) to be measured and release click. Select Yes.  

Angle The Angle tool cursor looks like crosshairs  to accurately calculate 

angles. Left click (1) on the object and drag gold line to the desired angle 

midpoint and click (2), continue to drag cursor to the final angle point 

and click (3). Select Yes.   

  

Note: If a mode is selected that does not have any associated task an error message will be displayed.  

Calibrating the CVT 

When the Measure panel is opened, the Calibrate mode tool is selected by default. The CVT (Calibrated 

Visual Target) in the image must be calibrated first, then all the measure tools become available. Four 

calibration points are needed, estimating one calibration point is permitted. The number of targets to be 
placed can vary based on the Target Type selected.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             

An obstruction may be due to vegetation, or an obstacle limiting your view of the red reflective bands. To 
place an estimated target, hold the Shift key and click to place a white target. Since the White CVT 

calibration points are known points in O-Calc® Pro, DMT accurately locates the estimated target point.  

If you need to redo the calibration process at any time, select the Calibrate tool and repeat the calibrating 

steps. There is no cancel or undo option for the Calibration process. If you need to redo the calibration 

process it does not affect any measurements already completed.  

To perform the Calibration process, complete these steps:  

1. Select the image you want to calibrate. 

2.  Place the mouse cursor box over the red reflective band and click to place a target, 

any order is permitted. 

Note: When setting the calibration, the cursor will change to a box   enabling you to get a 

precise measurement.  

3. Place the mouse cursor box over the red reflective band and click to place a target, 
any order is permitted. 

4. Zoom in using your mouse wheel. Zoom in so close that the red reflective band 

and cursor box are the same size on the top and bottom. Zooming in this close 

increases measurement accuracy. 
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5. Using the cursor box continue placing the remaining calibration targets at the 

same zoom level. Pan up or down the CVT in the image and click to place targets 
at each red reflective band. 

 

6. After the Calibrate process is complete the Height mode tool is 

automatically selected. Click on the image to begin placing height labels or select 

any of the other measure tools. 
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Note: When using IKE Images the Calibrate Mode is automatically changed to Select GL. This mode 

only requires one point on the image before additional measurements can be taken. If the ground line 

is not visible in the image an offset value can be entered by selecting File > Groundline Offset after the 

initial, Select GL point has been added.  

Edit Measure Labels 

Once the height labels are placed, right click on the label to open a menu for edits.  

 

 

 

 

 

 

Each image label type is described and shown below:  

Edit Text 

 

Use to edit the Label Text. 

 

Change Font Size Use to change Font Size.  
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Change Color 

 

Use to open a color pallet. Select a color 

and click OK to change the color of the 

label. 

 

 

 

 

Reposition 

 

 

Use to drag the label on the image to a 

new location. 

 

Set as Control Point 

 

Use to add a Control Point Height 

measurement. This is the point where 
calibration begins to measure attachments 

on the pole in the image. Control points 

can be any known location such as the 
ground line or the height of the lowest 

communication attachment. 

 

Delete Use to remove This Label (the one 

selected) or ALL Labels. 

 



[Type here] 

 

 106                   ©2025 Osmose Utilities Services, Inc.  

  

 

Change the Current Image Target Type 

When there is no CVT stick (CVT: White 13 foot) or Range Pole in the images, measurements can be made 

using Control Points set in the image. First you need to set the Target Type to ‘No CVT’. Only one control 

point can be used at a time. Control points ensure greater accuracy of attachment heights near the 

control point, when no CVT or Range pole is available in the image. Deselect the pole before using this 

method, because it only works if the pole is not selected (pole highlighted yellow) in the Inventory panel 

or 3D View. To begin using Control Points complete these steps:  

1. In the Measure panel, select the Image  menu, click the Change Current Image’s 
Target Type option.  

   

2. Select the Type: Tip Groundline Mode. The default choice is None, click the 

Select button.  

 

3. Using the Calibrate mode, click to place a red target at the base of the pole.  

4. Using the Calibrate mode, click to place a red target at the top of the pole.  

5. Using the Height tool, hold down the Ctrl key, and click a point on the pole that 

is a known height, such as the lowest communication span. 
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6. In the Edit window enter the control point height value that is known, click OK.  

  

  
 

Height Measurement 

To complete a Height measurement on the image, you must first calibrate the image following the step 

above in “Calibrating the CVT” to be in Height mode. Before taking any other measurement, first take the 

height of the pole above groundline measurement. 

To take a height measurements complete these steps:  

1. Select the pole first, so it is highlighted in yellow, and the Data Entry panel 

displays the pole attributes. 

2. In the image click on the top of the pole, select the Setting Depth of…option. 
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3.  The result may be a change in the pole Setting Depth based on the image 
data. This information is automatically populated in the Setting Depth  

attribute because the pole was selected. 

4. Next click the Crossarm height in the image, and select the Display Measured 

Value option. 

 

 
5. Continue to repeat this process until all the height label needed are added to 

the image. 

Arbitrary Measurement  

To complete an Arbitrary measurement between two points on the image, you must first calibrate the 

image, then complete these steps:   

1. Select the Arbitrary tool. 

  

2. Click the point you want the Arbitrary measurement to start, hold and drag to 

draw a line to where the Arbitrary measurement ends.  

3. Select Yes to add a label on the image.  No to cancel. 
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Conductor Diameter Measurement  

To complete a Cond Diam (conductor diameter) measurement between two points on the image, you 

must first calibrate the image, then complete these steps:   

 

1. Select the Cond Diam tool.  

  

2. Place the cursor in the middle of the conductor to measure. Hold and drag 

along the wire to draw a yellow ribbon stop when it reaches the same width as 

the wire. Release the click point when the desired width is achieved. 
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3. Select Yes to add a label on the image.  No to cancel. 

  

   

Angle Measurement  

The Angle measurement is a three-point process. After the Angle measurement is complete the 

Angle measurement is displayed for reference purposes only. Angle measurements need to be 

entered into O-Calc® Pro manually.  To assist you in measuring an Angle, complete these steps:   

1. Select the equipment in the Inventory panel that you want to measure the 

angle of.  

2. Select the Angle Mode.  

  

3. Place the crosshairs at the point you want the Angle measurement to start.  

4. Click the left mouse button and draw your first line, click the left mouse button 
again and draw your second line.  

  

5. Left click and the Angle measurement is automatically displayed for reference 
purposes.  

 

Adding to an Existing Note  

To add measurement information to an existing note, complete these steps:  

1. Select a note object in the Inventory panel.  
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2. Select the Mode you would like to use for the measurement.   

  

3. Place the crosshairs at the point you want the measurement to be taken at and 

click the left mouse button.  You may want to use the Scale Tool or the mouse 

wheel to zoom into a specific area in the image.  

   

4. The selected note in the Inventory panel automatically is displayed.  

  

5. Complete any edits to the note description, content or spreadsheet.  
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6. Select Edit > Paste to incorporate the measurement into the note content area. 

The selected measurement is automatically inserted into the selected note.  

 

7. Click the Calculations tab to have the measurement automatically paste into the 

Data Grid View. Select the cell you want to paste the measurement into and 

select one of the following options from the Sheet menu:  

Sheet > Paste > Value Only - Excludes the measurement text and only paste the measurement value into 

the spreadsheet.   

Sheet > Paste > All Text - Pastes the complete measurement into the spreadsheet with nothing excluded.   
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8. Select File > Save. 

Add Measurements to a Note  

To add measurements to the Data Grid View while working in the Measure panel you can create custom 

Measurement Labels in the Note Calculations sheet.  These measurement labels display each time the 

note is selected while completing a measurement.  To create a measurement label in a note and use 
them to paste measurements directly into the selected note, complete the following steps:  

1. Create a new note by right-clicking on any object in the Inventory, select Add Annotation > 
Notes.  

2. Enter a Description and the note Contents.  

3. Select a cell in the Data Grid View (Calculations tab) and enter a Measurement Label, select 

File > Save. 

There is no limit to the number of Measurement Labels you can enter.  The only exception is that the 

measurement label needs to be entered with brackets around it, i.e. <Measurement Label>. As there is 

no measurement value enter place holder values of zero in place of the measurement value to be 
entered.  Also, enter calculation formulas if they are needed.  
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4. Select the Note object in the Inventory panel, and make sure you are in the Height Mode in 

the Measure panel. 

 

5. Click the left mouse button where you would like each measurement taken from on the 

image and select the appropriate Measurement Label. 

  

6. To return to the Note object select it in the Inventory, and in the Dat Entry panel click the 

Contents attribute Press to View radio button. 
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7. Or right click at any height on the image and select the Show Note option. 

 

8. Open the Note (click Press to View) click the Calculations tab. Select the column and paste 
the value. 

 

9. Continue to repeat these steps until all the needed measurements are recorded.  
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Note: Additions and modifications can be made to any area of the note at any time. The note can also 

be copied to your User Catalog to be used as a template in the future.  

Note: If measurements have been incorporated into the Data Grid using Measurement Labels and the 

Units Convention (English or Metric Convention) is changed the measurements that are displayed in 

the Notes Data Grid will not change. 

 

Calibrating the Camera Lens 
The Lens Calibration Tool is used to determine the barrel / pin cushion distortion present for a particular 

brand of camera prior to its use in the Digital Measurement Technology (DMT) process.  

Enabling the Lens Calibration Tool   

To properly calibrate your camera lens, follow the 4-step process outlined in the Lens Calibration Tool.  

To enable the Lens Calibration Tool,  complete the following steps:   

1. Select Tools > Misc > Photo Measurement > Lens Calibration.  
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Lens Calibration Chart 

To begin the Lens Calibration process, complete these steps:   

1. The Step 1 tab is selected by default, click the Click here to print calibration 

chart button and print the calibration chart. 

Note: You can use a printer or save it to a file. You’ll need the printed calibration chart, and the 

camera whose lens you plan to calibrate to proceed to the next step.  

2. Click the Next button or select the Step 2 tab.  
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3. Using the camera that needs to be calibrated take a picture of the calibration 

chart that you printed out on the Step 1 tab.  

Note:  Make sure the document is lying flat, tape the corners down.  Use the detailed directions 

provided on the Step 2 tab to get the best possible image.  Incorrectly taken images of the calibration 

chart will result in an incorrect lens calibration.   

4. Save the image you took of the calibration chart.  

5. Click the Next button or select the Step 3 tab.  

  
6. Click the browse button  and navigate to and select the image you took of 

the calibration chart and click Open.  

7. Your image should display in the Step 3 tab.  
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8. Click the Next button or select the Step 4 tab.  

Note: Verify the Camera Make and Camera Model being displayed are correct for your camera.  

  

9. Click the Click here to select points button. The Lens Calibration Pick Points 

window displays.  

  

The Camera  
Make, Model  
and Sensor  
Ratio are  
automatically  
populated.    
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Begin with the outside row of points in a clockwise direction, zooming in close to place each pick point 

precisely. Using the detailed directions provided select each point until all points are selected on the 

chart in order.  

     

Select all outer  
points in a clockwise  
direction   
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10. When all points are selected, click the Done button.  

11. Click the Click here to calibrate button.  The calibration status bar displays the 

lens calibration progress.  

  

When the lens calibration is complete the Lens Distortion field will automatically be populated.  

 

12. Click the Click to update cameras file button.   

  

Select all inner  
points in a  
clockwise direction   

       

Lens Distortion  
is automatically  
populated once  
the cal ibration is  
completed.   



[Type here] 

 

 122                   ©2025 Osmose Utilities Services, Inc.  

13. Select OK to the verification message that the camera has been added to the 

supported camera database.   

14. Select Finished to close the Lens Calibration Tool.  

Tools Menu Overview 

Several advanced design tools are provided within the O-Calc® Pro Tools menu. Each option available in 
the Tools menu is described below. 

 

Scripting 

Provides the ability to add, edit and run scripts and macros, plus access to various controls for hotkeys. 

Includes the option to manage catalogs. 
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Script Manager 

 

 

Hotkeys 
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Scripting Manage Catalogs 

 

 

Batch Pole Report 

Provides access to all the reports available in O-Calc® Pro. After the pole(s) have been added in the Poles 

to Process window, select the check boxes for the desired reports and click the Print Reports button.  
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Custom Pole Reports 
Provides the option to create, edit, and display your own report using a .xlsx file. A list of available tokens 

is provided in the Custom Reports window, open the Other drop-down menu. From the Help menu in  

 

 

Export Batch Pole Info  
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Heights 

Provides quick access to pole attachment height information. 

 

 

Working with Clearance Analysis 
The O-Calc® Pro Clearance Analysis tool provides the ability to model actual field conditions accurately 

and to quickly check against clearance violations for attachments and groundline obstructions based on 

rules you create. Along with the ability to define elements attached under or interfering with the spans 

attached to a pole to evaluate any clearance violations. 

Examples of clearance requirements that can be added and violations that could be found are:  

• Spans of different types (power to comm. for example)  

• Spans and structures or vehicles  

• Spans and surfaces  

• Spans and foliage  

  

Creating a Clearance Analysis allows you to consider the existing or proposed field conditions such as 

surfaces (terrain), structures, foliage and wires.  The Clearance Analysis tool creates a 2D model of the 

spans and field conditions you input.  The Clearance Analysis Report is also available to easily detect any 
clearance issues.  Creating a Clearance Analysis is a four-step process:  

  

1. Add the Clearance Rules and Violations definitions using the Clearance Rules 
Editor.  

2. Define the Clearance Groups for objects on specific spans to identify the 

category or categories that a span falls into.  
3. Recording the actual field conditions surrounding the pole (surfaces, structures 

and foliage).  
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4. Run the Clearance Analysis Report.  
Note: Videos are available to help walk you through the Clearance Analysis Tool setup process.  

Find these in the Help menu under More Information, View Informational Videos. 

 

Step 1 - Clearance Rules/Violations   

Before any Clearance Analysis can be completed, the Clearance Rules and Violations need to be set up.  
Creating these Clearance Rules and Violations is typically only done once for any power company or 

division.    

Once the Clearance Rules or Violations have been established extreme caution is advised when removing 

or editing them after Clearance Analysis is configured.  Removing or editing existing Clearance Rules or 

Violations may invalidate existing clearance elements or rules.  

To create Clearance Rules and Violations, complete these steps:   

1. Select Tools > Clearance Analysis > Edit Clearances Rules. 

2. Editing or setting up the Clearance rules means you need to add any new 

Structure, Surface or Foliage element. To accomplish this you must first select 

one of the categories in the list: Structure, Surface or Foliage. Now when you 

click the Add button the element you create is added to that category. 

3. Select File > Save. 

 
Note: Only the Structure area allows you to define a Shape.   
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Note: When adding a Surface element, a Default surface attribute is available if you’d like 

to have a specific surface added by default when creating Clearance Analysis.   The 

default surface area can be changed at any time.  

4. Clearance Groups depict what categories spans can be a part of. To add a 

Clearance Group right-click on Clearance Groups or select Add from the menu.   

Note: There is no undo for this operation.  To remove an element, select the Structure, Surface or 

Foliage and select the Delete button. 

  

      

  

    

New Structure  
element is  
created   
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or 

Left click Clearance Groups and select the Add button   

  

Step 2 - Define Clearance Groups 

A comprehensive listing of all the current Clearance Rules is available by selecting File > Show Clearance 

Rules.  The O-Calc® Pro Clearance Analysis Rules report will display and is available for printing.  

5. Enter the new Clearance Group attributes.  

  

5. Select File > Save.  

Note: Complete the steps above to create additional Clearance Group rules.  

Note: There is no undo for this operation.  To remove a Clearance Group rule, select the Clearance 

Group to be removed and select the Delete button. 

  

  

New Clearance  
Group is created   
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6. Define the rules and violations that will be used when completing a Clearance 

Analysis. Add a Rule or Violation by right-clicking on Rules and Violations and 
select Add from the menu or left click Rules and Violations and select Add. 

7. Define the Rule or Violation attributes, enter the new Rules or Violations 

attributes.  
8. To set the Sources Targets attribute select the radio button. 

 

9. Check the boxes of the Sources and Targets to be used. Click OK. 

 

Note: Multiple Sources and Targets can be selected.  The only exception being that you cannot select 

the identical Source and Target.  
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10. Select File > Save.  

Note: There is no undo for this operation.  To remove a rule, select the Rule and Violation item and 

select the Delete button.  

 

Step 3 - Categorize Spans   

Once the rules are in place you need to categorize the actual spans on the current pole.  To identify which 
spans, go into specific categories you will need to place a Clearance object on each span.  To place the 

Clearance Object on a span, complete these steps:   

1. Select the Span to add a Clearance Object to.  

Note: Spans can be selected from the Inventory panel, the 3D View or the User Catalog.  If a span is 

selected from the 3D View or the User Catalog use the right click menu to add a clearance object.  

2. Select the Add button.  

Note: The Add Element > Clearance option can also be accessed by right clicking on the span you 

need to add the Clearance Object to.  

3. Select the Clearance option.  

  
Note: Only one Clearance Object can be added at a time.  

  
Note: Available tabs are dependent on corresponding equipment displayed in your Catalogs or 

Inventory panel.  

4. To add a Clearance Object from a catalog or the Inventory, select the clearance 
object you want to add.  

5. Select the Attribute Value tab to modify the clearance object attribute values, 

click OK. 
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Clearance Attributes Descriptions 

 

Description  A general description of the Clearance Object.  

Clearance Group  The name of the Clearance Group.  

Render in 3D View  A visualization of the vertical clearances.  

Population Mode  Determines the method by which the midspan sag values are 

populated.  

Manual: Sag values are entered by the operator.  

Automatic: Sag values are populated automatically.  

External: An external process populates the values  

Sag Minimum  Enter the minimum sag allowed at midspan.  

Sag Nominal  Enter the nominal sag allowed at midspan.  

Sag Maximum  Enter the maximum sag allowed at midspan.  

 

  

Note: To undo the addition of the Clearance Object, select Edit > Undo.   
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Create Clearance Analysis Profile   

To model the actual field conditions surrounding the pole in you need to create an O-Calc® Pro Clearance 
Analysis Profile.  As you are creating the field conditions a 2D representation of the model will be 

displayed as a visual reference.  To create a Clearance Analysis Profile, complete these steps:   

1. Select Tools > Clearance Analysis > Clearances and Violations.  

  

  

  

 

Setting up Vectors  

The first step to modeling the actual field conditions is to set the vectors.  Vectors are notional lines that 

extend outward from the pole at given angles, and which describe the type and elevation changes of the 

surface under the pole.  Vectors may contain instances of structures and foliage that fall along that line.  
Typically, these vectors have a close correspondence with the spans attached to the pole, but this is not a 

requirement. Note: To automatically create a vector at each span angle select the Auto button.    

1. To set the Vectors select the Add Vectors button from the Vectors 

toolbar.  
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2. Enter a Vector Angle, click OK. 

Note: The overhead view of a pole with all the span angles is available by selecting the Overhead 

button . The Overhead window utilizes some of the same features as the Top View 

window. 
 

Note: There is no undo or edit for this operation.  To remove a Vector Angle, select the Vector Angle 

to be removed and either select the Delete button from the Vector toolbar or right click the Vector 

Angle and select Delete.  

3. To create a structure at a specific vector, select the vector you want to 

add a structure object to.  

4. Select the Add Structures / Surfaces / Foliage drop down menu and 

select Structure.   
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5. Enter the structures attributes.  

  
6. Select OK.  

Note: There is no undo for this operation. To remove a structure select the Delete button. 

7. To set the surface at a specific vector select the vector you want to add a 

surface object to.  

8. Select the Add Structures / Surfaces / Foliage drop down menu and 

select Surface. 
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9. Enter the surface attributes.  

10. Select OK.  

Note: There is no undo for this operation. To remove a surface item, select Delete.  

11. To create the foliage at a specific vector, select the vector you want to 

add a foliage object to.  

12. Select the Structures / Surfaces / Foliage Add drop-down menu and 

select Foliage.  
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13. Enter the foliage attributes.  

  

14. Select OK.  

Note: Complete the steps above to establish additional foliage at a specific vector. There is no undo 

for this operation. To remove foliage, select Delete.  

  

Note: Structures, Surfaces and Foliage can be edited at any time by selecting the object and either 

selecting the Edit button from the toolbar or right clicking on the object and selecting Edit.  
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15. To Save the Clearance Analysis Profile select File > Exit.  Then in the O-

Calc® Pro main window select File > Save Pole.  

Step 4 – Run Clearance Analysis Report 

The O-Calc® Pro Clearance Analysis report displays any clearance violations along the spans you modeled.  
A Clearance Analysis report can be run against all the vectors you’ve specified or just one vector. To run 

the Clearance Analysis report, complete these steps:   

1. Select Tools > Clearance Analysis > Clearances and Violations.  

  

2. Select the Clearance Analysis drop down menu.  

  

• Current Vector – Creates a Clearance Analysis report on the currently select vector 

in the Clearance Analysis window.  

• All Vectors – Creates a Clearance Analysis report on all the currently listed vectors 
in the Clearance Analysis window.  
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Clearance Report Menu Options 

Once the Clearance Analysis report is displayed the toolbar menu provides you with a variety of options. 
The following options are available from the File menu:  

File 

 

 
 

 

Print Report Use to print the Clearance Analysis.  

Page Setup Use to configure how the  
Clearance Analysis will be printed.  

Save to PDF  Use to save the Clearance Analysis 
as a PDF file.  

Save to RTF  Use to save the Clearance Analysis 
as an RTF file.  

E-Mail Report To  Use to E-Mail the Clearance 

Analysis. 

Copy to Clipboard  Use to copy the Clearance 

Analysis to the clipboard to paste it into other 

applications. 

   

Navigation Controls  

  

Click the arrow buttons to easily navigate through the 

document pages.  

Zoom Controls  

  

Use to change the documents magnification level.  

Clearance Rules Maintenance   

The O-Calc® Pro Clearance Analysis rules can be exported for use by other O-Calc® Pro users, preventing 
the need to develop a new set of Clearance Analysis rules.  The export process makes a copy of the 

current Clearance Analysis rules and saves them in a location you specify.  The saved Clearance Analysis 
rules can then be exported to be imported by another O-Calc® Pro user and modified as needed. 

Export Clearance Rules   

To export the Clearance Rules, complete these steps:  

1. Select Tools > Clearance Analysis > Clearance Rules Maintenance > Export 

Clearance Rules.  

  

2. Browse to the location to save the Clearance Rules and click Save, click 

OK. 
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Import Clearance Rules   

To import the Clearance Rules, complete these steps:  

1. Select Tools > Clearance Analysis > Clearance Rules Maintenance > Import 

Clearance Rules.  

  

2. Browse to the location of the Clearance Rules file you want to import and 

select the (Clearance Rules name).crx file, click Open.  

3. Select OK to the import confirmation message. 

 

Load Case Defaults and Comparison 
When several Load Cases are attached to a pole in the Inventory panel O-Calc® Pro provides a Load Case 

Comparison report.  The Load Case Comparison provides detailed calculations for each Load Case and 

identifies and displays the Worst Load Case in the comparison. The report can be saved, emailed, copied 

or printed. To compare load cases you must have more than one load case added to the pole.  

 

To compare Load Cases you must add more than one Load Case to the pole. The Load Cases appear in the 

Inventory. Only one of the Load Case icons below is highlighted with a pink triangle. The pink triangle 

indicates the currently calculated Load Case. Although more than one Load Case is added to the pole, 
only one can be calculated at a time, the results are displayed in the Capacity panel.  
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To create a Load Case Comparison, complete these steps: 

 

1. First add a pole to the Inventory and add two different load cases from the 
Catalog to the pole. 

2. Go to  the Tools menu, select Load case, and click on Comparison. 

 
 

3. The report appears with the information about both load cases along with 

identifying the Worst Load Case at the bottom of the Report. 

 

Note: The pole calculations needs to be completed, if the Auto Capacity Summary is disabled the 

calculations cannot be performed and the Load Case Comparison is disabled. 
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Load Case Comparison Menu 

Once the O-Calc® Pro Load Case Comparison is displayed the toolbar menu provides a variety of options 
described below.  

   
 

 

File Menu 

  

Print Report. Select the Print  

Report option to print the Load Case 
Comparison.  

Page Setup. Select the Page Setup option to 
configure how the Load Case Comparison will be 
printed.  

Save to PDF.  Select the Save to  

PDF option to save the  

Load Case Comparison as a PDF file.  

Save to RTF.  Select the Save to  

RTF option to save the  

Load Case Comparison in RTF format.  

E-Mail Report To.  Select the E-Mail Report To 
option to Email the Load Case Comparison.  

Copy to Clipboard. Select the Copy to Clipboard 

option to copy the Load Case Comparison to the 

clipboard so that it can be pasted directly into 

other applications.  

Navigation Controls  

  

Click the arrow buttons to easily navigate 

through the document pages.  

Zoom Controls  

  

Use to change the documents magnification 

level.  

  

Remove a Default Load Case   

To remove any default Load Case, complete these steps:   

1. Select Tools > Load Case… > Defaults.  
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2. In the Default Load cases window, check the box(s) for the load case(s) you 

want to remove. 

3. Click the Remove Selected Default Load cases button. 

4. Click the Close button. 

 

Strength Reduction Calculator 
The O-Calc® Pro Strength Reduction Calculator offers the ability to add pole damage to the pole analysis 

based on the damage size and type. Any damage entered is applied to the groundline of the pole and 

considered in the pole loading results, providing a worst case scenario for the damage. 
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Sag Tension Calculator 
The O-Calc® Pro Tension Calculator displays a Span Profile view calculator which can be used to input 
conductor attribute values to examine different scenarios for amounts of wire sag. Another way to 

automatically see the results for a given span is to right-click on the span in the Inventory or 3D View and 

select the Tension of… option, the Sag Tension Calculator displays with the current results for the wire 
you selected. 

The O-Calc® Pro Sag Tension Calculator allows you to calculate and apply a Sag Tension to a span whose 

Tension Type is set to Static. The Sag Tension Calculator can also be used for reference purposes without 

applying a sag tension calculation.  When working with a span that has a Tension Type of Static, complete 
these steps to set the sag tension using the Sag Tension Calculator:   

1. Go to the Tools menu, select the Tension Calculator option. 

 
 

2. Input the values to examine different scenarios for amounts of wire sag in 

any open window (not greyed out) and the O-Calc® Pro Sag Tension 
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Calculator updates to display the results in the chart for your information. 

These edits do not affect the pole in the Inventory. 
3. Open the Mode drop down menu to change the display to Sag in feet (Sag to 

Tension) or Tension (Tension to Sag) in pounds. 

 

Sag to Tension Mode 

 
Tension to Sag Mode 

 

When the O-Calc® Pro Sag Tension Calculator is initially opened some of the fields are pre-populated with 

information from the pole. When opening the Sag Tension Calculator by selecting Tools > Tension 

Calculator the Apply to Span button is not displayed, you must right-click on a span in the Inventory or 3D 

View panel to have the Apply to Span option shown below. 
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Use the Reference button to: Reload References, Select Alternate Reference Load Case or Load Default 

Values. 
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Calculator Reference Menu 

The Sag Tension Calculator provides a variety of operations and options from the Reference menu:  

 

 

Reload References. Select the Reload 
References option to reload the pertinent 
values from the selected LC.    

Select Alternate Reference Load Case. Select 

this option to select a different load case to 

reference.  

 

Load Default Values. Select this option to load a 
set of nominal load parameters.  

Cancel. Select this option to close the 

Reference menu option without taking any 

action.  

  

  

Apply to Span. The Apply to Span options 
transfers selected attributes back to the 
original span and optionally changes the 
tension mode.  The menu items will reflect the 
tension mode of the original seed span   

Cancel. Select the Cancel option to close 

without taking any action.  

3. Complete any attribute modifications.  

4. Enter the Initial Sag measurement.  

5. Click Apply to Span to transfer selected attributes back to the original span and 

optionally change the tension mode. 

 

Working with Sag Tension Table Generator 

The O-Calc® Pro Sag Tension Table Generator is a versatile tool for analyzing conductor behavior under 

various conditions. Whether you're working from known sag or tension values, this tool provides a 

structured, repeatable way to generate tables showing sag values for different span lengths, load cases, 

and temperatures. 

The O-Calc® Pro Sag Tension Table Generator complements the O-Calc® Pro Sag Tension Calculator. It 
allows you to view the amount of sag occurring for a given span type and load case at various span 
lengths across a range of temperatures.  

O-Calc® Pro provides several tension types for modeling and analysis. For detailed information on these 
tension types, refer to the O-Calc® Pro Wiki article: Tension Types and Sag Explained, which can be 

accessed through the Help menu.  
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To utilize the Tension Table Generator complete these steps: 

1. Select Tools > Tension Table Generator…   

 

Step 1- Load Case(s) 

The Tension Table Generator is a 3-step process that produces sag results. In Step 1 add the Load Case(s). 
To begin to create the Sag Tension Table Generator information complete this three step process: 

1. In the Load Cases (Step 1) tab, click the Add Load Case button.  

2. The Create New Load Case window opens. Choose one Load Case at a time from the 
Catalog and click OK. Only one Load Case can be added at a time. 

Note: If multiple Load Cases are needed, the tool can run multiple scenarios for each of the Load Case 
parameters. Repeat the Add Load Case process above if you need to add additional Load Cases. 
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3. The Load Case(s) is added to the list.  

 

Step 2- Spans 

Select the span (normal span) or span bundle (messenger cable) or full span bundle (Hendrix cable) to the 
considered in the generated table and click OK. Follow these steps to add spans: 

1. Click Spans (Step 2) tab, click the Add menu and select Span from the available 
options: Span, Span Bundle, Full Span Bundle. 

 

2. The Create New Span window opens with a filtered version of the catalog that shows 
spans which correspond to the type that was selected.  

 

3. Select any conductor, the conductor is added successfully. 
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Step 3- Create Table(s) Report 

Enter a Start and End Length and Increment in feet. Along with other parameters. If the unit convention is 
set to metric the values display in meters. To complete step 3 follow these steps: 

1. Click the Create Report (Step 3) tab 

2. Modify the Report values displays for these options: 

a. Start Length the distance from the pole a user would like to have a sag value 
calculated.  

b. End Length how long the spans are.   

c. Increment the amount of feet between each point of sag calculation 

d. Order determines how the results are sorted in the report and has two 
options:  
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• By Load Case splits the report up by a Load Case, with each 
selected span run together. 

• By Span separates the report by the span type selected, with 
each type of span showing all Load Cases selected grouped 
together. 

e. Minimum Temperature based on the Load Case selected 

f. Nominal Temperature based on the Load Case selected 

g. Maximum Temperature based on the Load Case selected 

h. Display Sag  

i. Output Format options: PDF or CSV.  

j. Choose the Mode option:  

• Sag to Tension user to set the nominal sag for the conductor and 
have the tool calculate the amount of tension. 

• Tension to Sag user to input the tension and have the tool 
calculate the amount of sag. 

k. Nominal Sag in feet or keep the 1ft default value. 

l. Click the Create Table(s) button. The report is generated depending on the 
order selected, there are either separate pages for each Load Case, or for 
each span type. The header information indicates what Load Case, or span is 
being considered. 

 

The Report is generated depending on the order selected, there are either separate pages for each Load 
Case, or for each span type. The header information indicates what Load Case, or span is being 
considered:  

 

The File menu contains various options to print, save, email, and copy the report: 
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By Load Case order, the header information indicates the load case being considered, the ice and wind 
factors, and the table content is separated by the span type.  

By Span order, the header information provided relates to the span, and the table itself is separated by 
load case being considered. 

 

 

Soil Data Lookup (NRCS) 
Provides soil data based on the information at the U.S. Natural Resources Conservation Service website 

for the latitude and longitude of the pole. 
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Finite Element Model  

Provides a mesh view of the pole model and a finite element analysis of the node beam summary in a text 

file. 
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Catalog Maintenance 
Within the O-Calc® Pro Catalog Maintenance options are provided to add, remove, edit and download 
multiple Master and User Catalogs. Each catalog configuration displays independently within O-Calc® Pro.  

 

Configure Catalogs  

To open the catalog configuration window, complete these steps: 

1. Select the Tools menu, select Catalog Maintenance, click on Configure 

Catalogs. 

 

2. In the Catalog Configuration window click the Add Catalog button.  
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Note: A default Master and User Catalog are provided upon installation of O-Calc® Pro. To download 

additional Catalogs click the Download button. To Add, Remove and Edit Catalog you must first select 

the Catalog from those displayed by clicking on it. 

 

Add a Catalog   

To add a catalog, complete these steps:   

1. Select the Add Catalog button.  

  

2. Enter the catalog Name.  

 

3. Select the catalog Type from the drop-down list.  



[Type here] 

 

 156                   ©2025 Osmose Utilities Services, Inc.  

Note: Master Catalogs have blue folders and cannot be edited, User Catalogs have yellow folders 

and can be edited.   

4. Select the Catalog Path browse button  to browse to and select the catalog 
file and click the Open button.  

5. The State Path is automatically populated. Or you can use the browse button 

 to browse to and select the catalog expansion file you would like to use 

and click Open.  

6. In the Catalog Configuration window, click OK to close.  

Note: There is no undo for this operation.  

 

Edit a Catalog   

To edit a catalog configuration, complete these steps:   

1. Select Tools > Catalog Maintenance > Configure Catalogs.  

2. Select the Catalog you would like to edit.  

  

4. Complete any modifications to the catalog configuration.  

  

5. Click OK to close the Add Catalog Entry window.  

Note: There is no undo for this operation.  

6. Click OK to close the Catalog Configuration window.  

7. Click OK to the Restart Required message.  

Remove a Catalog  

To remove a catalog configuration, complete these steps:   

1. Select Tools > Catalog Maintenance > Configure Catalogs.  

3.   Select the  Edit   Catalog   button  .   
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2. Select the Catalog you would like to delete.  

3. Select the Remove Catalog button .   

4. Select Yes to the remove confirmation message.  

Note: There is no undo for this operation. These customizations can only be restored by reverting to a 

previously saved backup of the Master Catalog.   

Note: Backup versions of the Master Catalog can be obtained by selecting Help > Folders > User Root 

Folder > Catalog Backup.  

Download a Catalog  

To download the latest version of an O-Calc® Pro catalog, complete these steps:  

1. Select Tools > Catalog Maintenance > Configure Catalogs.  

2. In the Catalog Configuration window, select the Download Catalog(s) button.  

3. You are navigated to https://www.osmose.com/o-calc/catalogs  

4. Select a catalog to download – clicking on it will begin the download, close 

web browser when the download completes.  

5. You are prompted to choose a save location.  

▪ If saving in same location as older versions of a catalog, this action 

overwrites the older version.   

6. In O-Calc, select Tools > Catalog Maintenance > Configure Catalogs  

7. Use the Add Catalog button.  

 

Maintenance (Bulk Edit) Mode 

The Maintenance (Bulk Edit) Mode feature allows users with Administrative access to perform bulk edits.  

 

 

Newer Catalog Version Check 

The Disable New Master Catalog Notifications feature alerts you when a newer Osmose Master Catalog 
version is available to download, simply click it to disable this feature. By default each time you log into O-

Calc® Pro this feature checks if a newer version of the Osmose Master Catalog is available to download.  

 

https://www.osmose.com/o-calc/catalogs
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User Access Levels 
Used to allows permission to access additional features within O-Calc® Pro. Typical user access is the 

‘Normal’ option which is set by default. The User Level can also be updated by left clicking on the User 

Level in the Status Bar and selecting the preferred User Level. The current User Level will automatically 

be updated at the bottom of the Status Bar.  To change your access permission, complete these steps: 

  

1. Go to the Tools menu, select User Level, and select the level needed. 

2. Select OK to the confirmation message.  

Note: Changes to the User Level are per O-Calc® Pro session.  No changes to the User Level are 

permanent. For additional information on O-Calc® Pro Security Level, see O-Calc ® Pro Security 

Administration.  

View Color Legend 

O-Calc® Pro reveals the Color Legend in a vertical display with increments of ten and the corresponding 

color changes associated with the amount of stress on the pole.  

Utilities – Standalone Tools 
Provides several standalone application tools that operate independently, without needing an internet 

connection, other programs, or external systems to function. These applications are self-contained, can 

store data locally, and perform their main functions on their own. 
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O-Calc Measure provides the Measure panel for access to image functionality. 

 

 
 

 

 

PPLX Image Split / Merge provides access to additional image functionality. 

 

 

Pole Browser provides access to pole files. 

 

 

Shapefile Viewer provides access to view Shapefiles. 
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Span Tension Sag Calculator tool is used to examine conductor sag scenarios. 
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View Menu Overview 

The View menu provides a variety of options based on user preference, many of them affect how O-Calc® 

Pro is displayed.  In some instances these commands are enabled or disabled by clicking on them. A check 

mark indicates the option is enabled. 
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Theme 

Theme provides the ability to change the theme of your O-Calc® Pro display.  Select Light, Dark, Blue 
or Legacy and restart the application for the changes to take effect. 

 

3D View 

View the pole model in the 3D View, which includes all the equipment listed in the Inventory. To return 

the view of the pole to an isometric view use the Reset Camera Position option. To view the pole from the 

top down, use the Bird’s Eye View option.  

 

 

Save 3D View to 

Provides the ability to save the 3D View screen capture to a clipboard, or as an image file, plus print and 

save options for the 3D View. 

 

 

Update Capacity Summary (Alt+U) 

Provides the ability to initiate the calculation to produce results in the Capacity display area. 
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Docking Layout 

The default docking layout view maximizes the 3D View space. You can return to this default view at any 
time by selecting the View menu, Docking Layout > Default. 

 

Refresh All Views 

A refresh of all views causes a redraw of the 3D View area and the Inventory to recover any graphics. 

 

Reset All Filters 

Options are available in 3D View to filter out or limit the scope of the data displayed in the 3D View. 

When a filter is not active the command is unavailable (greyed out). When a filter is active the sunglasses 

icon is displayed in the upper right corner. If a filter is active, the Reset All Filters option clears any filters.   
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Options Menu Overview 

The Options menu offers choices in how menu data is displayed and accessed, which is based on user 

preference.  This overview includes a brief description of each menu item. Most commands are enabled 

(check mark is displayed) or disabled (no check mark) by clicking on them. An arrow icon next to the 
name of a menu item indicates a submenu is available with additional options.  

 

   

Capacity Display 

The Capacity panel displays the pole loading calculation results as a percentage value for the allowed MCU 

(Maximum Capacity Utilization) for the pole.  

 

When the Auto Capacity Summary is enabled (see check mark) the pole loading calculation engine is 

effectively “On” and producing results automatically whenever changes are made to the pole model. This 

is the preferred method for instantly displaying pole loading calculation results, it’s enabled by default. 

 

The three MCU results display options available are: Capacity Meter Display, Capacity Numeric Display, 
Factor of Safety Display. Only one can be displayed at a time, but you can change displays at any time. 

These MCU results options are based on user preference each one is described below. 
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Capacity Meter Display 

 

Displays the percentage of allowed maximum 

capacity utilization (MCU) for the pole loading 
results in a metered format. 

 

 

Capacity Numeric Display 

 

Displays the percentage of allowed maximum 

capacity utilization (MCU) for the pole loading 

results in a numeric format. Including details for 

the groundline and maximum capacity utilization 

for moment values. 

 

 

Factor of Safety Display 

 

Displays the Pole Factor of Safety values and active 
load case for GO95 Rules in effect for the state of 
California 
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Command Bar (Alt+ C) 

The Command Bar displays in the Data Entry panel. Click the “?” for help. 

 
 

Shortcut Keys 

Use existing shortcut and function keys to replace menu commands or create new ones. Import and 

export options are also available. The Edit menu provides an option to reset the default shortcut keys 

shown below:  

 

F1  Press F1 to switch to the 3D View.  

F2  Press F2 to switch to the Charts View.  

F3  Press F3 to switch to the Data Entry panel.  

F4  Press F4 to switch to the Measure panel.  

F5  Press F5 to switch to the Reports.  

F6  Press F6 to switch to the Inventory panel.  

F7  Press F7 to switch to the Heat Map.  

CTRL + F7  Press CTRL + F7 to switch to the Capacity panel.  

F8  Press F8 to switch to the Schematic panel.  

F9  Press F9 to switch to the Top View panel.  

F11  Press F11 to save the current changes.  

F12  Press F12 to switch the 3D View to a Bird’s Eye View.   

Insert  Pressing the Insert button while an object is selected in the Inventory 
window will display a shortened list of convenient features.   

(Example: Add objects, select  multiple objects and add notes)  

CTRL + Insert  Press CTRL + Insert to modify an insert.  

CTRL + ?  Press CTRL + ? to switch to the Find Menu Item Window.  

Delete  Press the Delete button to delete objects in the Inventory panel.  
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To create new shortcut keys complete these steps: 

1. Select the Options menu, click the Shortcuts keys option. 

2. In the Shortcut Key Editor window, select any command within the menu list. 

 
 

3. Check the box for the desired keyboard option: Ctrl, Alt, or Shift. 

 

 
4. Select a character from the dropdown menu: A-Z, 1- 9 or F1-F12. 

5. Click Apply, the menu item is now highlighted in yellow. 

6. Click File menu and click Save. 

 
 

Visualization and Color Scheme 

 



[Type here] 

 

 168                   ©2025 Osmose Utilities Services, Inc.  

Edit Render Colors 

Provides the ability to change the color of the equipment displayed in the 3D View. Import or export your 

selections and reset to the default colors. 

 

 
 

Red Green Blue, Red Green, Full Spectrum 
Provides options to change the display colors throughout the application.  

 
 

Options in 3D View 

Camera 

The Camera option provides access to helpful tools based on user preferences to increase lighting and 

provide greater mouse control. 

 
 

Additional Light Source   Provides the ability to brighten the 3D View display area. 

 

 

Mouse Tracking Rates  Allows for greater control of mouse 

movements. Since mouse response rates 

can differ, use these controls to slow down 

or increase the mouse tracking rates. The 

higher the number the slower the 

movement. 
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Alternate Control Scheme   The Alternate Control Scheme enables enhanced navigation from pole 
to pole in the 3D View for use with the Line Design functionality. The 
enhanced navigation differs from the default mode of cylindrical orbit 
controls used for single pole navigation in the 3D View. 

   

Labels 

Allows users to control the display options available in the 3D View panel. Check to enable, uncheck to 
disable any option. 

 
 

Label Elements in 3D View 

Displays equipment names (yellow font) for each object added to the pole. 

 

Measure Cursor 

A display of the current height value when moving the mouse cursor up or down the pole in 3D View. 

 

Show Damage and Decay Markers 

Displays damage and decay markers in the 3D View. 
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Show Sub-Damage and Decay Markers 

Displays sub-damage and decay markers in the 3D View. 

 

Display Direction Arrow > Wind 

Displays a gold arrow pointing to the worst possible wind angle or load angle for the pole.  

 

 

Override Wind 

By default the override wind attribute is set to No. To override the worst wind direction, click the radio 
button to change to Yes and enter the direction the wind is coming from. 

     

Note: You can override the results for the worst wind direction by selecting the Load Case on the 
pole and changing the Override Wind attribute from No to Yes and entering a value for the Override 
Wind Angle. 

 

Display Wind Pressure 

Displays the gold arrow for the worst wind angle derived from the selected load case.  
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Display Direction Arrow > Load 

Displays the purple arrow for the worst load angle derived from the selected load case. 

 
 

 

Display Angles 

Displays numeric values in 10 degree increments around the base of the pole in the groundline above the 
compass marks. 

 

 

Display Heights / Ruler 

Displays a vertical ruler next to the pole in 3D View at 5-foot increments from the ground up. 
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Show Pole Label 

Displays the Pole Number attribute at the top of the pole in the 3D View. The default is Unset, change the 
Pole Number in the Data Entry panel. 

   

 

Show Messenger Only for Bundles 

Prevents communication wires (part of a bundle) from appearing in 3D View displays only the messenger. 

                          Disabled                                                        Enabled 
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Height Filtering 

Provides the ability to filter out the graphics displayed in the Schematic panel when enabled, by sliding the 
scale buttons up or down. 

 

Angle Filtering 

Provides the ability to filter out the graphics displayed in the 3D View by adjusting the angle of the filter in 
Top View. When enabled click and hold on the grey dot icon to move the cursor left or right until the filtered 
area is achieved. 

 

Visualization 

Based on user preference you can limit or expand the scope of pole loading data displayed in the 3D View. 
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Render Deflection Path Bars  - Displays the amount of pole deflection by rendering rectangular bars. 

   

Render Deflection Ghost Pole  - Displays the amount of pole deflection by rendering a shadow. 

 

Exaggerate Ghost Radius  - Displays the amount of pole deflection by rendering a larger diameter 
shadow. 

 

Show Cap Util on Ghost  - Displays the capacity utilization within the Ghost shadow that includes the 
colors that coincide with the vertical Heat Map in the Capacity display area. 
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Render Sweep Visualization  - Displays is a flat visual representation of data that involves a "sweeping" 
action, used to represent spatial or temporal changes. 

 

 

Sweep Visualization 3D Surface  -  Displays is a raised visual representation of data that involves a 
"sweeping" action, used to represent spatial or temporal changes. 
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Render Obstructions  - Displays the obstructions as defined in the Clearance Analysis Tool. 

Render Violations  - Displays the violations as defined in the Clearance Analysis Tool. 

Animate Selected Object (Flash) 

Requires advanced device drivers to display this flashing graphics feature, which causes the selected item 
(insulator in this example) to continuously flash in yellow and grey. 

  

Show 3D View When Pole Opened  - Displays the pole model in the 3D View when opening any .pplx 
file type. 

 

Image Brush Opacity  - Controls the opacity based on a scale of 0-1. Brush opacity determines the 

transparency of brushstroke, controlling how much the underlying image or color shows through. 
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Info Tips and Data 

Based on user preference you can limit or expand the scope of pole loading tips and data displayed in the 
Catalog, Inventory and the 3D View. 

 

 

Inventory Info Tips 

Displays a list of equipment attributes when you hover over the object’s icon in the Inventory panel. 

Note: The Inventory Info Tips and Component Load Info Tips cannot display simultaneously, choose one or 

the other. 

  
 

Component Load Info Tips 

Displays the percent of pole capacity that is consumed by the equipment on the pole when you hover 

over the object’s icon in the Inventory panel. 
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Catalog Info Tips 

Displays the equipment attributes when you hover over the object’s icon in the Catalog panel. 
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Top View Info Tips 

Displays the span attributes when you hover over a “G” icon in the Top View panel. 

 

 

Heat Map Segment Tips 

Displays a subset of an object’s attributes.  The tip will display as you hover over an object in the Heat 
Map panel. 

 

 

 

Heat Map Moment and Load Details 

Displays the full loading details for each element in the Heat map when the courser is hovered over the 

element. 
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Show All Attributes in Info Tips 

Displays an object’s editable attributes when you hover over the object’s icon in the Inventory panel. 

 

Show All Attributes in Data Entry Panel 

Displays all the equipment attributes in the Data Entry panel for the selected object. 
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Remember Attributes Filter Settings in DEP 

Allows you to always use the last filter selected in the DEP (Data Entry Panel) when selecting another 
object. 

  

Show TBD Item Status 

Use to indicate the TBD items in the Inventory panel. 

 

Units Convention 

English is the default unit convention when the application is initially installed.  To change the unit 
convention and select from feet or metric convention complete these steps:   

1. Select Options > Unit Convention. 

 
 

2. The English option offers different formats in which to display values: Decimal 

Feet, Feet Decimal Inches, Feet Fraction Inches, Feet Whole Inches. Select one. 

 
 

3. To select the Metric system option, open the drop-down for the English (U.S. 

Feet) option and select Scientific (Metric). 

 

 

Backward Compatibility Mode 

Use to save PPLX files in a format from a previous version of O-Calc® Pro.  The Backward Compatibility 

Mode also allows a person to use a newer version of O-Calc® Pro to create a PPLX that can be accessed by 

a user with an older version of O-Calc® Pro.  
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Enable / Disable Prompts 

Provides a list of 20+ various warning prompts and the ability to enable/disable them individually based 

on user preference. Check mark indicates the option is currently enabled, click to disable. 

 

Manage Available Reports 

Used to enable/disable 35+ load analysis Reports and 15+ diagnostic Charts on a user-by user basis. 

    

 

Misc. Options – see Appendix D 

Use to enable/disable 20+ feature control options. 
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Manage Plugins 

Used to enable or disable 60+ various plugins on a user-by user basis.  Activating plugins requires you 
restart O-Calc® Pro for the changes to take effect. Some plugins require the input of a license key and 
expiration token. If a pole file is open (.pplx or .pplld) it will need to be closed first before the Manage 
Plugins window become accessible. To manage plugins complete the steps below: 

1. Close any open file(s). Go to the Options menu, select the Manage Plugins option. 

 
2. In the Manage Plugins window select the check boxes for the Plugins you need and 

click the Apply button 

 
 

3. In the Restart? message, click Yes to restart now. 
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4. When O-Calc® Pro has restarted, the Plugins you activated are now available from 
various menus within the O-Calc® Pro menus.  
 

Plugin Name Menu Location 

Allowable Strut Loads for 
Sidewalk Struts 

This plugin works automatically in the background. The strut 
diameter attribute value can be input in the Data Entry panel. 

Clipboard Capture 
Location 

This plugin works automatically in the background. You access 
this functionality inside the Google Earth application by holding 
the shift and control keys and clicking on the map to “capture” 
the pole location. This information is then transferred back into 
O-Calc® Pro. 

Show on Google Earth File menu. 

Soil Data Lookup (NRCS) Tools menu. 

Street View This plugin works automatically in the background. 

 

Help Menu Overview 

The Help menu provides helpful resources in the form of User Guides, Videos, Wiki articles, Technical 

Support Requests, and application version information. 

O-Calc® Pro Help 

Directs you to the Osmose website for User Guides and helpful information related to O-Calc® Pro.  

 

About 

Displays the version of the O-Calc® Pro application that you are currently using. 
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More Information 

Provides access to internet links for O-Calc® Pro videos and wiki articles. Use the Submit Issue or Feature 
Request option to access the O-Calc® Pro Support Page where you can submit an issue, technical 

question, or enhancement suggestion. 

 

Note: Additional information on how to use Plugins, Reports and many other topics can be found at the O-Calc® Pro 
Wiki site. Go to the Help menu, select More Information, click on the O-Calc® Pro Wiki option. 

 

Enter or Change Product Key  

Used to enter the 15 character O-Calc® Pro product registration key. 

 

 

Folders 

Provides access to internal O-Calc® Pro files and helpful information. 

 



[Type here] 

 

 186                   ©2025 Osmose Utilities Services, Inc.  

Key Word and Calculation Shortcuts  
Reposition Objects in 3D View  

Objects can be repositioned from within the 3D View by selecting the object to be repositioned and using 

the following shortcut keys. 

   

Angle “A” Holding down the “A” key and selecting an object 

allows you use the mouse to rotate the object to 

reposition it.   

Vertical “V” Holding down the “V” key and selecting an object 

allows you to use the mouse to reposition the 

object up or down.   

Horizontal “H” Holding down the “H” key and selecting an object 

allows you to use the mouse to reposition the 

object to the left or the right.  (Use the “G” key 

option if the front of the object is facing you).   

Reverse Horizontal 

“G” 

Holding down the “G” key and selecting an object 

allows you to use the mouse to reposition the 

object to the left or the right.  (Use the “H” key if 

the back of the object is facing you)  

  

Units, Heights, Rot., Circ., Comput. Exp. 

When entering data in the Data Entry panel, use any of the helpful key words and calculation shortcuts 

shown below. Shortcuts are not case sensitive. 

 

UNITS  

FFF’II   

  

  

  

  

CTRL+U  

  

Unit Shortcuts:  

FFF’II enters values in feet and inches instead of decimal 
feet.  
(Example: Crossarm>Initial Height attribute enter 40’6)  

  

CTRL+U enables a conversion tool that allows you to easily 
convert an input value.  

  
Enter an Input value, select the convert From/To options in 
drop-down menu. Select OK.  
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HEIGHTS  

TIP-NNN (T-NNN)  

  

  

  

 

HAGL=NNN  

HA=NNN  

  

  

  

REF=+NNN  

REF =-NNN  

  

 

 

T@NNN  

Height Shortcuts:  

Tip adds an object at the tip of the pole.  

tip-nnn allows you to enter feet down from pole tip.  
(Example: tip-3 or t-3 adds an object 3 feet down from the 
tip of the pole)  
  

hagl=nnn changes the end drop and rise of a span based on 
the height above ground line at another pole. Entering ‘sag’ 

values as measured from height above ground line.   
(Example: hagl-38 or ha-38)  

  

ref=(+/-)nnn adjusts ‘height of attachment’ of an object 
relative to another object by entering a height value.   
  
Note: You must enter either a (+/-) sign before the number to 
move the object either above or below the reference object.  

  

t@nnn sets the ‘height of attachment’ or ‘Install Height’ 
value to correspond to the top of an object. 

 

C@NNN  

  

  

  

B@NNN  

c@nnn sets the ‘height of attachment’ or ‘Install Height’ 
value to correspond to the center point of an object.  
  

b@nnn sets the ‘height of attachment’ or ‘Install Height’ 
value to correspond to the bottom of an object.   

ROTATIONS  

ABS=NNN  

AB=NNN  

 

ABS=~NNN  

AB=~NNN  

 

IND=NNN  

  

   

REF=+NNN  

REF=-NNN 

Rotation Shortcuts: abs=nnn sets absolute rotation 
(compass coordinates) to the entered value.  
(example: abs=90 or ab=90)  

 
abs=~nnn adds 180 degrees to the entered value.  
(Example: abs=~90 or ab=~90)  

  

ind=nnn independently rotates an object without effecting 
the rotation of any attached objects.  
 
ref=(+/-)nnn adjusts the ‘rotation’ of an object in reference 

to (relative to) another object by entering a rotation value.  

  
Note: You must enter either a (+/-) sign before the angle to rotate 
the object in a given direction from the reference origin angle.  
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WIRES  

MOE=  

  

  

  

  

  

  

  

  

AWG=NNN  

  

Wire Shortcuts: moe= enables the Modulus of Elasticity 
Calculator.  The MOE value can be adjusted in the 
calculator and populated into the Data Entry panel.  
Note: For additional information on working with the 
Modulus of Elasticity Calculator go to Tools > Misc. 
  

awg=nnn populates the standard diameter from the AWG 
Table.  
(Example: awg=10 will automatically populate the AWG 
Gauge 10 conductor diameter)  
   

CIRCUMFERENCES  

DIAM=NNN  

D=NNN  

  

  

  

Circumference Shortcuts:  

diam=nn enters the diameter which is then automatically 

converted to a circumference value.  

RADIUS=NNN  

R=NNN  

  

(Example: diam=12.5 or d=12.5 will automatically be 
converted to circumference value) radius=nnn enters the 
radius which is then automatically multiplied by two.   
(Example: radius=12.5 or r=12)  

  

EXPRESSIONS 

CTRL+E  
  

Expressions Shortcut:  

ctrl+e enables the Expression Evaluation which allows you 
to enter expression values, the results are automatically 
populated into the Data Entry panel.  

  

 

Enter the 

Expression and select OK.  
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CALCULATOR 

CTRL+F  
  

Calculator Shortcut: ctrl+f enables the Calculator which 
allows you to enter calculations that are then 
automatically populated into the Data Entry panel.  

  

Enter a calculation and select OK.  

  

 

 

Adding Damage and Decay to Wood Pole  
Poles that are not new may have damage or decay.  The Wood Pole Damage Or Decay 

functionality is used to reduce the overall strength of the pole at the groundline, based on any 

damage or decay on the pole.  To add damage or decay to a pole, complete these steps:  

1. Select the pole in the Inventory or 3D View panels and click the Add button. 

 
 

2. Or the Wood Pole Damage or Decay option can be accessed by right-clicking on 

the pole in the Inventory panel. Only one piece of damage or decay can be 

added at a time. 

 
 

3. In the Create New Wood Pole Damage or Decay window open the Type 

attribute dropdown and select a Type from the list. Enter any other known 

damage information, click OK.  
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Note: To undo additions, select Edit > Undo.  

  

 

Damage and Decay Group Object  

Damage or Decay objects can also be grouped together. Create a damage or decay object 
using the process documented above, and simply duplicate the damage or decay object, with 

the original decay object as the parent, and each subsequent damage or decay object as a 
child item. This will prevent a long list of damage and decay items in the Inventory List. 
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Modeling a Multi-Pole Structure  

Begin at the File menu to model a new Wood, Steel, Concrete, Composite or Segmented Fiberglass 

multi-pole structure, complete these steps:  

 

1. Select the structure type from the File > New Pole > select the Multi-Pole 
Structure.  

Note: If there is no default Load case set for the Multi-Pole structure a No default message 

reminds you that a load case must be added to the container object. The calculation for pole 

loading cannot generate results without a load case. 

Note: If a default Load Case has been set it displays automatically in the Inventory panel when the 

structure is created. 

The container object for the multi-pole structure is added to the Inventory, as shown 

below. 
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2. Add one pole of your choice to the container object from the Catalog. 
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3. Open the Wood Pole filter and select the Multi Pole option. 

 
 

4. Enter the Offset value for the distance between the poles from center. 

 
 

5. Select the pole and drag and drop it to the container object to add the second 
pole. 
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Note: When adding a platform between a multi-pole structure it must be added to the container 

object instead of the poles.  

Node Junction 

The Node Junction in an object that helps facilitates connecting Lattice Sections to either 

individual poles or crossarms.  To add a Node Junction to complete these steps:  

1. Select the pole you want to add a Node Junction to.  

  
Note: The Node Junction can also be accessed by-right clicking on the pole in the Inventory panel.  

   
Note: Available tabs are dependent on the corresponding node junction displayed in your 

catalogs or Inventory panel.  
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3. To add a Node Junction from one of the Catalogs, select the appropriate tab and 

select the Node Junction you want to add.   

4. Select the Attribute Values tab to modify the Node Junction attribute values.   

5. Select OK.  

Note: To add additional Node Junctions complete steps 1 – 5.  

  
Note: To undo additions, select Edit > Undo.  

Lattice Section 

To add a lattice section to a multi-pole structure in the Inventory panel, complete these steps:  

1. Select the structure you want to add a Lattice Section to and click the Add button, 
select Lattice Section. 

  

  
Note:  The Lattice Section option can also be accessed by right clicking in the Inventory panel.  

    .   
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Note: Available tabs are dependent on corresponding Lattice Section(s) displayed in your catalogs.  

  
3. To add a Lattice Section from one of the Catalogs, select the appropriate tab and 

select the Lattice Section you want to add.   

4. Select the Attribute Values tab to modify the Lattice Section attribute values.   

5. Select OK.  

Note: To add additional Lattice Sections complete steps 1 – 5.  Note: To undo additions, select 

Edit > Undo.  

  

Add Material to a Lattice Section  

To add material to a lattice section in the Inventory panel, complete these steps:  

1. Select the lattice section you want to add material to.  

2. Select the Add button  and select Material.  
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Note: Materials can also be added by-right clicking on the lattice section in the Inventory panel.  

  
Note: Available tabs are dependent on corresponding materials displayed in your catalogs.  

3. To add Material from one of the Catalogs, select the appropriate tab and select 

the Material you want to add.   

4. Select the Attribute Values tab to modify the Material’s attribute values.   

5. Select OK.  

Note: To add additional beams complete steps 1 – 5.  

  
Note: To undo additions, select Edit > Undo.  

Add Beams to a Lattice Section  

To add beams to a lattice section in the Inventory panel, complete these steps:  

1. Select the lattice section you want to add a beam to.  
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Note: Beams can also be added by-right clicking on the lattice section in the Inventory panel.   

   

Note: Available tabs are dependent on the corresponding beam displayed in your catalogs.  

3. To add a Beam from one of the Catalogs, select the appropriate tab and select 

the Beam you want to add.   

4. Select the Attribute Values tab to modify the Beam’s attribute values, click OK.   

Note: To add additional beams complete steps 1 – 4.  
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Note: To undo additions, select Edit > Undo.  

Add a Lattice Group to a Lattice Section  

To add a lattice group to a lattice section in the Inventory panel, complete these steps:  

1. Select the lattice section you want to add a lattice group to.  

  

  

2. Select the Add button  and select Lattice Group.  

  

 

Note: Lattice groups can also be added by-right clicking on the lattice section in the Inventory panel.  
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Note: Available tabs are dependent on corresponding lattice groups displayed in your catalogs.  

3. To add a Lattice Group from one of the Catalogs, select the appropriate tab and 

select the Lattice Group you want to add.   

4. Select the Attribute Values tab to modify the Lattice Group’s attribute values, click 

OK.   

Note: To add additional lattice groups complete steps 1 – 4.  

  
Note: To undo additions, select Edit > Undo.  

Add Nodes to a Lattice Group  

To add node(s) to a lattice group in the Inventory panel, complete these steps:  

1. Select the Lattice Group you want to add a Node to. 

 

2. Select the Add button, select Add Other, click Node.  
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Note: Nodes can also be added by right clicking on the lattice group in the Inventory panel.  

   
Note: Available tabs are dependent on corresponding nodes displayed in your catalogs.  

3. To add a Node from one of the Catalogs, select the appropriate tab and select the 

Node you want to add.   

4. Select the Attribute Values tab to modify the Node’s attribute values.   

5. Select OK.  

Note: To undo additions, select Edit > Undo.   

Adding Annotation (Notes) 
To add a note and/or calculations to a pole or attached equipment in the Inventory panel, 
complete these steps:  

1. Select the Pole or pole attachment such as the Crossarm. 
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2. Right-click the equipment you want to add a note to, select add Annotation, click on 

Notes. 

   
 

Note: The Notes option can also be accessed by right-clicking on any equipment to add a note.  

 3. Enter a note Title, and the note Content.  

   
 

Edit a Note  

The edit option for a note can also be accessed by right-clicking on a note and either selecting Edit Note, 

Edit Note Contents or View/Print Note. Basic changes to a Notes Description, Note Type, Owner, Author 

or Date can be made right from the Data Entry panel.  Content changes to a Note or Calculations need 

to be completed from within the Note window. To begin to edit a note or the calculations tab from the 

Inventory, complete these steps:  

1. Select the note you want to edit and click the Edit button. 

 
 

2. In the Data Entry click the Contents attribute Press to View radio button. 
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3. Complete your edits to the note contents or the calculations, click File, Save. 

  

Note: To undo the addition of the Note, select Edit > Undo from the main toolbar.  

Change a Note Type  

The note type field allows you to easily flag a structure as needing additional interaction. You can also edit 

a note by right clicking on a note and selecting the Edit Note option. To change the note type, complete 

these steps:  

1. Select the note whose type you want to change, select the Edit button. 

 
2. Select the  Note Type from the drop-down list of choices.  
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Note: To have TBD Notes highlighted in the Inventory panel, enable the option in Options > Info 

tips and Data > Show TBD Item Status.  

 

 

  

Note Type Icons  

The Note icon in the Inventory panel will vary depending on what Note Type is selected.  

Note Type Icons  Description  

  Normal or Info  

  High Priority  

  TBD Initial  

Note: The note, the pole, and the object that the note is attached to 
will  
be  if Show TBD Item  
Status is enabled.  

highlighted 

red 
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  TBD Complete  

Note: The note, the pole, and the object that the note is attached to 

will be highlighted yellow if Show TBD Item Status is enabled.  

  TBD Accepted  

Note: The note, the pole, and the object that the note is attached to 
will  
be  if Show TBD  
Item Status is enabled.  

highlighted 

green 

  

View or Print a Note  

To view or print a note, complete these steps:  

1. Right click on the note you view or print.  

  

2. Select View / Print Note (note display name).  

   

The selected note will automatically display in the Reports panel.   
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Change the Description of a Note  

To change the description that is displayed next to a note icon in the Inventory panel, complete these 

steps:  

1. Right click on the note you want to change the display description for.  

  

2. Select Description of (note display name).  

  

3. Enter the Description you would like to be displayed.  



O-Calc® Pro 8.0                                                                                                  User Guide  

©2025 Osmose Utilities Services, Inc.                                                                                                  207  

   
Note: Select Clear to clear the description field and use the default value.  

4. Select OK.  

  
Note: To undo the display description change, select Edit > Undo.  

Delete a Note  

To delete a note, complete these steps:  

1. Select the Note to be deleted, click the Delete button, or right-click to select the 
Delete option. 

  

 

 

Note: Notes can also be deleted by right clicking on the note to be deleted and selecting Delete 

(note display name). To undo a deletion, select Edit > Undo. 
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Substitute a Note  

To substitute a note, complete the following steps:  

1. Select the note you would like to substitute click the Substitute button.  

  
 

 
Note: The Substitute option can also be accessed by right clicking on the note that needs to be 

substituted and selecting Substitute (Note display name).  

  

Add a Calculation to a Pole or Equipment  
From the Note window, the Calculations tab provides a lightweight spreadsheet that allows you to enter 

values such as numeric and string variables, but it also allows you to enter basic calculations.  Numeric 

values can also be obtained from the selected equipment’s attributes or the selected equipment’s parent 

objects. To add a Calculation to the Note, complete these steps:  

1. Select the Add button and select the Notes option.  

2. Select the Calculations tab.  

 

Note: When working with the Measure panel numeric values can also be obtained from taking 

actual image measurements.   
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In addition to the basic Notes menu options, the Calculations tab also provides the following 

menu options:  

  

Recalculate. Select the Recalculate option to update any formula 
calculations in the spreadsheet.  

Add Row. Select the Add Row option to add a row to the 
spreadsheet.  

Paste. Select the Paste option to paste values only or complete 
text from the Office Clipboard directly into the spreadsheet.  

Copy Sheet. Select the Copy Sheet option to place the sheet on 
the Office Clipboard for use in other applications.  

Item Attributes. Select the Item Attribute option to incorporate 

other values into the spreadsheet from the select equipment or a 

parent’s attributes.  

  

Formula Bar.  Use the Formula Bar to make it easier to view and 

edit a long formula or large amount of text in a cell.    

  

4. Enter data or calculations into the spreadsheet.  

 

Add an Item Attribute to the Calculation  

To incorporate attribute value from the equipment the note is attached to or from a parent 

item, perform the following steps.  Select the field you want the value populated into.  From the 

menu select Sheet > Item Attribute and choose the items whose attribute value you need 
displayed in the spreadsheet.  

  

  

  

String values  
entered in the  
spreadsheet   
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Manually Enter a Formula in Note Calculations 

  
5. From the main menu select File > Save.  

  

  

  

    

Selected  
Crossarm  
Install 

Height  attribute  

Manually enter a formula   
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Add a URI to a Pole Model  
To add a Universal Resource Identifier (URI) to a pole or attached equipment in the Inventory panal, 

complete these steps:  

1. Select the pole or pole attachment. 

2. Select the Add button and select the Linked URI option.  

  

 

 

 

Note: The Linked URI option can also be accessed by right-clicking on the equipment you need to 

add a linked URI to. To undo the addition of the URI, select Edit > Undo from the main toolbar.  

 

Edit a URI   

The URI Description, Owner or Viewer attributes can be changed in the Edit window. To edit 

content changes to a URI within the URI window complete these steps:  

1. Select the URI you want to edit. 

  

 
2. Select the Edit button in the Inventory tool bar. 

 

 

Note: The edit option for a URI can also be accessed by right-clicking on a URI and selecting the Edit 

URI link.  
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3. Select the URI radio button for the URI attribute. 

 

4. Select the Edit URI option. 

 

5. In the Universal Resources Identifier window, enter the URI you would like to use. 

 

6. Select the Test button to verify the entered URI is correct, then click OK. 

 

  
 

Note: To cancel the current URI, select the Cancel option.  The URI change can also be done by 

selecting Edit > Undo from the main toolbar.  
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Set the URI Viewer  

The edit option for a URI can also be accessed by right clicking on a URI and selecting Edit Link. To set the 
viewer you want the URI to open in, complete these steps:  

1. In the Inventory click on the URI you want to select a viewer for. 

 
2. In the Data Entry select the Viewer attribute arrow. 

 

3. Select the Viewer button, and select Built in to have the URI link open within 
the application as a separate tab.  Select External to have the URI link open in a 
separate window outside of the application. 
 

Change the Description of URI 

To change the description which will display next to the URI icon in the Inventory panel, 

complete these steps:  

1. Right click on the URI to change the display description.  

  

2. Select Description of (URI display name) option. 
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3. Enter the Description you would like to be displayed.  

  
Note: Select Clear to clear the description field and use the default value.  

Open a URI Link  

To open a URI Link, complete these steps:  

1. Right click on the URI you want to open.  

  

2. Select View Linked Item to be redirected to the URI location. 

 

3. The URI should take you to the correct location, unless the URI in 

Invalid or empty then the URI Error message displays. 
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Delete a URI  

To delete a URI, complete these steps:  

1. Select the URI to be deleted and click the Delete button.  

  

 

 

Note: URIs can also be deleted by right clicking on the URI to be deleted and selecting Delete 

(URI display name).    

    

Working in the File menu 
To open an existing pole in the Inventory panel, complete these steps:  

1. Select File > Open Pole…  

  

2. Browse the location of the pole to open, select the .pplx file and click Open.  

Save Pole  

To save the pole in the Inventory panel, complete these steps:  

1. Select File > Save Pole.  

  
2. Browse to the location to save the pole and click Save.  

Save Pole As   

To save a pole as a different file name, format or location, complete these steps:  

1. Select File > Save Pole As…  
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2. Browse to the location where you will save the pole and 

click Save.  

Close Pole  

To close the current pole in the Inventory panel, complete these steps:   

1. Select File > Close Pole.  

  
Note: If any changes have been made to the current pole you will be prompted to save your changes 

before closing the pole.  

Preview Mode 
Preview mode is used to quickly review any existing pole template without having to open and close 

the .pplx file. Work cannot be saved while in Preview mode, think of it as a ‘view only’ tool. To begin 

work on a pole from Preview mode select the Preview menu and click the ‘Preview to New Pole’ 

option, you can now work and save your changes.  

 

The pole is automatically displayed in Preview mode within O-Calc® Pro. While previewing a 
pole the O-Calc® Pro typical functionality is limited to a ‘read only’ type of view, meaning no 

work can be saved until you exit the preview mode. The Preview menu offers options to exit 
the mode and save your work. Preview mode ensures you can quickly display any pole 

template available without having to open/close the pole files.  
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Note: If you have an unsaved pole loaded in the Inventory panel you will be prompted to save your 

changes before the pole file is closed. Equipment assemblies cannot be viewed in preview mode by 

themselves, they must first be attached to a pole. 

To enter the Preview mode through a Catalog, complete these steps: 

1. Locate any pole template from the Catalog of your choice to preview. Only complete 

poles can be displayed in the Preview mode from a Catalog, complete poles display 

the pole icon shown below. 

 

2. Right-click on the pole of your choice in the Catalog, select Preview This Pole. 

 

3. The pole appears I the 3D View under the Preview Mode banner. 

 

4. To exit Preview mode, go to the File menu location (next to the Edit menu shown 

below), it currently displays the Preview menu. Select the Close Preview option. 
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Preview to New Pole 

Use Preview to New Pole to begin work on the pole with the ability to save your work. No work can be 

saved in Preview Mode. Or select the Preview to New Version to add a new pole version to an existing 

.pplx file. To create a new pole from the pole you are currently previewing, complete these steps:  

1. Select Preview > Preview to New Pole.  

  
Note: Once Preview to New Pole is selected the Preview Mode is automatically closed.   

2. Complete any modifications to the new pole.  

3. Select File > Save to save the new pole. 

Preview Menu 

The Preview menu provides a variety of options:  

  

Preview to New Pole. Select the Preview to New 
Pole option to convert the currently previewed 
pole to a new pole.  

Preview to New Version. Select the Preview to 
New Version option to convert the currently 
previewed pole to a new version.  

Open Previewed Pole. Select the Open Previewed 

Pole option to open the currently displayed 

preview pole and exit preview mode. 

 

Close Preview. To close the pole, you are 

previewing and exit Preview Mode  

  

Preview to New Version  

To create a new version from the pole you are currently previewing, complete these steps:  

1. Select Preview > Preview to New Version.  

  
Note: Once Preview to New Version is selected the Preview Mode is automatically closed   
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2. Complete any modifications to the new version.  

3. Select File > Save to save the new version.  

Open Previewed Pole  

To open the pole you are currently reviewing, complete these steps:  

1. Select Preview > Open Previewed Pole.  

  
Note: Once Open Previewed Pole is selected the Preview Mode is automatically closed.   

2. Complete any modifications to the pole, select File > Save.  

 

Additionally, Preview mode can be accessed through File Explorer using the File menu. To access 

Preview Mode from the File menu complete these steps: 

1. Select the File menu, select More Options, and click Preview Pole. 

  

2. Select the Browse button and navigate to the .pplx file(s) you would like to preview, 

click OK. 

  

3. Select the .pplx file you would like to preview. Select OK.  

 Note: Select Open to open the selected .pplx file in edit mode instead of Preview Mode.  Select Cancel to 

close the Preview Pole window. 

  

Pole Reviewer 
The Pole Reviewer allows you to quickly locate pole files (.pplx) within a directory. You can work through a 

list of poles, quickly load them, make edits, save your work automatically, and move along to the next pole 

in your list to edit. Complete these steps to use the Pole Reviewer:  
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1. Select the File menu, select More Options > Pole Reviewer.  

   
2. Click the Browse button and browse to the Directory that has the .pplx files, click 

OK.  

  
3. The first pole in the list automatically displays. Complete any modifications to the 

pole and select Next to load the next .pplx file in the Inventory panel. The changes made 

are saved automatically when the Auto Save check box is selected. 

4. To obtain the updated loading Capacity results for your changes click the red 

Manual button at the bottom of the screen.  

 

Note:  If the Auto Save option is deselected you will be prompted to save the changes to each .pplx file 

you change.  

5. To close the Pole Reviewer click the red “X” in the upper right-hand corner. 
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Set a Default File Name  
The Default File Name Mask provides the ability to use a reporting token to create a 

default file name to match a specific naming convention. A token can be copied and 

posted from the valid token list into the Default File Name field. To set a default file 

name, complete these steps:   

1. Select File >More Options > Set Default File Name.  

 

Note: A pole does not need to be open to set a default file name.   

2. Enter the file name token you would like to use. 

  

3. Select the Help button in the Default File Name Mask window to view a list of tokens: 

 
4. Select Test to preview a display of the default file name, click OK. 
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Note: To cancel the current Default File Name, select the Cancel Option.  

After you set the Default File Name, the first time you save a pole the default file name token 

automatically displays in the file name. Once the pole has been saved with a specified name, it will not 

update the file name default File Name, unless a save Pole As…action is performed. 

 
 

 

  

  Default file name token   
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Master Catalogs  

Setting a Default Load Case  

Load cases are used to group a series of loads, boundaries and safety conditions into loading 

district environments.  The Master Catalog provides a dynamic listing of load cases broken down 

into categories.    

For each category, a default load case can be specified dependent on pole type.  This can aid in 

ensuring the correct load case is applied each time a pole of that category/type is created.   

Use the following steps to set a default load case for each pole category:  

1. Expand the Master Catalog folder.  

2. Expand the Load Cases folder until the catalog list you need is displayed.  

  
Note: A default Load Case can only be selected from the Master Catalog.  

3. Right click on the Load Case you want to set as the default.  

4. Select Set as the default Load Case and select the pole type.  

 
5. Select OK to the verification message. 
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User Catalogs 
Add a Subfolder  

To add a subfolder to the User Catalog, complete the following steps:  

1. Right click on the User Catalog folder you want to create a subfolder for.  

  

2. Select Add Subfolder. 

 

3. Enter the Name for the subfolder.  

  
4. Click OK.  

  
Note: Undo is not available.  

Note: Once a subfolder has been added to the User Catalog, additional folders can be added to 

that subfolder by selecting the Add button  or by right clicking on the subfolder and 

selecting Add Subfolder.   

Remove a Subfolder  

To remove a User Catalog subfolder, complete the following steps:  

1. Select the User Catalog folder to be removed.  
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Note: The selected User Catalog folder can also be removed by right-clicking on the folder and 

selecting Remove (name of the folder).  

3. Select Yes to permanently remove the selected folder.  

Note: There is no undo for this operation.  

Rename a Subfolder  

To rename a User Catalog subfolder, complete the following steps:  

1. Right click on the User Catalog folder to be renamed.  

2. Select Rename Folder.  

   

3. Name the selected folder.  

  

4. Select OK.  

  
Note: There is no undo for this operation. 

2.   Select the  Remove   button  .   
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Add Equipment to a Subfolder  

Available tabs are dependent on the corresponding equipment displayed in your catalogs or Inventory 
panel. To add equipment to a User Catalog subfolder, complete the following steps:  

1. Right click on the User Catalog subfolder that equipment will be added to.  

2. Then select the equipment to be added from the equipment list.  
Note: Only one piece of equipment can be selected at a time.  

 
 

 

3. To add equipment from one of the Catalog tabs or the Inventory tab select 

the appropriate tab and select the equipment you want to add. 

  

4. Select the Attribute Values tab to modify any attribute values. Click OK.  
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Equipment can have attachments (Example: A crossarm can have insulators and spans attached to 
it).  To add additional attachments to equipment, complete the following steps:  

5. Right click on the equipment you want to add additional equipment to.  

6. Select the equipment to be added from the equipment list.  

   
Note: If multiple pieces of equipment are displayed in the list, only one piece of equipment can 

be selected at a time.  

  
Note: Available tabs are dependent on the corresponding equipment displayed in your catalogs or 

Inventory panel.  

7. Add additional equipment from one of the Catalog tabs, i.e. within the 

‘Create New Guy Brace’ window (shown above) or use the Inventory and 
select the equipment you want to add. 
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8. Select the Attribute Values tab to modify the equipment’s attribute 

values, click OK.  

Note: There is no undo for this operation.   

 

Edit Attributes in a Subfolder  

To edit equipment attribute(s) in a User Catalog subfolder, complete the following steps:  

1. Right click on the equipment whose attribute(s) you want to edit.  

2. Select Edit (equipment display name).  

     

3. Complete your edits to the equipment attributes. Click OK.  

  
Note: Certain attributes are only editable in Administrative User Mode.  

Delete Equipment in a Subfolder  

To delete equipment in a User Catalog subfolder, complete the following steps:  

1. Right-click the equipment to be deleted, select the Remove option.  
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2. Or select an item and click the Remove button in the tool bar menu.  

 

Change the Display Description  

To change the description that is displayed next to the equipment icon in a User Catalog subfolder, 

complete the following steps:  

1. Right click on the equipment you want to change the display description of.  

2. Select Description of (equipment display name).  

   

3. Enter the Description you would like to be displayed, click OK.  

  
 

Note: Select Clear to clear the Description field and reset it to the default value.  
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Working in 3D View 
The 3D View is a three-dimensional interactive image of the Inventory panel.  As equipment is added to 

the pole in the Inventory the 3D View is automatically updated with those changes.    

Structures can also be created or edited in the 3D View and automatically added in the Inventory. 

  
Note: Any selected object in the Inventory is rendered in the 3D View in yellow.   

 

Mouse Controls 

The 3D View provides several ways to reposition the 3D View to better analyze the pole and the objects 

attached to the pole. You can use the mouse wheel to interact with the 3D View.   

 

Mouse Wheel To zoom in or out scroll the mouse wheel forward or backward.   

Right Mouse 

Click 

Click and hold down the right mouse button to pan the 3D View to the left, right, 

up or down, and orbit around the camera look point.  

Left Mouse Click Click and hold down the left mouse button to either rotate the 3D View or move 

the 3D View vertically up and down.  Left mouse button click and moving mouse 

left-right will rotate the image.  Left mouse button click and moving the mouse 

up or down will vertically move the viewing perspective of the 3D View down or 

up.    

Invert Mouse 
Wheel 

Inverting the mouse wheel changes the zoom in/out movement of the mouse 
wheel.  
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To invert the mouse wheel, go to Options > Misc. Options > User Interface 

Conventions > Invert Mouse Wheel.  

Invert Left Mouse 

in 3D X or 3D Y 

To invert these movements, go to Options > Misc.  

Options > User Interface Conventions.   

Invert Right 
Mouse in 3D X or 

3D Y 

To invert these movements, go to Options > Misc. Options > User Interface 
Conventions. 

Menus Right to 

Left 

To change the menu orientation 

 
Click the R button to return to the isometric view 

 
Click the B button to return to the Birdseye view 

 
Click the grey space between the R and B buttons to access 3D View options to 

save, copy, or print. 

 

Filter Options  

The 3D View offers tools to review and interact with the 3D image. Options can be enabled or disabled by 

clicking on them (toggle on/off). Options displaying a check mark icon are enabled. 

   

    

  
All Types of spans can be toggled off/on individually or All 
On/All Off, to narrow the scope of data being displayed.  
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Used to edit the span render size. You can display various 
thicknesses used to enhance the 3D View of spans; 1X, 2X, 
4X, 8X, 16X.  

  
  

      

Pole Attribute Edits 
Setting Depth of a Pole  

To set the depth of a pole, complete these steps:  

1. Right click the pole in the 3D View.  

2. Select the Setting Depth of (Pole display name).  

  

3. Select the Mode from the drop-down list and enter the Depth in feet. Click OK.  

  
Note: The Depth in Feet field will automatically display the default pole depth when initially opened.  

Set the Above Ground Length in Feet of a Pole  

To set the length of a pole, complete these steps:  

1. Right click on the Pole you want to set the length for.  

2. Select the Set Length and Depth option.  

3. Select Above Ground Length of (Pole display name).  
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4. Select the Mode from the drop-down list and enter the AGL in Feet.  

  

5. Select OK.  

Note: To undo the AGL Length change, select Edit > Undo.  

Set the Length in Feet of a Pole  

To set the length of a pole, complete these steps:  

1. Right click on the Pole you want to set the length for.  

2. Select the Set Length and Depth option.  

3. Select Length of (Pole display name).  

  

4. Select the Mode from the drop-down list and enter the Length in Feet.  

  

5. Select OK.  

Note: To undo the Length change, select Edit>Undo. 
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Add Equipment to a Pole  

To add equipment to a pole in the 3D View, complete these steps:  

1. Right click the pole in the 3D View.  

2. Select the Add Element option.  

3. Select one piece of equipment from the list of available choices.  

Note: Only the equipment which can be added to a pole appears in the list of choices.  

  
Note: Only one piece of equipment can be added at a time.  
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Note:   Available tabs are dependent on the corresponding equipment displayed in your catalogs or 

Inventory panel.  
  

4. To add a crossarm from the Catalog tabs or the Inventory tab select the 

appropriate tab and select the crossarm you want to add.  

5. Select the Attribute Values tab to modify the crossarm’s attribute values.  

6. Click OK.   

Note: To remove the added equipment, select Edit > Undo.  

Equipment can have attachments (Example: A crossarm can have insulators and spans attached to it).  To 
add additional attachments to equipment, complete these steps:  

7. Right click on the equipment in the 3D View that you want to add any 

additional equipment for.  

8. Select Add Element or Add Spans and Related and select the equipment to be 

added from the equipment list.  

  
 

Note: Only one piece of equipment can be selected at a time.  

  
Note: Available tabs are dependent on the corresponding equipment displayed in your catalogs or 

Inventory panel.  
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9. To add an insulator from one of the catalog tabs or the Inventory tab select the 

appropriate tab and select the insulator you want to add.  

10. Select the Attribute Values tab to modify the insulator’s attribute values, click 

OK.  

 

Working with Jumper Cables  

Jumper cables can be generated between two insulators on a pole, or between an insulator and a 

terminal point. To add the Jumpers where you designate them to begin and end, completed the steps 

below. 

Creating a Jumper on a Double Dead-end  

To Jumper between two dead-end insulators follow the following steps:  

  

1. Select the first dead-end insulator.  

2. In the Data Entry panel, filter the view to ‘Jumper’ to see only the relevant 

information on jumpers and enter the name for the Jumper ID attribute in the 

first row. 

  
 

3. Select the second dead-end insulator. This dead-end insulator is the Jumper 

Target dead-end for the jumper cable, enter the name for the Jumper ID 

attribute in the second row. 

 
 

4. The jumper is automatically added to the designated insulators. 
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Using the Split and Jumper Option  

Instead of creating a jumper through the data entry panel as described above, the user can instead use 

the split and jumper method. For this tool the following conditions need to be met.  

1. There is only one dead-end insulator required  

2. That dead-end insulator has two spans attached to it, in opposite 
directions To use this method, right-click on the dead-end insulator and select Split 

and Jumper Insulators option. 

  

  
 

 

 

 

 



[Type here] 

 

 238                   ©2025 Osmose Utilities Services, Inc.  

Mirror Spans 

The automated option for adding Jumpers is to use Mirror Spans. Mirror Spans adds the insulator, 

conductor and the jumper all at the same time.  

 

To use the Mirror Spans operation complete these steps: 

 

1. Begin with a Dead End pole model. 

  
 

2. Right-click one of the Insulators in the 3D View or the Inventory panel and 

select the Mirror Spans option. 

 
 

3. The Jumper, Insulator and Span are added. Repeat to add more. 
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4. Repeat the Mirror Spans operation to add more. 

 
   

Working with Guying Systems 
Auto-Guy  

To properly guy a structure in O-Calc® Pro use the Auto-Guy automated guying functionality.  The Auto-
Guy uses the worst wind direction calculation to determine the lead angle placement of the anchor. And 

the pole deflection is used to determine the lead length of the Anchor. The goal of the Auto-Guy is to 

lower the Maximum Capacity Utilization (%MCU) as much as possible and best support the pole. 

To use Auto-Guy, you must first select an anchor and guy assembly to be the default auto-guy assembly. If 

multiple guys are attached to the default anchor/guy assembly the topmost attachment height is used in 

the ‘Set height at’ (shown below) window. Additional guy wires are then attached below the highest one 

at two foot intervals.  

An Auto-Guy default can also be set from a User Catalog and can contain up to three attached guy wires 
per anchor/guy assembly.  

To set up a default auto-guy assembly, complete these steps: 

1. From the Master Catalog right-click on a guy and anchor assembly: Anchor for Down 

Guy, Anchor for Sidewalk Guy, Stub Pole for Span Guy. 

 

2. Select the Set as the default “Auto-Guy” assembly option. You can change the Auto-

Guy at any time by selecting another assembly. 
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The O-Calc® Pro Auto-Guy functionality allows you to manually change Anchor and/or Guy attributes. 

Edits can be made to the anchor lead angle and lead length, plus the guy wire attachment height to 
ensure the structure is guyed properly based on scenarios unique to the pole.   

To use the Auto-Guy function in the 3D View or in the Inventory, complete these steps:  

1. Right-click in the Inventory or the 3D View on the approximate location on the 

pole where you want the Down Guy Install Height placed. 

2. Select the Auto-Guy option.  

 

3. The point at which you right-click on the pole enters the Install Height for the 

guy in the Edit window, accept it or enter your own value, click OK. 

 

4. Verify and edit any Anchor attributes. Select OK.  

Note: The maximum numbers of guy wires in an Auto-Guy assembly is three. 
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Note: The deflection of the pole was used to set the lead length.  The anchor and guy wire are 

automatically added to the pole based on the default Auto-Guy you set. The lead angle is determined 

based off the worst wind angle for the pole before the anchor/guy assembly was added.  

Extra Guy 

To automatically add extra down guys to an anchor already displayed in the 3D View, complete these 

steps:  

1. Select the Anchor that you want to add an additional down guy to in the 3D 

View.  

2. Right click the area on the pole where you want the additional down guy 

placed, select the Extra-Guy option. 

 

3. The Extra-Guy operation is completed as shown in the 3D View below.  



[Type here] 

 

 242                   ©2025 Osmose Utilities Services, Inc.  

  
Note: Extra guy wires can be added to existing anchors as needed, you must select the anchor first.  

Guy Type Descriptions 

The Type attribute gives users the ability to change the guy type. Guy wires may be pretensioned to a 

desired value before environmental loads are applied. To change a down guy into another type of guy, 

complete these steps:  

1. Select the Guy Wire in the Inventory or 3D View panels.  

2. In the Data Entry, select the drop-down arrow next to the “Type” Attribute.  

  

3. Select the Guy Type from the list to suit the pole design.   
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The Type attribute offers several options for the type of guying being utilized. See those choices below. 

 

Guy Type Description 

Crossarm (Crossarm Down 

Guy)  

Use to model a standard down guy, with the ability to make the 

attachment point a crossarm instead of the pole.   

Crossarm Span (Crossarm 

Span Guy)  

Use to model a standard span/head guy, with the ability to 

attach the guy wire to a crossarm instead of the pole.   

Down (Down Guy)  Use to model as an anchor set at a given distance and angle 

away from the pole, with one or more attached guy wires.   

Pushbrace  A pushbrace is a pole that supports the structure being modeled, 
rather than using an anchor/guy wire combination.   

Note: The pole height and class of the pushbrace pole cannot be set.   

Sidewalk (Sidewalk Guy)  A sidewalk guy models an anchor set at a given distance and 
angle away from the pole with one or more attached guy wires 
connected to one or more struts.  

Use of this type creates a new filter option in the data entry 

panel called Sidewalk.   

Span/Head (Span Guy)  A span guy, also called a stub guy, or a guy to a stub pole, models 

a blue “stub pole” and one or more associated guy wires.   

Truss (Truss Guy)  A truss guy models a guy wire with several attachment points on 

the pole, rather than an attachment point connected to an 

anchor on the ground. This model also includes two struts.   

 

Mirror Guys 

The Mirror Guys option is used to easily copy, in the opposite (mirror) direction, any guy object 

in the Inventory that is attached to the pole. To perform the Mirror Guys operation complete 

these steps:  

1. Right-click on the pole, anchor, or guy wire in the Inventory panel, and 

select the Mirror Guys option. 

 
2. The operation is completed as shown in the 3D View below. 
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Guy Wire Tension  

Guy wires may be pre-tensioned to a desired value before environmental loads are applied.  

  

1. Select the Guy Wire you want to change the Tension value for.  

2. In the Data Entry change the filter from Standard to Tension.  

   
3. Change the Tension Mode attribute drop-down menu from Calculated to Manual.  

   
4. Enter the Man Tension (Manual vs. Calculated) attribute value as desired. 
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Merge Like Struts (Compression)  

Combine comparable struts into one strut for analysis as a single entity. The struts need to be placed on 
the pole on the same anchor and at the same height, angle, and length before they can be merged.  

Struts are combined automatically with the Merge Like Struts attribute set to Yes (which is the default) 

setting.  To unmerge (separate) the comparable struts, complete these steps:  

1. Select the guys you would like to unmerge in the Inventory panel.  

Note: Multiple guys can be selected concurrently by holding down the ctrl key.  If the guys are 

displayed next to each other hold down the shift key to select a range of items.  

   

2. In the Data Entry panel toggle the Merge Like Struts attribute to No.  

 

 Note: All results in O-Calc® Pro are automatically recalculated and updated to reflect the attribute 

selection.   

  

Note: O-Calc ® Pro provides a Strut Evaluation Summary so you can easily evaluate the load applied to 

a sidewalk guy strut arm by the guy or guys impinging upon it. 
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Calculated vs. Manual Guy Brace Tension 

O-Calc ® Pro offers the ability to set a minimum tension on a guy brace regardless of the environmental 

loading. This Over-tension attribute is found on the Guy Brace object. This field does not apply any 

tension to the guy if the regular pole loading is greater than the value the user sets. If the pole loading 

doesn’t apply greater tension than the Over-tension value, the Over-tension value is applied. To edit the 

Calculated tension and enter a Manual Tension value completed these steps: 

1. Select any guy brace object in the Inventory or 3D View panels. 

 
2. Select the Tension Mode attribute drop-down menu, click on the Manual option. 

 
3. Enter a value in the Man Tension attribute. The calculation results are updated. 

  

Working in the 3D View 
Place the 3D View on the Clipboard   

You can save the current 3D View to a .png file or place it on a clipboard, to use later.  To place your 
current 3D View on the clipboard, complete these steps:  

1. Select View > Save 3D View to > Clipboard.  
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Note: A Copy 3D View to Clipboard option is also available by holding down the ctrl key and right 

clicking on the 3D View background display.  

Save the 3D View   

To save your current 3D View to a .png file, complete these steps:  

1. Select View > Save 3D View to > Image File.  

  
Note: To adjust the size of the 3D View image being saved select Saved Image Size.  

Note: The Save 3D View to File option can also be accessed by holding down the ctrl key and right 

clicking on the 3D View background display.  

2. Navigate to where you want to save the 3D View .png file and select Save.  

3. Select OK to the confirmation message.  

  

Print the 3D View   

To print the current 3D View, complete these steps:  

1. Select View > Save 3D View to > Print 3D View (or Ctrl + right click on 3D View 

background).  

  
 

Filter the 3D View   

Use the Filter button to affect the display in the 3D View. Only the objects that are expanded in the 
Inventory panel will display in the 3D View, complete these steps:   
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1. Collapse any objects with attachments (assemblies) in the Inventory by 

clicking on the minus sign. Clicking the plus sign in the Inventory expands the 
assembly. 

 
 

2. In the Inventory panel, click the Filter button. All the objects that were 

collapsed in the Inventory panel are not displayed in the 3D View. 

 

3. To reset the filtered display in the 3D View click the Sunglasses icon or click 
the Filter button in the Inventory. 

  
 

4. Or turn the filter off by selecting View > Reset All Filters. 

 
 
 

Understanding Pole Loading Capacity 
The Capacity panel has three options for viewing pole loading results: Meter, Numeric, and Factor of 

Safety Display. The Capacity panel displays the MCU (% of allowed Maximum Capacity Utilization) pole 

loading results achieved by the O-Calc® Pro calculation engine.  
 

Auto Capacity Summary  

If the Auto Capacity Summary is enabled a recalculation automatically occurs anytime an edit is made to a 
pole model. This feature is enabled by default, but it can be disabled (turned off) if necessary.  

    

  
These objects are  
collapsed in the  
Inventory panel  
but are displayed  
in the 3D View.   
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1.  The Auto Capacity Summary is enabled (see check mark) by default.  

 
 

2. When the Auto Capacity Summary is disabled, you must click the red Ready 

button located in the tool bar below the meter to initiate the O-Calc® Pro calculation 

engine to obtain pole loading results. This “manual” process is required each time 

an edit to initiate the pole loading results. The yellow Recalculation Needed 

message indicates the Auto Capacity Summary is currently disabled.

 

 

Note: An additional way to manually update the Capacity results can be found in the View menu 

by clicking on the Update Capacity Summary option.  

 

Capacity Meter Display 

The O-Calc® Pro Capacity panel is automatically updated each time a change is made to the selected 

pole, by default. There are three different options available to display the pole loading results: Meter, 
Numeric, and Factor of Safety.  Only one option can be displayed at a time.  
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In addition to the meter (gauge) display a color coded vertical stress chart indicates the stress on pole. 

Below the meter, color coded horizontal banners call out MCU status messages to alert the user 
concerning pole overloading or overturning, and guy/anchor adequacies or insufficiencies. 

 
 

 
 

Numeric Display  

The Numeric Capacity Display shows the loading calculation details for maximum and groundline 

moment, capacity utilization results, wind direction and anchor/guy adequacies. Options can be 

enabled/disabled by clicking (toggle on/off) on them. The check mark means enabled.  

To enable the Capacity Numeric Display, complete these steps:  

1. Select the Capacity Numeric Display option to enable it. 

 

2. The pole loading results are displayed for Groundline and Maximum Capacity 

Utilization Moment. % MCU results by Max, GL, Buckling sorted by Height, 

Wind Angle and Load Angle categories. 

      

  
  

  

Pole Stress  
Chart   

% of Pole  
Capacity  
Gauge   

Guy Status   

% of   
Allowed  
MCU  
Results   
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Factor of Safety Display  

The O-Calc® Pro Factor of Safety Display provides the pole loading results displayed within categories 
unique to the GO95 regulations for the State of California. To enable the Factor of Safety Display, 

complete these steps:  

1. The Factor of Safety Display option is enabled by clicking on it as evidence of 

the check mark. 

   

 

 

 

Capacity Meter Thresholds   

The following tables describe the default color representations in the Pole Stress Chart and the Percent of 

Pole Capacity Gauge. Color Legend is also available from the Tools > View Color Legend. The Capacity 

Meter display color schema can be changed by selecting a color schema from the Options > Visualization 

Color Scheme menu. 
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Display 

Color  

Description  Display 

Color  

MCU  

Thresholds  

Description  

Blue  0% Pole Stress  Green  < 80%  Acceptable 

Capacity  

Green  …  Yellow  80% to 89.9%  Near  

Capacity  

Yellow   50% Pole Stress  Orange  90% to 99.4%  Near  

Capacity  

Orange  …  Red  99.5% or 

above  

At or Over 

Capacity  

Red  100% + Pole 

Stress  

      

          Acceptable Pole Capacity Example        Failed Pole Capacity Example  

  

Capacity Menu Copy Options   

Right clicking on a Capacity panel background provides Copy Image and Copy Data options.  

         

 

Copy Image.   Select the Copy Image option to copy the current 

Capacity panel as an image to the clipboard so that the image of the 

Capacity panel can be pasted directly into other applications such as 
Microsoft Word, E-Mail, and Notepad etc. 
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Copy Data.  Select the Copy Data option to 

copy the Capacity panel data to the clipboard 
so that the Capacity panel data can be 

pasted directly into other applications such 

as Microsoft Word, E-Mail, etc.  

Cancel. Select the Cancel option to close and take no action.  

 

Working in the Data Entry 
The O-Calc® Pro Data Entry panel works in conjunction with the Inventory panel. When selecting an 
object(s) in the Inventory panel the object’s attributes are displayed in the Data Entry panel. This provides 

a comprehensive way to review or make changes to editable attributes.    

Editing Attributes   

Certain attributes are only editable in Administrative User Mode. If you are not in Administrative User 

Mode, the attribute will be grayed and not changeable. If additional attributes are available a drop-down 

menu will display next to the selected object’s name in the Data Entry panel.  Select the drop-down 

menu to display additional attributes. To edit an attribute, complete these steps:  

1. Select an object in the Inventory panel.  

  

2. The selected object displays in the Data Entry panel.  
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3. Select an attribute to be edited, enter the value. 

  
Note: For a complete list of the editable icon’s descriptions Editing Equipment Attributes.  

 

Expand All Attributes   

By default, the Standard list of attributes is initially displayed in the Data Entry panel when an object is 

selected in the Inventory panel.  To change the default setting so that all the selected object’s attributes 

are displayed, complete the following steps:  

1. Select Options > Info Tips and Data > click the Expand all Attributes in Data Entry 

Panel option. 

   

Note: All options can be enabled/disabled by simply clicking on them (toggle on/off) again. Any 

enabled option displays the check mark symbol indicating it is on.   
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Display Multiple Attributes   

When multiple objects are displayed in the Data Entry panel all like objects are automatically grouped 

together. To display multiple objects for review or editing from the Inventory panel, hold down the ctrl 

key to select more than one object out of sequence.  Hold down the shift key to select a range of objects 

next to each other in the Inventory list. Complete these steps:  

1. Select any objects in the Inventory panel.  

  
  

2. The selected objects are displayed in the Data Entry panel.  

  
 

Display Multiple Corresponding Attributes   

It is easy to display multiple objects that are of a specific type on the same hierarchy level, for review or 

editing from the Inventory panel. Hierarchy levels (parent-child relationships) indicate how objects are 

connected. A visual indicator of hierarchy levels is the dotted lines in the Inventory which show the 

connections between objects. Complete these steps:  

1. Right click on any object in the Inventory panel.  

2. Select the Select All of Type option.  
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3. The selected object and any like objects within that hierarchy level are displayed in 

the Data Entry panel.   

  
 

 

Creating a Custom Filter 

To create a Custom Filter containing a list of attributes to view in the Data Entry panel. A Custom Filter 

listed can be deleted in the Custom Filter Editor window. If the custom filter is displayed in the Data Entry, 

it cannot be deleted. To delete, first deselect the customer filter, then you can delete it in the Custom 

Filter Editor window. Complete the following steps:  

1. Select an object in the Inventory panel. In the Data Entry panel, select the 
attributes filter drop-down menu arrow.  
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2. Select the Custom Filters option. 

 

3. The Custom Filter Editor window opens; click the Add Filter button. 

 

4. Enter a name for the new Custom Filter, click OK. 

 

5. Check the boxes for the attributes you want included in the custom filter and 

click OK. 



[Type here] 

 

 258                   ©2025 Osmose Utilities Services, Inc.  

  

6. In the Data Entry, open the filter and the new Filter Name is displayed at the top.  

 

 

Delete a Custom Filter 

To delete the Custom Filter complete these steps: 

1. Click the Del Filter button. 
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2. In the Delete? window, click the 

Yes button.  

3. Then click OK to close the Custom Filter Editor window. 

 

Working in the Schematic View  

The O-Calc® Pro Schematic panel displays a side elevation view of the major equipment on the pole.  Within 

the Schematic panel you can change the height of the equipment, view basic information about the 
equipment, or filter the scope of the data displayed.  

 

Schematic Menu Options   

Right clicking on the Schematic panel background provides several options.  
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Save Schematic View to File. This option 
saves the current Schematic View as a 
variety of file types (JPEG, BMP, GIF or 
PNG)  

Copy Schematic View to Clipboard. This 
option copies the current  
Schematic View to the clipboard so that 
the Schematic View can be pasted 
directly into other applications such as 
Microsoft Word, E-Mail, etc.  

Print Schematic View. This option prints 
the currently displayed Schematic View.  

Cancel. This option closes the available 

Schematic View options without taking 

any action.  

 

Display Above GL Portion Only   

To display only the portion of the pole above the groundline (GL), complete these steps:  

1. Check the Above GL Portion Only box to display only the portion of the pole 

that is above the groundline.  Un-check the box to display the complete pole. 

   

Display Draft Pole Break   

To replace a portion of the pole with no attachments with a drafting break, complete these steps:  

1. Check the Draft Pole Break box to insert a temporary drafting break.  Un-check 

the box to display the entire pole.  

  

Change Equipment Height   

To edit the equipment height, complete these steps:  

1. In the Schematic View, click on the equipment height label you would like to 
change.  
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2. In the Edit window enter a new height for the equipment. Click OK. 

   
Note: To undo a height modification, select Edit > Undo.  

To filter the spans on the pole according to height, complete these steps:  

1. Go to the Options menu, select Options in 3D View, select Height Filtering.   

  

 

2. Slide the button(s) up/down to use the Height Filtering. Click the R to remove.  
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Note: If you have multiple filters set you can remove just one or all the filters by right clicking on the  

Sunglasses  button and select one of the Reset Filter options: All, Height, Angle.  

  

 

  

  

    

  

  

Only the filtered span heights  
are displayed in 3D View   

A filter notification (sunglasses)  
icon is added to the 3D View   

Constraints of the  
Height Filter scale   
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Charts 
Once a pole is completed in the Inventory in O-Calc® Pro you may want to perform additional analysis by 

consulting several predefined charts.  

  
Note:  A pole needs to be displayed in the Inventory panel for data to display in the Charts.  

 

Chart Menu  

The O-Calc® Pro Charts toolbar menu provides you with a variety of operations and options.   
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File. The following options are available from the File menu:  

Print Chart.  Select the Print Chart option to print the currently 
displayed chart.  

Page Setup. Select the Page Setup option to configure how the chart 
will be printed.  

Print Preview. Select the Print Preview option to preview the 

currently displayed chart exactly as it will be printed.  

  

Condition Selector. Select MCU to see data at maximum capacity 

utilization or select GL to see data at groundline.  

  Chart. Select the desired Chart to display from the drop-down menu.  

  

Ignore Sign. Check the Ignore Sign option to ignore the Trans/Long 

values.  

  
Northing / Easting. Check the Northing / Easting option to plot the 

individual component vector lines in the selected chart.  

  

Magnitude. Check this option to plot the Magnitude line in the 

selected chart.  

  Capacity. Check this option to plot the Capacity line in the selected 

chart.  

  
Total. Check this option to plot the sum of the individual components 

in the selected chart.  

  Left\ Right arrows. Select the left\ right arrows to scroll through and 

display the various charts without having to use the chart drop down 

menu.  

Note: Available plotting options are dependent on the selected chart.  

Chart Options 

As soon as the Chart has been selected from the list it automatically displays in the Charts panel. The 

chart uses the currently selected Load Case when calculating and displaying a chart. To view any Chart, 

complete these steps:   

1. Load a pole that has a Load Case in the Inventory panel.  

2. Select a Chart to be displayed from the available Charts drop down list.  
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Note:  Use the mouse wheel to zoom in and out on a specific area on the chart. To set the chart back 

to the default scale right-click anywhere on the Chart, select Set Scale to Default.  

Chart Menu   

In addition to the basic menu options that are available, once a chart is displayed additional chart options 

are available by right clicking on the chart.  

  

  

Copy.  Use to copy the current chart to the clipboard so that 
the chart can be pasted into other applications such as 
Microsoft Word, E-Mail, etc.  

Save Chart.  Use to save the current chart as a variety of file 
types (JPEG, BMP, GIF, etc.).  

Show Point Values.  Use to display floating point values when 
hovering in a chart.  

Un-Zoom.   Use to undo a previous zoom operation.   

Set Scale to Default.  Use to set the chart back to the default 

scale.  
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Interpreting the Chart   

Each O-Calc® Pro  Chart value is plotted using lines as identified by color in the chart legends.  

Capacity (Gray)  Definitions 

The Pole Fiber Stress X Strength Factor is plotted on Moment and Stress 
Charts.    

Example: For a yellow southern pine (8,000 psi) under NESC Grade C (.85 strength 

factor) criteria, the pole’s allowable stress is plotted at 6,600 psi on a Total Stress 

chart.  

Easting (Blue)  These values are perpendicular to the frame of reference and represent 

results in the 90°/270° direction.  Easting values are plotted on all charts.  

Northing (Green)  These values are those in the direction of the northing value and 

represent results in the 0°/180° direction.  Northing values are plotted on 

all charts.  

Magnitude (Red)  A non-directional value representing the summary of forces along the 

length of the pole.  This line is critical because it represents a combined 

value of the Easting and Northing directions.  This line represents the 

summary of forces acting on the pole.  
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Analysis Reports 

Once the pole is completed in the Inventory panel you may want to generate a variety of reports.  The O-

Calc ® Pro Analysis Report is provided to help you inspect the analysis results.  

  

  

Note:  A pole needs to display in the Inventory panel to enable the Reports option.  

Report Menu Options  

The report’s toolbar menu provides you with a variety of operations and options.   

  

  

File. The following options are available 
from the File menu:  

Print Report. Select Print Report to print 
the current report.  

Page Setup. Select the Page Setup option 
and configure how the report should be 
printed.  

Save to PDF.  Select Save to PDF to save 
the current report to edit an existing 
report template.  
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Save to RTF.  Select the Edit Report 

Template to edit an existing report 

template.  

E-Mail Report To Use this option to e-mail the currently 

viewed report.   

  Report. Select the desired Report to 

display the from the drop-down menu.  

  Left\ Right arrows. Select the left\ right 

arrows to scroll through and display the 

various Reports without having to use the 

chart drop down menu.  

  

Refresh. Select to refresh the Report 

panel.  

  

Batch Report.  Select to open and work 

with the Batch Pole Reporting tool.  

  

Custom Reports. Select to create Custom 

Reports.  

  
Manage Reports. Select to manage which 
reports display in the Report drop- down 
list.  

Note: Manage Report configurations are 

carried over to Bulk Reports  

  
Auto.  Select to automatically reload the 

currently displayed report after 

calculations have been performed.   
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Reports Toolbar Options  

Once a Report is displayed the report’s toolbar menu provides you with a variety of operation and 
options.    

  

Navigation Controls  

  

Navigation Controls. Click the arrows to 

navigate through the document. Double 

arrows navigate to the first or last page. 

Single arrows navigate to one page at a 

time.  

  

Zoom.  Select the Zoom drop-down list to 

change the report magnification level.   

  
Zoom In/Zoom Out.  Click the zoom in or 

zoom out buttons to manually zoom 

within the currently selected report.   

  
Zoom to Fit.  Click the Zoom to Fit option 

to automatically have the report fill the 

space provided.  

  

Page Count.  Displays the current 

page/the total pages in the report.     

  

Viewing Reports   

The list of available reports is dependent on which reports are selected under Manage Report.  The list of 

available reports also corresponds with the currently loaded pole. (Example: The crossarm reports will 
not be displayed in the report list if there are no crossarms on the currently loaded pole). Once a report 

has been selected the Report will automatically be loaded, this may take a moment depending on how 

many reports are displayed. The selected report uses the currently selected Load Case when calculating 
and displaying a report. 

 

To view an existing report, complete these steps:   

1. Open a pole with a Load Case in the Inventory panel.  
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2. In the Reports tool bar select a report from the drop down list.   
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Batch Pole Report Menu   

The Batch Pole Report allows you to print report(s) against specific poles that you select.   

Toolbar Menu Options Add Poles. Select the Add Poles option to add poles that will be processed in 
the Batch Reports.  

Remove Poles. Select the Remove Poles option to remove poles that have 
been to the Poles to Process list.   

Printer Setup. Select the Printer Setup option to configure the printer that 
the Bulk Reports will utilize.  

Print Reports. Select the Print Reports option to print the currently selected 

batch reports. 

 

Named View  Enables the ability to save and name commonly retrieved sets of reports.    
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Sort Files  Use to sort the PPLX files in alphabetical order when they are printed to files.  

All Versions  Use to create a print to file report for each version within the selected PPLX 
files.  

All Load Cases  Select this option to create a separate print to file report for each load case 

attached to a PPLX file.  

Print to files  Select the Print to files option to print the currently selected batch reports 
into file format.  

File Per Report: Select the File Per Report option to create an individual file 
for each report selected.    

File Per Pole: Select the File Per Pole option to create one file per each 
processed pole.   

Single File: Select the Single File option to create a single file that includes all 

the selected Per-Pole Reports.  

Poles to Process  Displays the poles that will be processed in the selected Batch Reports. The 
order of the poles can be changed by using the drag-and-drop option. 

Bulk Reports  Displays the list of available Bulk Reports. These reports print separate from 

the Per-Pole Reports. 

Per-Pole Reports  Displays the list of available Per-Pole Reports. The order in which the reports 
will be printed can be changed by using the drag-and-drop option.   

 

Create a Batch Report 

To create a Batch Pole Report, complete these steps:   

1. Select Tools > Batch Pole Report.  

Note: The Batch Pole Report can also be accessed by selecting Batch Report in the Reports panel. 
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2. Select the Add Poles button.  

   

3. Browse to the location of the pole(s) you wish to add to the Batch Report 

process and select the (pole name).pplx file and click Open.  

Note: Hold down the ctrl key to select more than one pole out of sequence.  Hold down the shift key 

to select a range of poles next to each other.  

  

  

Toolbar   

Pole to Process   

    

Report  
Output  
Type   
  

PPLX File  
O ptions   

Bulk  
Reports   
  

Per - Pole  
Reports   
  

Named  
Report   
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Note:  To remove selected poles from Poles to Process area select the pole then select the Remove 

Poles button   

4. To change the order in which the (pole name).pplx file(s) will be printed click 

and drag the .pplx file.  

5. Select the Bulk Report(s) to be included.  

  

6. Select the Per-Pole Report(s) to be included.  
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7. To change the order in which the Per-Pole Report(s) will be printed click and 
drag the report. 

8. To save the changed layout of the batch Report, enter a name in the Named 

View box and click the Enter. The name is name saved for future use.   

  

9. Check Sort Files to place the PPLX files in alphabetical order when printed.  

10. Check All Versions to create a report for each version within the selected files.  

11. Check the All Load Cases to create a report for each load case within the files.  

12. Select the Print Reports button to print the Batch Reports to a printer.  

To print the Batch Reports to a different printer, select the Printer Setup 

button and select your printer of choice.  
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Additionally, you can check the Print to files option, select the Report Output Type then navigate to and 

select where you want the Batch Report files saved.  

Note: Only the primary pole image is included in the Batch Report.  Subsequent images that are 

attached to the./pplx file will be printed or saved as individual PDF files as ‘pplx file name_image#’.   

Exporting Batch Pole Info   

The Export Batch Pole Information Report allows you to export specific pole attributes and calculation 
results to a .CSV file.  To export Batch Pole Information, complete these steps:   

1. Select the Tools menu, click the Export Batch Pole Report Info option. 
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Export Batch Pole Info tool bar menu offers these options: 

  

Add Poles 

 

 

Remove Poles 

 

 

 

Export Info 

Select the Add Poles option to add poles that will be 
processed in the export.  

 

Select the Remove Poles option to remove poles that are 
listed in the Poles to Process list.   

 

Select the Export Info option to export the selected items 

and calculations to a .CSV file.  

Check All  To select the entire Items to Export list.  

Uncheck All  To uncheck the entire Items to Export list.  

Display Layout  Enables you to swiftly switch between different screen 

layouts.    

All Versions  Used to create a separate entry for each item and calculation 
based on each version within the selected PPLX files.  

All Load Cases  Used to create a separate entry for each item and calculation 

based on the load case(s) attached to a PPLX file.  

Poles to Process  Displays the poles that will be processed in the exported 
batch pole .CSV file.  

(The order of the poles can be changed by using the drag-

and-drop option)  

Items to Export  Displays a list of available items (attributes) that can be 
exported.  

(The order of the items can be changed by using the drag-

and-drop option)  

Selected Items  Displays a complete list of all the selected Items to Export.  

  

2. Select the Add Poles button.  

   

3. Browse to the location of the pole(s) you wish to add to the Batch Pole 

Information Export process and select the (pole name).pplx file and click Open.  

Note: Hold down the ctrl key to select more than one pole out of sequence.  Hold down the shift key 

to select a group of poles that are next to each other.  



[Type here] 

 

 278                   ©2025 Osmose Utilities Services, Inc.  

   
Note:  To remove selected poles from Poles to Process area select the pole then select the Remove 

Poles button.  Hold down the ctrl key to select more than one pole out of sequence.  Hold down the 

shift key to select a group of poles that are next to each other.  

4. Select the Items to Export from the available list.  

  

5. To change the order in which the Items to Export will be displayed in the .CSV 

file click and drag an item to arrange the items placement. 

 
6. Select the Export Info button. Browse to the location where you want the 

Batch Pole Information Export saved and enter a file name. 
7. Click OK in the Export confirmation message. 

 

 

Note: When an item is being dragged to a new location the cursor will change to indicate a valid move  . 

 

   

Working with the Strength Reduction Calculator   

The Strength Reduction Calculator allows you to calculate and apply the effective groundline 
circumference using the Osmose industry accepted strength calculations.  When the Strength Reduction 
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Calculator is initially opened some of the fields will already be prepopulated with information from the 

pole. 

 

Create a Strength Reduction Calculation   

To create a Strength Reduction Calculation, complete the following steps:   

1. Select Tools > Strength Reduction Calculator.  

    
 

 Select any attributes you want to modify in the Strength Reduction Calculator window.  

3. Adjust the Orig. GL and Shell Rot Circumference (if needed). 

 
4. To include heart rot, check the Include Heart Rot box, and enter a value. 

5. For each instance of decay or damage repeat the steps above.  

  

To Add a Strength Reduction due to a particular type of damage, complete these steps: 

1. In the Strength Reduction Calculator window, click the Add button. 

  

 

2. In the Edit window, select a Reduction Type from the drop-down list. 
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3. Enter the Width or Thickness and Depth value. 

  

4. Enter the damage Direction value from the drop-down list, click OK.   

  

5. Select the Apply Effective Circumference button. 
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6. Click Yes to the Apply Effective Circumference informational message.  

Once a Strength Reduction Calculation has been added the Calculated Effective Circumference 

automatically updates.  This is the value to be used in calculating the groundline capacity. The Orig. 

Effective Circumf  field is automatically updated to reflect the Applied Effective Circumference.  To set the 

Applied Effective Circumference back to the default value select the Clear Effective Circumference button. 

  

Remove a Damage Record in Strength Reduction Calculator   

To remove damage records from the Strength Reduction Calculation click the Remove button. 

  

 

Edit a Damage Record in Strength Reduction Calculator   

To edit damage records in the Strength Reduction Calculation, complete these steps:   

1. Click on the damage record to be edited and click the Edit button. 

 

Note: Double clicking on the damage record will also open the damage record in edit mode.  

2. Complete any edits in the Edit window and click OK. 
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Appendix A – Installing Osmose O-Calc® Pro  
  

System Requirements   

The system requirements for Osmose O-Calc® Pro include the following:   

• Supported Operating Systems: Windows 10 & 11 (64-bit version)  

• 16 GB System memory  

• 1-2 GB min. available Storage Space  

• DirectX11 compatible Graphics Subsystem, hardware accelerated 3D graphics 
(dedicated/separate)  

• Microsoft .Net Framework version 4.7.1 or later  

• PDF Reader Software  

Note: Surface laptop with integrated graphics card not recommended.  

 

Installing O-Calc Pro 

This page: http://www.o-calcpro.com/LineDesign/ allows registered users of O-Calc® Pro to install and run 

their software.  O-Calc® Pro uses Microsoft Click Once deployment. This technology simplifies the 

deployment of Windows-based applications, allowing them to be installed and updated automatically. 

You will need the following items:  

1. A valid and up-to-date O-Calc® Pro license key.  

2. An Expiration Token.  

If you need a key or token contact Osmose email ocalc@osmose.com before proceeding.  

To install/download the software at https://O-CalcPro/LineDesign/setup.exe and run it.  

Note: It is strongly recommended that you uninstall previous versions of O-Calc before 

proceeding.  

You may receive a message that windows has prevented the application from running.  
If this happens simply click "Advanced" or "More Info" and select "Run Anyway". This software 
is fully vetted and digitally signed.  

 

Use the following procedure to install O-Calc® Pro:  

1. Go to the download page at http://www.o-calcpro.com/LineDesign/ 

2. Click this install download link shown at the site: 

http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
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To install download https://O-CalcPro/LineDesign/setup.exe and run it. 

  
 

3. When the installer Welcome screen appears, click Next.  

  

 

4. Review and check the “I accept the terms in the License Agreement”.  

http://www.o-calcpro.com/LineDesign/setup.exe
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5. Click Next to use the default Destination Folder or click Change to browse to a 

different Destination Folder then click Next. 

 

 

 

 

 

 

    

    

License  
Agreement  
check box   
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6. Click Install to begin the installation process. 

  

 

7. When the installation is complete, click Finish to acknowledge the completed 

installation.  
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Registering Osmose O-Calc® Pro   

Once you have installed the Osmose O-Calc® Pro application you will need to enter a Product Registration 

Key to register the application and accept the License Agreement.  To register the Osmose O-Calc® Pro 
application, complete these steps:  

1. Open O-Calc ® Pro.  The O-Calc® Pro Product Key window is displayed.  

  

2. Enter the Registration Key Code that was provided in the email you received 

from Osmose. Note:  The Registration Key Code is not case sensitive.  

  
Note:  If you have questions about the type of Product key needed for your installation, contact O-

Calc® Pro product and sales support at ocalc@osmose.com.  

3. Click the Register O-Calc® Pro button.  

Note:  You can cancel the registration by clicking the ‘X’ in the upper right corner.  However, you will 

not be able to use the Osmose O-Calc® Pro application until it’s been successfully registered.  

4. When the O-Calc® Pro License Agreement window displays, scroll to the 

bottom of the license agreement while reading it carefully and check the “I 

have read and accept all of the terms of this agreement”.  

Note:  You must scroll to the bottom of the license text window to make the check box and the Accept 

button active.   

5. Click the I accept the terms in the licensing agreement box.  
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Security Administration 

O-Calc® Pro limits what user levels are available based on the Windows User Group a person is in.  The 

following table lists what user levels are available to each Windows User Group. Users can select any User 

level with an asterisk * in it.  The default level is also indicated.   

  

  Access Level  Windows User Groups  

    O-Calc 

Administrators  

All Others  O-Calc Limited  

O-Calc Pro 

User Access 

Levels 

Limited  * *  * (default)  

Normal  * (default)  * (default)   *  

Administrative  *     

  

O-Calc Administrators and O-Calc Limited are the names of the actual Windows User Groups that need to 

be created to grant or limit privileges.  When placing users into specific security groups they need to log 

off and then log back onto their computers to ensure the proper security group settings are enabled.   

O-Calc® Pro User Level Definitions   

O-Calc® Pro offers three different user levels: normal, limited and administrative.  These levels allow 

companies to grant or restrict access to individual features within O-Calc® Pro.  Below is a brief 

description of each user level.   

• Limited – Restricts access to certain attributes and operations that if changed 

could gravely affect the data within O-Calc® Pro.  Placing a user at the Limited 

level is intended to support training, inexperienced users and untrained data 

entry personnel.   

• Normal – This is the default user level.  All attributes except those in sealed 

Load Cases can be edited at this level.  At this level the user can also unseal 
Load Cases and manipulate the Catalog items.  The user will not be able to 

manipulate the Master Catalog directly.    

• Administrative – Users at this level have access to all the features within O-

Calc® Pro including the option to manipulate Catalogs, re-seal Load Cases and 

edit read only attributes.  

Note: If a user is in both O-Calc Administrators and O-Calc Limited groups, they will be considered a 

member of the O-Calc Administrators group.  

Administrative User Level 
This tool allows the user to control certain O-Calc® Pro settings only accessible to advanced O-Calc® Pro 

users with administrative privileges. Below are the steps to activate administrative mode for qualified users. 
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With the user level set to Administrative you can see the Administrative Settings menu option under the 

Tools menu otherwise it is not displayed. 

 

1. In the lower left of the O-Calc® Pro application is the user level designation, typically 

set to ‘Normal’, click on the User Level: Normal button. In the Set user level menu 

click the Set user level to Administrative option. 

 

 

2. In the User Level Set informational message window, click OK.  

 
 

3. In the lower left of the O-Calc® Pro application see User Level: Administrative. 

 

 

 

Using the Administrative Settings Feature 

To access Administrative Settings go to Tools>Misc> Administrative Settings from the main toolbar at the 

top left of the application. 
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The Administrative Settings window opens with the option to select a Default Pole Segment Length (inch). 

 

You can change the Default Pole Segment Length used by the O-Calc® Pro finite element analysis 

calculations. You may want to increase or decrease this value to adjust the resolution of the finite element 

model of the pole being calculated. 
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Increasing the value decreases the number of elements used per model, thus lowering the definition of 

the analysis and potentially lowering the accuracy of the analysis, with the tradeoff being a quicker 

calculation time. 

 

 

 

Decreasing the value in the dialog has the opposite effect, increasing the number of elements in the 
analysis. This results in a higher resolution calculation which may be more accurate at the cost of being 

less time performant. 

 

To save any changes to the Administrative Settings O-Calc® Pro will have to be restarted. 
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Development Information 
Retrieving Reference Information  

O-Calc® Pro contains several reports containing reference information. Catalog and schema information is 

provided for developers. Details of the values available to the reporting system are available for custom 
report authors. Raw reports of data and calculated forces are all available to assist in the understanding 

of pole loading.  

These utilities are intended for software and report architects and as such they are of limited use to 

general users.  

To access the reference information, complete the following steps:  

1. Select Tools > Misc.  

There are four reference reports available:  

• Schema Explorer (PDF or HTML Format)  

• Dump Reporting Parameters  

• Dump Forces Detail Report 

• Dump Catalog  

 

2. Select the reference report you would like to run.  

 

Note: These schemas can be enabled by setting the ‘SchemaAndForces’ value to try in the registry.  The registry path 

is HKEY_CURRENT_USER>Software>PPL>Dump.  

 

Creating Custom Loading Districts   

In certain situations, it may be necessary to use custom loading districts within the O-Calc® Pro 

application.  Creating a custom loading district file replaces the O-Calc® Pro default loading district values.  

If you need any of the default loading district values, you must manually add them to your custom loading 

district file.    

Load Cases that are currently used in the O-Calc® Pro default loading districts cannot be overwritten 

when a custom loading district file is created.  If you need pre-existing loading districts changed you must 

manually edit these Load Cases.  A Load Case district can only be changed in an unsealed Load Case.   

To create a custom loading district file, complete the following steps:  

1. Open Notepad.  
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2. Create a list within Notepad of the custom loading districts.  

   

3. Select File > Save.  

4. Save in \Documents and Settings\All Users\Application Data\OsmosePPL.  

 

Note: Read and write permission will be needed to the OsmosePPL directory. This directory can also 

be accessed by selecting Help>Folders>All Users Root Folder from within O-Calc® Pro.  

  

5. Enter the File name as “customloadingdistricts.txt”.  

  

  

Note:  Once the customloadingdistricts.txt file has been created and saved to the correct location the 

OCalc® Pro application will automatically utilize this file.  O-Calc® Pro will need to be restarted for the 

changes to take effect.    

Note: To restore the default loading district values simply remove the customloadingdistricts.txt file 

from the OsmosePPL directory. O-Calc® Pro will need to be restarted for the changes to take effect. 
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Locating O-Calc® Pro Folders   

To easily access O-Calc ® Pro user and common folders, complete these steps:   

1. Go to the Help menu, select the Folders option, click on the folder you need.  

   
 

Working with Catalog Backups  

Each time changes are made to a catalog a backup of the catalog is automatically created when the 
current session is closed.    O-Calc ® Pro retains up to 10 backups of each catalog, automatically deleting 

the oldest as new ones are created. By retaining a backup of each time, the catalog(s) are changed by 

session it allows you to revert to a previous catalog in case a change was done in error.   

Backups of the catalogs are easily accessible from within the O-Calc ® Pro application.  The backups are in 

a Catalog Backup folder wherever catalog files are located.     

Some of your catalog backup files can quickly be located using the links under the Help > Folders > User 

Root Folder.  

Each catalog backup file provides the date and time that the backup file was created right in the file 

name.    

(Catalog Name).pplc.02_12_2016_08_03_18.Backup  

  

   Catalog Name          Date   Time  

To revert to a previous version of a catalog, complete the following steps:  

Note: The steps below are for reverting to a previous catalog.    

1. Open the catalog folder that has the catalog that you need to revert.  

2. Open the Catalog Backup folder.  

3. Select and copy the backup file you need to revert to.  

4. Edit (open) the Catalog Data Path that your current catalog resides in (the one 

you want to replace).  

Note: The Catalog’s Data Path is in the Catalog Configuration window.  The Catalog Configuration 

window can be accessed by opening Tools > Catalog Maintenance > Configure Catalogs.  

5. Rename the catalog that resides in this folder.  
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6. Copy the Catalog Backup file you copies in step 4.   

7. Edit the catalogs name by removing the Date, Time and the word Backup.  

8. O-Calc® Pro application will need to be closed and reopened before the 

change will take effect.   

Catalog Maintenance Mode  

O-Calc® Pro provides a Catalog Maintenance Mode that enables administrators to complete modifications 

within a catalog.   The Catalog Maintenance Mode allows anyone with administrative privileges to have 

full editing capabilities to all catalogs.  All attributes included attributes that are normally un-editable can 
be edited in this mode. This mode should only be accessed by the most qualified personnel as all changes 

are permanent once they are saved.   When the Catalog Maintenance Mode is activated, only 

modifications within the Catalog panel are permitted.  All options within O-Calc ® Pro that do not pertain 

to the Catalog panel are disabled until you have exited the Catalog Maintenance Mode.    

To use the Catalog Maintenance Mode, complete the following steps:  

Note: Only a person with Administrative privileges can access the Catalog Maintenance Mode.  

1. Close any pole that is opened in the Inventory panel File > Close Pole.  

2. Select Tools > Catalog Maintenance > Maintenance (Bulk Edit) Mode.  

Note: When the Maintenance Mode is enabled a check mark will display next to the menu option.  

  

3. Select Yes to continue in Catalog Maintenance Mode.  

Note: The Status Bar will turn yellow and clearly indicate that the Catalog Maintenance Mode is active.    

4. Complete your modifications to the catalogs.  

5. Deselect the Tools > Catalog Maintenance > Maintenance Mode option.  

  

6. Select Yes to save your changes.   
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Changing the Product Key 

To change the initial Product Registration Key entry, complete the following steps:  

1. Open O-Calc ® Pro.  

2. Select Help > Enter or Change Product Key.  

   

The O-Calc® Pro Product Key window is displayed.  

  

 

3. Enter or change the Registration Key Code. Note: The Registration Key Code is not 

case sensitive. Click the Register O-Calc® Pro button.  

  
 

To verify the O-Calc® Pro software version and key information installed on your device, complete these 

steps:  

1. Click to open the Help menu drop-down list.  
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2. Select Help > click the About option.  

  

3. Click the Details >> button to view the user details or System Info.  

4. Click OK to close the About O-Calc® Pro window.   

Help Resources 

Various resources contain additional information about O-Calc® Pro.  These resources can be easily 

accessed by following these steps:  

1. Go to the Help menu drop-down list.  

  

2. Select O-Calc® Pro Help to access helpful documents and User Manuals 
at osmose.com/o-calc/help  

 

 Help Resources available at the site are:  

• O-Calc® Pro 8.0 Line Design User Guide (use for Line Design functionality)  

• O-Calc® Pro Command Bar (use for help with Command features)   

• O-Calc® Pro 8.0 User Guide (use for O-Calc® Pro functionality, except Line Design)  

• Intro to Custom Reports with Excel (use to create custom reports with Excel) 

• Html Tags Chart (use for a list of Html tags with examples) 

https://www.osmose.com/o-calc/help
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To navigate to ‘topic specific’ instructional YouTube videos on osmose.com/o-calc/video, complete these 

steps:  

1. Select Help > More Information > View Informational Videos.   

 

  

To navigate to ‘topic specific’ instructional articles on osmose.com/o-calc/wiki, complete these steps:  

1. Select Help > More Information > O-Calc® Pro WIKI.   

  

 

 

For help with submitting an issue or feature request, complete these steps: 

  

1. Select Help > More Information > Submit an Issue or Feature Request.   

 

3. Complete the online form and click the Submit Request button. Be sure to 

enter all the applicable information and attach any images, screen shots, and 

pole (.pplx) files.  

https://www.osmose.com/o-calc/video
https://www.osmose.com/o-calc/wiki
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Appendix B – Creating a Customized View  
  

Understanding the Default View 

Within O-Calc® Pro the default location of the windows can be changed at any time.  This allows users to 

create unlimited screen layouts, which can be saved for future use in the Named View dropdown list 

 in the right corner of the Tool Bar menu.    

The O-Calc® Pro home page is broken into six panels.  Any of the windows within O-Calc® Pro can be 

moved into any of the six panels based upon user preference. See the seven panels below:  

  

Repositioning Panels 

To create a separate window, complete these steps:   

1. Left click on the panel heading, hold and drag the overlaid blue window to the 

new location (a second monitor or layout location) or release it.  

  
Note: The separate window can be dragged and dropped on to a second monitor if desired.  
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To change the location of any panel, complete these steps:   

1. Click on the Capacity panel blue ribbon, hold and drag the window (an overlaid 

blue window appears, and navigation cross appears) to the new location.  

2. Place your mouse cursor in the desired docking location within the yellow and 
white navigation cross and release. The right quadrate docks the Capacity 

panel to the right, the left docks on the left, the upper docks at the top, and 
the lower docks at the bottom of the window.  

 

3. Below is the resulting the docking placement within the panel based on the 

right quadrant location within the navigation cross:  

  

Once the blue overlay window is near the center of a panel or the edge of a panel, the yellow and white 

navigation cross automatically displays to provide you with the docking options.  

 

      

Cursor is   placed  in   the  
right  quadrant of the  
navigation cross.   

  

Window is docked to  
the right of the panel.   

  

Navigation cross appears  
when the panel is  
dragged to a new location.   



O-Calc® Pro 8.0                                                                                                  User Guide  

©2025 Osmose Utilities Services, Inc.                                                                                                  301  

Note: Undo is not available. To reset to the Docking Layout to the default view, go to View > Docking 

Layout > Default.  

These docking placement options using the navigational cross for all quadrants and the center:  

  

  

Drag the blue overlay window over the navigational cross quadrant that best interprets where you would 

like the window docked.  

When dragging a window over a navigational cross quadrant or center, the blue overlay window will 
display where the window is be docked within the panel.   

   

Note: Undo is not available. To reset to the Docking Layout to the default view, go to View > Docking 

Layout > Default.  

Save a Named View   

To save the view that you’ve created and add it to the Named View list, complete these steps:   

1. Click in the Named View box.  

2. Enter a name.   

  

3. Press the Enter key to save your Named View.  

4. The view is automatically added to the list, viewable in the drop-down list.  

Delete a Named View  

To delete a Named View, complete these steps:   

1. Select the view to be deleted from the Named View drop-down list.  

  

  

Window  
placed at the  
top of the  
panel   

Window placed at the top,  
bottom, right, or left  
quadrant within the panel.  
Or if docked at the center, it  
becomes a tab within the  
panel.    

Window  
placed at the  
bottom of the  
panel   

Window  
placed at the  
left of the  
panel   

Window  
placed at the  
right of the  
panel   
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2. Select the Delete button  next to the Named View box.  

3. Select Yes to the Delete? confirmation message.   

Note:  Undo is not available for this operation. 

  

Return to the Default Docking Layout   

To return to the O-Calc® Pro default docking layout, complete these steps:   

1. Select View > Docking Layout > Default.  

  

Refresh All Views  

To refresh all views, complete these steps:   

1. Select View > Refresh All Views.   

  

  



O-Calc® Pro 8.0                                                                                                  User Guide  

©2025 Osmose Utilities Services, Inc.                                                                                                  303  

Appendix C – Misc. Tools 
Within O-Calc® Pro the Tools menu there are additional Misc. Tools available; some tools may be 

considered advanced user functionality. 

Below is the list of Misc. Tools available: 

 

Install Plugins and Reports 

To initiate owner edits for O-Calc ® Pro Plugins and Reports within a single window, complete these steps:   

1. Go to the Tools menu, select Misc., click the Install Plugins and Reports option. 

  

2. In the Select O-Calc® Pro Modules window navigate to the location of the file you 

need to add, select the file and click the Open button. 
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Data 

Force Summary of Selection 

To obtain the Forces of Selected Elements data for the selected wire, complete these steps:  

1. First select a conductor or wire under tension in the Inventory or 3D View panel. 

  
 

2. Go to the Tools menu, select Misc, select Data, click the Force Summary of Selection option. 

  
 

3. The Forces of Selected Elements window appears with the data, click OK. 

 

 

Fill Moment Table 

To obtain the Fill Moment Table data for the selected pole, complete these steps: 

1. First select the pole in the Inventory or 3D View panel. 
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2. Go to the Tools menu, select Misc, select Data, and click the Fill Moment Table 

option. 

 
 

3. The O-Calc® Pro informational message tells you the moment table is populated. 

Now you can view the Moment Table data from the Data Entry panel. 
 

 
 

4. Locate the Override Moment Cap attribute, click the radio button from No to Yes. 

 
 

5. Click the Moment Cap (ft-lb) attribute to view the table. 
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6. You can click the File > Save option or click the Value tab to Add, Remove, Sort, 

Import and Export the Moment Capacity vs. Height table. 
 

 

Working Data Store 

The Working Data Store is a digital repository that stores and safeguards the information.  

Export Selected Element 

To initiate various data handling operations such as exporting all or selected or elements or deleting 

working data, complete these steps:  

First select the elements in the Inventory or 3D View panel you want to export and complete these steps: 

1. Go to the Tools menu, select Misc, select Data,  select Working Data Store, click the 

Export Selected Element option. 
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2. In the Save Working Data Store window, navigate to the location you want to export 

the selected elements to, and click Save. 

 

Export All Elements 

First select the elements in the Inventory or 3D View panel you want to export and complete these steps: 

1. Go to the Tools menu, select Misc, select Data,  select Working Data Store, click the 

Export All Elements option. 

 

 

2. In the Save Working Data Store window, navigate to the location you want to export 

the selected elements to, and click Save. 
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Delete Working Data 

First select the elements in the Inventory or 3D View panel you want to delete and complete these steps: 

1. Go to the Tools menu, select Misc, select Data,  select Working Data Store, select 

Delete Working Data, click the Selected Element or All Working Data option. 

 

 

2. Click Yes to delete the data, there is no undo for this operation. 

 

 

Working with Bulk Edits 
Bulk Owner Edit 

To initiate owner edits for attachments easily within one window, complete these steps:   

3. Go to the Tools menu, select Misc., click on Bulk Owner Edit.  

  

4. In the Bulk Set Owner window, enter the needed changes, click OK.  
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Bulk Description Operations 

To initiate description edits for attachments easily within one window, complete these steps:   

1. Go to the Tools menu, select Misc., select Bulk Description Operations, click on 

the Bulk Edit All Descriptions option. 

 

 

2. In the Edit Descriptions window, enter the needed changes, click OK. 
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Calculator 

A basic calculator is provided to help with simple calculations or conversions. To access the calculator, 
complete these steps:   

1. Go to the Tools menu, select Misc., click the Calculator option.  

  

  

 

Modulus of Elasticity Calculator 

To create a Modulus of Elasticity (MOE) calculation for reference only, complete these steps:   

1. Select Tools >Misc. > Modulus of Elasticity Calculator.  

  
Note:  A pole does not need to be added to the Inventory panel to use the Modulus of Elasticity 

Calculator.  

2. In the Main Material Tab, Select the Material from the drop-down list. 
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3. Enter a value for % Solid, Diameter, and Young’s Modulus. 

 

4. In the Core Material tab, enter a value for % Solid, Diameter, and Young’s 

Modulus (MOE). 

 

5. In the Insulation Tab, Select the Material from the drop-down list.   

• Enter a value for Thickness, Young’s Modulus 
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• Check the box if Insulation is present 

          

 

Results: Modulus of Elasticity (MOE) Calculator is automatically calculated. Select the ‘X’ to close. 

 

   

 

Note:  The Modulus of Elasticity Calculation cannot be applied to a currently loaded pole.  This 

calculation is for reference only.  

Ruling Span Calculator 

To calculate the ruling span for reference only, complete these steps:   

1. Select more than one span in the Inventory panel or 3D View.  

2. Select Tools > Misc. > Ruling Span Calculator.  
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Note: The Ruling Span Calculation cannot be applied to the currently loaded pole.  This calculation is 

for reference only.  

  
3. Select OK to close the window. 

 

AWG to Diameter Conversion  

To display the AWG to Diameter conversions, complete these steps:   

1. Select Tools > Misc. > AWG to Diameter Conversion.  

  
Note:  A pole does not need to be added to the Inventory panel to display the AWG to Diameter 

Conversion window.  
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2. Select OK to close the window.  

  

Concrete Pole Class List  

To view the list of Concrete Pole Classes, for reference only, complete these steps:   

1. Go to the Tools menu, select Misc., click on Concrete Pole Class List. 

 

2. Adjust the Strength Factor, click OK, close the window using the ‘X’ in upper 

right corner.  
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Note: A pole does not need to be loaded in the Inventory panel to display the Concrete Pole Class List 

window.  

  

Working with Soil and Overturn 
Soil Class List 

To view the list of Soil Classes, for reference only, complete these steps:   

1. Go to the Tools menu, select Misc., click on Soil Class List. 
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RUS-based Overturn Moment Calculation  

The RUS method (RUS Bulletin 1724E-200) will take into consideration pole length, setting depth, and soil 
type.  The user will have the option to change the soil classification based on local known conditions 
and/or field data.  The tool will automatically fill in the overturn moment value and the O-Calc® Pro 
calculation engine will flag the pole if overturn is a limiting factor for the pole model. This functionality is 
in support of the CPUC GO95 Rule 94.11 (pole overturning calculation).   

To enable the RUS-based overturn moment feature, complete these steps:   

1. Select the pole from your 3D view or Inventory panel.  

2. In the Data Entry panel, change the filter to the Overturn option. 
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3. The Overturn filter displays the Soil Class and Overturn Moment (ft-lb) value, 

after you select a soil class. No overturn moment value is calculated for the 

Unset default option. Unset means that O-Calc® Pro considers the pole as 

‘rigidly constrained’ at groundline.  

  
4. Select a Soil Class from the list (shown below) the Overturn Moment changes 

from Unset to Auto. To view the Overturn Moment value go to page 1 of the 

Analysis Report. 
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Below are the nine Soil Classes (0-8), their Descriptions, and Soil Constants as listed by the NRCS (Natural 

Resources Conservation Service). The soil class number corresponds to a value for the Overturn Moment, 

referenced in the O-Calc® Pro Analysis Report below.  

 

Class  Description  Soil 

Constant  

0  Sound hard rock; bedrock; unweathered  140  

1  Very dense and/or cemented sands; coarse gravel and cobbles  140  

2  Dense fine sand; very hard silts and clays (maybe preloaded)  140  

3  Dense sands and gravel; hard silts and clays  70  

4  Medium dense sandy gravel; very stiff to hard silts and clays  70  

5  Medium dense coarse sand and sandy gravels; stiff to very stiff silts 

and clays  

70  

6  Loose to medium dense fine to coarse sand; firm to stiff clays and 

silts  

35  

7  Loose fine sand; alluvium; loess clays; soft-firm clays; varied clays; 

fill  

35  

8  Peat; organic silts; inundated silts; fly ash; very loose sands; very soft 

to soft clays  

35  

  

1. Verify the Overturn Moment is displayed on page 1 of the O-Calc® Pro 
Analysis Report.  
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Deactivate Overturn Moment  

To disable the RUS-based overturn moment feature, complete these steps:   

1. Select the pole from your 3D View or Inventory panel.  

2. In the Data Entry panel, set the filter to Overturn Moment.  

3. Open the Soil Class drop down menu and select the Unset option. 
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Pole Section Evaluation  

The Pole Section Evaluation calculations are updated automatically and cannot be edited once saved. To 

evaluate pole damage and decay, complete these steps:   

1.  Go to  the Tools menu, select Misc., click the Pole Section Evaluation option. 

2. Select Add and select a damage or decay item from drop down list. Modify the 

damage or decay attributes.  

 

3. To remove a damage or decay item from your list select the item and click the 

Remove button in the Pole Section Evaluation window. 

Clean Temp Folder   

To clean the Temp Folder, close any open pole file and complete these steps:   

4. Go to  the Tools menu, select Misc., click the Clean Temp Folder option.  
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5. Select OK to the informational message. 

  

 

 

Save Pole Versions as Individual 

To cause a Version of a New Pole to save separately from the originating .pplx complete these steps: 

1. First you must have two versions of the same pole in the Inventory panel. 

 
 

2. Go to the Tools menu, select Misc., click the Save Pole Versions as Individual option. 
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3. In the Select Folder window you need to navigate to the folder you want to save the 

pole Version to, and select it then click the Select Folder button. 

  

 

Photo Measure Advanced Tools 

Advanced image measurement options are available as described below. 

Misc. Photo Measurement Tool Description 

CVT Configuration Use to edit the CVT Configuration attributes. Enter the values 
you need and click OK. 

 

Lens Calibration Use the 4-step process to calibrate your camera lens. 
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Set Default Measurement Font Size Use to edit the font size displayed on the images in the Measure 

panel, click OK to save. 

 

Set Default Measurement Color Use to edit the measurement color displayed on the images in 

the Measure panel, click OK to save. 

 



[Type here] 

 

 324                   ©2025 Osmose Utilities Services, Inc.  

Auto Create Measurement Labels 
 

Use this option to enter a description that proceeds the height 

value. 

 

Load Canned Label Set Use the Select Canned Label Set window and browse to the 

location of the file you need to add that contains a set of 

canned labels already prepared, click Open. 

 

Clear Canned Label Set Use to clear the Select Canned Label Set. 
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Appendix D – Misc. Options 
 

Within the O-Calc® Pro Options menu there are additional Misc. Options available; some options may be 

considered advanced user functionality. 

Below is the list of Misc. Options: 

 

Display “Pole Saved” Confirmation 

All options are enabled when a check mark is displayed next to the menu option.  No check mark 

displayed indicates the option is disabled.  The option below is enabled by default. To disable the “Pole 

Saved” confirmation message from displaying, complete these steps:   

1. To enable\disable the Pole Saved confirmation message option, select Options, 

select, Misc. Options, click on Display “Pole Saved” Confirmation.  
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Divide Add Menu Items by Category  

To change how the “Add Element” menu is displayed, complete these steps:  

1. To enable\disable the Divide Add Menu Items by category option, select Options 

>  Misc. Options > Divide Add Menu Items by Category  

Note: Disabling the divide add menu option displays all elements to be added to an item in one list.    

 

Show Text and Images in Inventory Menu 

This option is enabled by default offering the menu option name alongside the corresponding menu icon. 

To disable the names of the menu icons in the Inventory toolbar, complete these steps:   

  

1. Go to the Options menu, select Misc. Options, click the Show Text and Images in 

Inventory Menu option to disable (no check mark) it. 

  
  

 
 

User Interface Conventions 

The Invert Mouse Wheel function affects the 3D View, Bird’s Eye View, Perspective Camera and Top View 
only. Option are available to Invert the Left and Right Mouse buttons in the 3D X and Y. Additionally, 

menus can be arranged in a right to left layout. To invert (reverse) the mouse wheel direction, complete 

these steps:  

1. Select the Options menu, select the Misc. Options, select the User Interface 

Conventions option, click on Invert Mouse Wheel.  
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Save Pole History Archive 

The Pole History Archive provides an audit record of the changes made at each save point.  When the 
Pole History Archive option is enabled, each time you save changes to a pole a snapshot of that pole is 

created and stored as a history record.  Each history entry records who made the changes and when they 

were made.  By retaining a history of each time, a pole has been saved, you are able to review previous 
revisions to a pole and even revert to a pole’s previous revision.  To enable the Pole History Archive, 

complete the following steps:   

1. Go to the Options menu, select Misc. Options, click Save Pole History Archive.  

 

   

Note: When the Save Pole History Archive option is enabled a check mark will display next to the 

menu option.  When the option is disabled the check mark is not displayed.  

2. Create a new pole in the Inventory panel and save the pole using the File > 

Save Pole option.  

 

The first time the pole is saved a Pole History Archive file is created containing the Date, User, and 

Workstation record.    

3. To view the pole’s history archive, go to the File menu, select More Options, 

click Open Archived Pole.  Browse to the location of the saved pole and select 
the (pole name).pplx file.  

  

 

Note: The Open Archived Pole option is only visible when the Save Pole History Archive option is 

enabled. To enable it in Options > Misc. Options > Save Pole Archive History. 
 

4. Select the archived version of the pole from the list that you need to open, click OK. 

5. Complete modifications to the current pole in the Inventory panel and save the pole 

using the File > Save Pole option.  

    

  
New pole  
created in the  
Inventory  
panel   
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The Revision History area is automatically updated.  

6. To review previous revision to a pole or to revert a pole to a previous version, 

select File > Open Archived Pole.  Browse to the location of the pole you wish 

to work with and select the (pole name) .pplx file.  Select the Revision History 

record you need.  

 

7. Select Open Archived Version.  

  

  

    

Select  
the  
revision  
history  
file   

Select the (pole name).pplx file   

    

  

Active pole with  

attachments added 

ent 
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The selected Revision History snapshot is loaded in the Inventory panel and can be reviewed.  The pole is 

completely editable at this time, and it can be modified and saved.  If the revision is saved, it will then 

become the active version of that pole and replace the .pplx file.  For safety, a new revision history record 
will be added at that time that stores a snapshot of the previously saved version of the pole.   

Auto Save 

By default, the Auto Save option is set to Never, to select an auto save interval based upon the number of 

edits (5, 10, 15, 20, or 25) you make, complete these steps:   

1. Go to the Options menu, select Misc. Options, open the Auto Save: Never drop 
down menu, select an available option.  

  

Idle Time Interval  

The Idle Time Interval can be set to a minimum 1000 milliseconds and a maximum of 5000 milliseconds 
The Auto Capacity Summary option needs to be enabled for the Idle Timer to activate. To set the idle 

time before calculations are calculated, complete these steps:   

2. Go to the Options menu, select Misc. Options, click Idle Timer Interval 

(currently set time).  

   

 

3. Enter the Idle Timer Interval in milliseconds, click OK.  
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Assemblies Shown in New and Subst Trees 

In the Catalog by default, equipment assemblies are not displayed in the tree view, unless they are 
directly under a folder. To display assemblies without regard to where they display in the tree view, 

complete these steps: 

1. Go to the Options menu, select Misc. Options, click Assemblies Shown in New 

and Subst Trees.  

 
 

2. With the option disabled the equipment needs to be directly under a folder to 

display in the tree view.  

 

Set Height After Assembly Drop  

To set the height of equipment or an assembly being dragged onto the current pole from a catalog, 
complete the following steps:   

1. Go to the Options menu, select Misc. Options, click Set Height After Assembly 

Drop.  

  

 

2. Select the Set at automatic height recommendation.   

  

  

With the option  
disa bled   the  
equipment  
needs to be  
directly under a  
folder to display  
in the tree view.   
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3. Or select the Edit Height option, and in the Edit window enter a Height value. 

Click OK.  

   
Note: When the Set Height After Assembly Drop is selected the height adjustment window will 

display each time a drag-and-drop operation occurs from a catalog.  The height value displayed is 

the pole attachment height of the topmost item of the assembly.  All other items will be adjusted 

relative to the topmost attachment height.  

Double Buffer in Image Measurement  

O-Calc ® Pro uses an off-screen bitmap buffer to reduce redraws flicker of the photo measurement 
screen.  This option requires a large amount of system memory.  On computers where memory levels or 

CPU performance do not meet the stated O-Calc ® Pro requirements, this option may be enabled to 
reduce memory consumption and increase performance at the expense of increased image flickering.  To 

enable double buffering in the Measurement panel, complete the following steps:   

1. Go to the Options menu, select Misc. Options, click Double Buffer in Image 

Measurement.   

 
Note: When the Double Buffer in Image Measurement option is enabled a check mark will display 

next to the menu option.  When the option is disabled the check mark is not displayed.  

Note: To review a complete list of O-Calc ® Pro system requirements, see Appendix A. 

Warn on Keyboard Delete 

When deleting objects in the Inventory panel using the delete button on your keyboard a delete 

confirmation message is displayed.  This message is enabled by default.  To change if the delete 
confirmation message displays, complete the following steps:   

1. Go to the Options menu, select Misc. Options, click Warn on Keyboard Delete.  
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Note: When the Warn on Keyboard Delete option is enabled a check mark will display next to the 

menu option.  When the option is disabled the check mark is not displayed. 

  

Automatic Copy to Clipboard on Item Click  

The copy value feature allows you to easily copy values or value sets from the Data Entry panel onto the 

clipboard.  To use this feature, complete these steps:   

1. Go to the Options menu, select Misc. Options, click Automatic Copy to 

Clipboard on Item Click.  

 

 

2. In the Data Entry select any attribute value to copy, right click to paste to 

clipboard.  

 

 

Note:  Only one attribute per copy.  To copy both the header and attribute, select the header.  

  

3. If the Automatic Copy to Clipboard on Item Chick is disabled, you can use the 

Ctrl + C to copy any attribute value or data entry header, Ctrl + V to paste to 

clipboard.  

Data Entry Header  Selecting the Data Entry Header then selecting Ctrl + C will copy all the 

objects and attribute values within the selected category to the 

clipboard.  

Object  Selecting an object then selecting Ctrl + C will copy the object value and 

the objects attribute value to the clipboard.  

Streetlight  -   8  ft. Arm   
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Attribute  Selecting an attribute then selecting Ctrl + C will copy the attribute value 

to the clipboard.  

  

Shortcut and Function Keys  

To easily switch between the O-Calc ® Pro views keyboard shortcuts and function keys have been 
enabled.  To work with these features, complete the following steps:   

1. Go to the Options menu, select Misc. Options, click Enable Shortcut and Function Keys. 

 
 

 

Stub Pole Options  - See ‘Working with Guying’. 

 

 

 

Show Error Tab Automatically 

To display any error(s) in a separate tab, that causes the calculation engine not to complete, complete 
these steps:  

1. Go to the Options menu, select Misc. Options, click Show Error Tab Automatically.  

  
 

 

Move Pole Segments Together 

To Move Pole Segments Together complete these steps:  

1.  Go to the Options menu, select Misc. Options, click Move Pole Segment Together. 
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Label Images From Current Height 

To Label Images From Current Height completed these steps: 

1. Go to the Options menu, select Misc. Options, click Label Images From Current 

Height. 

 

 

 

Top View Merge Thresholds 

When using the Gang “G” Editor in the Top View you can automatically merge spans within specified 

thresholds for Angle and Length.  

 

To merge the Top View Thresholds complete these steps: 

1. Go to the Options menu, select Misc. Options, click Top view Merge Thresholds. 

 
 

2. Enter the threshold values you need for merging spans.100 

 

 

 

Override Auto Setting of Wind Drag Coefficient 

The Override Auto Setting of Wind Drag Coefficient option enables users to override wind drag coefficient 

values.  By default this option is disabled. Entering a value of zero in the Data Entry returns the option to 
the default mode of ‘Auto’. 

 

The O-Calc® Pro application automatically adjusts the Wind Drag Coefficient based on the shape of the 

equipment to a value of 1 for cylindrical objects and a value of 1.6 for cubic objects. 
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To override the default wind, drag coefficient, complete these steps: 

1. Select Options > Misc. Options > Override Auto Setting of Wind Drag Coefficient. 

 

 
 

2. Select an object in the 3D View or Inventory panel, in the Data Entry change the Wind 

Drag Coef. Attribute, input a number between 0 and 1. 
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Appendix E – 3D Navigation Enhancements  
 

Default Control Scheme 

Previous 3D View Controls included in our older versions of O-Calc® Pro, restricted the camera to a 

cylindrical orbit 20,000 inches away from the centerline of the pole. Traditionally, the camera could move 

to a point on that cylinder only, and zooming was accomplished by changing the camera’s field of view. 

Panning was only possible along a vertical axis. But depending on field of vision (FOV) this made the 
ability to visualize other locations, i.e. adjacent poles, limited and hard to understand.  

  

In the 7.0.1 version of O-Calc® Pro we have added 2 new control sets; Default and Alternate, which 
should make 3D navigation much more intuitive for users.   

  

To accompany these new control sets, new filters and a Camera Look Point icon has been added in the 
form of a pink ball at the center of the 3D View panel.  

  

Camera Look Point  

The pink “ball” icon represents the camera “look point”. The ball icon is displayed in the center of the 3D 

View.  To locate the Camera Look Point (hidden from view behind the pole) complete these steps: 

 
1. Right-click in the 3D View and drag the mouse left or right to reveal the ball 

icon hidden behind the pole. 
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2. To orbit around the Camera Look Point right-click your mouse and drag the 3D 

View in a circular motion, around the Camera Look Point.  

 

3. To return the pole to the center of the 3D View, click the R (Reset) button. 
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4. If when hovering the mouse over the camera look point and zooming in, the 

camera look point ball becomes enlarged. Simply click the “R” Reset button to 

restore the ball icon to its original size. 

  

Alt Key Controls  

The use of additional key controls allows users a greater range of motion capabilities within the 3D View. 

To try the movements, follow these steps:  

1. Hold the Alt key and left click mouse on any object to move to that selected point.  
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2. Release the Alt key to view the additional move options.  

  

3. Select the Near End of Span option.  

  

4. Select the Far End of Span option.  

  

   
5. Select the Midpoint of Span option.  



[Type here] 

 

 340                   ©2025 Osmose Utilities Services, Inc.  

  
  

   

Alt and Shift Key Controls  

By using a left click you can move the camera, a right click action moves the camera look point. To try 

these actions, follow these steps:  

1. Hold the Shift key and drag the cursor to turn the look point up or down.  

   
2. Hold the Alt key turns the “X” direction off.  
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3. Hold the Alt and  mouse wheel casing a “trucking” motion which brings the 
camera forward or backward. This motion is especially useful when navigating 

in Line Design through a long line of poles.  
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Alternate Control Scheme 

The Alternate Control Scheme was developed to make navigating in Line Design to multiple poles easier 
for users. These controls are based on 3D Modeling Industry standards.  The controls are divided into two 

sets; the Default Control set and Alternate Control set. To activate the Use Alternate Control Scheme 

option, follow these steps:  

1. From the Options menu, select Options in 3D View, select Camera, and click the 

Use Alternate Control Scheme option.  

  

 

Note: Deselect (uncheck) the Use Alternate Control Scheme option to return to the Default Control 

set of controls.  
 

Default Controls Set  

Press the left mouse button and drag in the following directions:  

Mouse Direction  Resulting Effect in 3D View  

Left or Right  Movement turns the camera look point around in 

cylindrical rotation  

Up or Down  Moves the camera AND look point up or down equally  

Holding "Alt" key down  

  

Left and Right movement does nothing  

Up Down movement works as expected  

Holding "Shift" key down  

  

Left and Right movement works as expected  

Up and Down moves ONLY the camera (tilt)  

Holding "Shift" and "Alt" keys 

down simultaneously  

Move the mouse to cause a rocking motion in 360 

degrees  

  

Press the right mouse button and drag in the following 

directions:  
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Mouse Direction  Resulting Effect in 3D View  

Left or Right  Orbits the camera look point around the camera (pan)  

Up or Down  Moves the camera AND look point up or down equally  

Holding "Alt" key down  

  

Left and Right movement does nothing  

Up Down movement works as expected  

Holding "Shift" key down  

  

Left and Right movement works as expected  

Up and Down moves ONLY the look point  (reverse tilt)  

Holding "Shift" and "Alt" keys 

down simultaneously  

Move the mouse to cause a forward and backward 

motion in 360 degrees  

  

Press the mouse wheel button and drag in the following directions:  

Mouse Direction  Resulting Effect in 3D View  

Forward  Moves the camera towards the look point (zoom in)  

Backward  Moves the camera away from the look point (zoom out)  

Holding "Alt" key down  Forward - moves camera AND look point in look 

directions (dolly)  

  Backward – moves camera AND look point away from 

look direction (reverse dolly)  

Left Click  

Left click and Alt key  

Moves up, down, left, right, orbits around 360 degrees  

Moves look point to element clicked (if any)  

Right Click  Moves up, down, left, right, orbits around 360 degrees  

  

Alternate Controls Set  

Although the alternate control set is based on current 3D modeling standards, it was a significant 
deviation from traditional O-Calc® Pro controls, therefore it was decided against being the default control 

set.   

Press the left mouse button and drag in the following directions:  

Modifier Keys  Resulting Effect in 3D View  

None  X = Orbits Camera around the Look Point  

Y = Raises and Lowers the Camera Look Point  
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Alt Key  X = Orbits Camera around Look Point  

Y = Raises and Lowers Camera only but NOT 

Look Point  

Shift Key  

  

X = Orbits Look Point around Camera  

Y = Raises and Lowers Camera only but NOT 

Look Point  

Holding "Shift" and "Alt" 

keys down simultaneously   

X = Orbits Camera around Look Point  

Y = Raises and Lowers Look Point but NOT Camera  

  

Press the right mouse button and drag in the following directions:  

Modifier Keys  Resulting Effect in 3D View  

None  X = Moves Camera and Look Point Perpendicular to Look 

Direction  

Y = Moves Camera and Look Point Parallel to Look 

Direction  

Shift Key  X = No action  

Y = Moves Camera Towards or Away from Look 

Point (Zoom)  

Press the mouse wheel button and key below to drag in the following 

directions:  

Modifier Keys  Resulting Effect in 3D View  

None  Moves Camera Towards or Away form Look Point 

(Zoom)  

Shift Key  Raises and Lowers Camera and Look Point  

Alt Key  

  

Raises and Lowers Look Point but NOT Camera  

Shift and Alt Key  Raises and Lowers camera only but NOT Look Point  

  


