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Osmose O-Calc® Pro Line Design Overview 

About Osmose O-Calc® Pro Line Design 
Osmose O-Calc® Pro Line Design automates the calculation of structural loading on new and 

existing lines of utility poles. The Line Design enhancement of O-Calc® Pro can be used for full 

line design, network extensions design, full circuit loading analysis, make ready engineering 

work and clearance analysis issue detection and correction.  

With O-Calc® Pro Line Design, one can analyze an entire circuit (line of poles). As with previous 

versions of O-Calc® Pro, non-structural engineers can decide whether more cables can be added, 

or larger conductors can be used on existing pole lines. The calculations in O-Calc® Pro Line 

Design are complex, but the operator interface is designed for simplicity of use. In addition to 

technical load calculations and statistics, this application provides a configurable, three-

dimensional visual rendering of each utility line’s load conditions and environmental conditions.  

O-Calc® Pro Line Design can be used to evaluate the integrity of an entire line of poles and each 

pole within the line. It can quickly assess the impact of re-conductoring, by automatically 

stringing new spans up to each pole in a line. The O-Calc® Pro analysis of stress along the length 

of the pole for each pole in a line can be used to consider cost-effective alternatives to replacing 

overloaded poles.  

O-Calc® Pro Line Design is a powerful new resource in evaluating structural load for joint use, 

safety, network reliability, and network planning purposes.  

Osmose O-Calc® Pro Line Design Concepts 
Osmose O-Calc® Pro allows you to model a line of utility structures (wood, steel, or concrete 

poles) by defining the components of each structure using the Inventory Window or 

interactively constructing the line of structures in the 3D View and Line Design View. All 

methods can be used simultaneously. There are several methods that can be used to create a 

line of poles, each starting with predefined components from the Master or User Catalogs.  
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Understanding the O-Calc® Pro Line Design Workspace 

Workspace Windows  Description 

Line Design Model many poles in the 3D View area and make global edits to the 
line design.  

Line Design Auxiliary 
Menu 

Contains the Line Design auxiliary menus and submenu tools and 
options to the left of the Map area, such as Poles, GIS Files, Map, and 
Clearance. This area can be collapsed. 

Line Design Main Menu Contains the Line Design main menu tools and options in the Line 
Design area are related to opening, closing, and modifying the entire 
line, or segments of that line.  

Poles Menu Poles offers menus and submenus to perform operations such as 
adding, editing, or removing poles within the Line Design. 

GIS Files Menu Used to add GIS files, including Shapefiles and GeoJSON files. Once 
added, a list of the added files is shown plus a check to enable or 
disable each layer. 

Map Area Used to visualize the poles on a map background. Here you can 
display public domain maps such as OMV Tiles and Open Street Maps. 
Other subscription services are available, like Google Maps.  
 
*Note: The license key for subscription map services is the 
responsibility of the end user; they are not provided with your  O-Calc® 
Pro license.  
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Understanding the O-Calc® Pro Line Design Menus 

Line Design Menu  
This section of the user guide reviews various functions that can be performed from the Line Design 

menu. 

 

 

 

Collapses or Expands the Line Design area which 
shows the poles on a background map. This 
feature is helpful for expanding the map area. 

 

Use the magnifying glass icon to search for any 
Line Design menu items. 

 

File Menu 

 

Open Line Design 
Within the File menu, the Open Line Design option is used to open an existing, previously saved Line 

Design file. A Line Design file has the file extension ‘.pplld’. Only one Line Design file can be open at a 

time, so the Open Line Design option is disabled if a .pplld file is already open. 

To open an existing line design (.pplld) file, complete these steps: 

1. Under the File option, select Open Line Design… 

2. In the Load Line Design window, select a .pplld file and click Open. 

Alternatively, Line Design files can also be opened by dragging and dropping a line design file into the 

Poles menu, left of the Line Design map area.  

Save Line Design 
The Save Line Design option enables the user to manually force a save to the Line Design file. While line 

design files are saved dynamically as work is performed, selecting this option immediately forces any 

edits made to be committed to the line design file.  

1. In the Line Design area, under the File option, select Save Line Design. 

Clearance Menu Used to create clearance violation rules and check for violations. Tools 
are available to model field conditions like foliage, structures, 
surfaces, and easements of various types.  



Osmose O-Calc® Pro 8.0  Line Design User Guide 

©2025 Osmose Utilities Services, Inc.      11 
 

 

Save Line Design As… 
The Save Line Design As option allows a user to take the currently open line design and save it with a 

different name, maintaining the previously opened line design file.  

1. In the Main Line Design area, under the File Option, select Save Line Design As… 

2. A File Explorer window opens; navigate to a location and enter a file name for the new .pplld 

file, click Save. 

Close Line Design 
The Close Line Design option exits the Line Design mode when a line design file was open. The File menu 

in single pole O-Calc® Pro (upper left corner) is disabled while a Line Design file is open and the message 

below appears in red: 

 

1. Under the File option in the Line Design panel, select the Close Line Design option to close an 

open line design file. 

Note: When opening, editing, saving, or closing Line Design files, there is no option to ‘undo’ any of 

these operations. These changes are saved dynamically as the user works, so there is no option to undo 

a previous action. Any changes that are made are stored and must be corrected manually by the user. 

Saved Line Design File List 
In the Line Design File menu the last six Line Design files (.pplld file type) saved are displayed for easy 

retrieval.  Complete these steps: 

1. From Line Design, click the File option. 

2. Listed below the Close Line Design option, see your last six files displayed: 
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Using Line Wizard 
To start a new line design using the wizard functionality, complete these steps: 

1. Begin by opening the .pplx file for the first pole in the line, or by modeling a new pole. Any pole 

can be your Line Design seed (template) pole. Click yes to specify which span set for multiple 

span sets, i.e. tangent pole with spans, and continue to the next step of selecting the span 

direction. 

  
2. In the Line Design menu, under the File option, select New Line Design. 

3. From the options, select the Using Line Wizard option. 
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4. The pink ‘Select Line Start’ prompt at the top of the map area indicates you are ready to start 

using Line Wizard. Use the cursor to select a point on the map where you’d like to place the 

starting pole – notice the cursor displays the coordinates for where it is placed. 

5. Left click once to place the first pole in the line. Notice the yellow ‘Extend (click here when 

done)’ prompt at the top of the map area. 

6. Continue to place poles on the map as desired and click the yellow prompt when done. 

 



Osmose O-Calc® Pro 8.0  Line Design User Guide 

14   ©2025 Osmose Utilites Services, Inc.  
 

Note: Use the Mouse Scroll wheel to zoom in or out; hold down the right-click and drag to pan 

around the map view.  As the mouse is moved to the location of the next pole, the coordinates of 

the next pole and the distance from the previous pole are displayed on the cursor.  

 

7. Notice the ‘O-Calc Pro – Working’ progress bar. Note: You may also be prompted to save the 

original seed pole (template used to start the line) .pplx file. 

8. The Create Line Design window appears. Enter a File name, click Save. 

 

Starting a line design using the wizard tool is the easiest approach to modeling an entire line of poles. 

This method allows the user to set up the first (seed) pole as essentially a template pole, with 

attachments like those attached on all other poles in the line. By creating a line using the wizard, the 

attachments on the seed pole are carried over to each new pole in the line. Each pole is labeled 

according to the order in which they were placed.  Additionally, the wizard ensures that the connectivity 

of the spans is carried from one pole to the next.  

Tip: To assign the Pole Number as you are adding poles to the map using the Line Wizard, simply 

click to toggle on the Edit Pole ID When Created option. Go to Line Design > Options > Editing 

Options > Edit Pole ID When Created. 

 

Terminate Wizard Line 
This setting is used to automatically end a line on conductors created using the line design wizard. It is 

enabled by default and ensures that when a line is being extended using the wizard, the last pole in the 

line does not further extend any attached spans.  
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Line of poles that terminates. 

This feature would be disabled if additional poles were going to be added later, perhaps by adding an 

existing .pplx file to the line design. To disable this feature, complete these steps: 

1. Under the File option, select New Line Design 

2. Select Terminate Wizard Line to un-check and disable the feature.  

 

Line of poles that do not terminate. 

Start Line with Current Pole(s) 
To start a new line design using a single existing .pplx file with valid coordinates, complete these steps: 

1. Begin by opening the .pplx file for the first pole in the line design. 

2. Ensure that it has coordinates entered under Edit > Pole Coordinates. 

3. Under the File option, select New Line Design. 

4. From the options, select Start Line with Current Pole(s). 

 
5. The Create Line Design window appears, enter a File name, click Save. 
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6. A pole icon (dot) is placed on the map for the first pole in the line design and a corresponding 

pole is added to the list under the Poles menu. 

 
7. Additional (as many as you want, typically 40 is what the average device can process in a timely 

manner) poles can be added using the Add PPLX Files to Line Design Method. 

 
 

Taking an existing pole and using it to start a line design is also an acceptable method, although there 

are some additional steps when compared to using Line Wizard.  

• First, coordinates must but entered for this pole – they cannot be added by selecting a point on 

the map, like they are when the Line Wizard is used.  

• Secondly, any new poles in the line must be added individually and without connectivity.  

New poles that are added must be manually linked (connected) to each adjacent pole in the line. This 

process is outlined in this guide under the section about Linking Spans. When a line design is created 

using this method, the poles that are added are not labeled in the Poles menu, they appear with the 

Pole Number designation of ‘Unset’.  

Import a Line Design 
Another method for starting a new Line Design is the use of a spreadsheet of data and a pole model to 

generate the line of poles. This method would be useful for a list of poles and their coordinates, and 

essentially batch-generating them. To use this method, complete these steps: 

1. Begin by opening the .pplx file for the first pole in the line or modeling a new pole.  

2. Under the File option, select New Line Design. 

3. From the selections, choose Import, followed by Create Line from Data. 
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4. When prompted, select a data file to use and click OK. 

5. When prompted, enter a name for the line design and click Save. 

 

This approach requires the imported pole data to be formatted in a very specific way. For more 

information on formatting that data click the Show Expected Format option. See the section Formatting 

Input Data for Creating Line Design. Using this method requires a seed pole to be chosen or modeled. 

Then, using the pole data file, O-Calc® Pro generates the additional poles in the line, copying over the 

attachments from the seed pole. When this operation is performed using a pole data file with multiple 

entries, each entry is added to the line design, in the order they are listed. Connectivity between the 

poles is applied, like it is when using the Line Wizard feature. 

Export > Overhead View 
This function allows a user to export the line of poles that they have modeled in several formats, 

specifically as an overhead view of the line. The export of the overhead view can be used to generate 

several file formats, including DXF, Shapefile, PDF, EMF, and GeoJSON. The level of detail of the 
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exported overhead view can be either Simplified View or Mesh View. Simplified view represents the 

insulators as nodes, while Mesh view renders them in more detail.  

 

To open the window shown above, complete these steps: 

1. Under the File option, select Export 

2. Select Overhead View 

3. Set the Format for the exported file, and the level of Detail 

4. Click Export; if enabled, the file is opened after the export is complete 

But how do you know which format to choose? That would depend on how the data were going to be 

used. Regarding the formats, a Shapefile could be loaded into a GIS program, or a PDF could be used to 

generate a graphic for a report or presentation. The other formats would have more technical 

applications, like a GeoJSON.  

 

Simplified (insulator shown as node)                            Mesh (insulator is rendered in detail) 

In the left image, the Simplified overhead view is shown, with each insulator being represented as a 

node. In the right image, the Mesh overhead view is shown, with each insulator being rendered in more 

detail.  

Export > Profile View 
This function allows a user to export a line of poles in several formats, specifically as a Profile (side) View 

of the line. The Profile View of the line design can be exported as a DXF, Shapefile, or PDF. Additionally, 

there is a drop-down menu that enables the user to form several preset scale factors, indicated by Horiz 

%, which is the amount of ‘horizontal percent” used in the scaling shown in the exported file.  
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For instance, in this image the Horiz % is set to 10, so the exported file is scaled down to 10% of its 

original horizontal scale. This results in an output that is easier to read, as shown below.  

 

The screen shot above shows an example of profile view. This profile view was exported with a 10% 

scale factor in the horizontal direction. 

This function also has an option to immediately open the exported results when they are created just 

like in the Export Overhead View tool.  

Export > Mesh (3D) 
The Mesh (3D) export option allows a user to export the entire line of poles as a 3D file, like in a Collada 

(KMZ), Shapefile, of DXF format. These files can often be used to view a 3D rendering of the pole line, 

like what can be seen in the 3D View in O-Calc® Pro. Here, there is also an option to open the results 
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when the export is complete. Note: This same type of result can be achieved using Show Pole on Google 

Earth > Render Structure. Learn more about Plugins at our Wiki site: http://o-calcpro.com/wiki/ 

Below is an image of the Collada, or KMZ file exported and displayed in Google Earth.  

 

Edit Menu 

Lock Wind 
Locking the wind angles on one or several poles allows the user to determine loading on the entire line, 

given a specific wind direction. By default, O-Calc Pro sweeps the wind around the entire pole and 

identifies a wind direction as being the ‘worst case scenario’. In this situation, the worst wind angle is 

calculated by the program, and any capacity meter readings are based on that worst-case wind 

direction.  

To lock the wind that is calculated in Line Design, complete these steps: 

http://o-calcpro.com/wiki/
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1. Under the Edit option, select Lock Wind 

2. From the list, select the poles for which the wind is to be locked; these can be: 

a. All Poles 

b. Checked Poles 

c. Current Pole 

 

3. Enter a value for the wind angle; this would be the wind direction that wind is coming towards, 

not the direction that it is coming from. 

4. Click OK. 

5. O-Calc Pro iterates through each pole in the line design, adjusting the wind angles to the value 

entered for the selected poles. Click OK. 

 

Freeze Guys 
This Freeze Guys feature is designed to be used if, and only if, span-head guy wires and the associated 

stub poles are going to be processed as individual .pplx files at some point in time. Typically, when a 

span-head guy is used, the tension applied on that guy wire is calculated dynamically, depending on the 

wind, and loading on the pole that it is supporting. Then, when the stub pole is analyzed, the tension 

would have to be entered manually or essentially ‘copied’ from the main pole to the stub pole.  

When freezing (locking) the guys, the tension going to the stub pole on the span-head guy is then copied 

and used as the tension coming from the span-head guy to the main pole.  

To freeze (lock) the tension of the guy wires applied to subsequent poles in a line design, complete 

these steps: 

1. Under Edit > Freeze Guys, select Freeze Span/Head Guys. 
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2. From the list, select the poles for which the span-head guy wire tension needs to be frozen: 

a. All Poles 

b. Checked Poles 

c. Current Pole 

 

3. Enter a value for the wind angle to be applied to calculate the tension of the span-head guy 

wire; this tension is going to be fixed, so the individual .pplx file of the stub pole can be 

analyzed.  

Utilities > Fix Separated Links 
The Fix Separated Links feature allows the user to remove the chain-link with red slash through its icon 

in the Inventory for spans that were previously linked but have been separated. Separated spans can 

occur when a pole with linked spans has been deleted from the Line Design. The spans previously linked 

to a pole’s spans are now considered ‘Separated’. The spans that remain may need to be un-linked from 

the deleted pole. To un-link globally rather than individually, complete these steps: 

1. From the Line Design menu select Edit > Utilities > Fix Separated Links. 
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2. The chain-links with red slash through its icon for the Separated spans are removed.  

 

Utilities > Constrain All Elements 
This feature is ideal for situations that arise after a substitution or edit has been performed that results 

in a configuration that is illegal. For instance, a crossarm with insulators that are placed beyond the end 

of the crossarm. This feature forces the illegal arrangement to become legal, by adjusting the placement 

of elements as directed. To use this feature, complete these steps: 

1. Begin with a pole in a line design, perhaps like the one pictured here: 

 

2. Make an edit that could be considered illegal – like shortening the crossarm or substituting it 

with a smaller size: 

 

3. In Line Design, go to the Edit > Utilities menu, and select Constrain All Elements 
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4. Corrects illegal arrangement by snapping to legal position, in this case to ends of crossarm. 

 

Undo/Redo 
These options allow a user to undo or redo the previous action that was performed in Line Design. Just 

like previous versions of O-Calc® Pro, there are keyboard shortcuts for both actions.  

Undo CTRL + Z 

Redo CTRL + Y 

Tools Menu  
The tools menu includes many functions designed to simplify and expedite the line design process. The 

tools outlined here are meant to be used when a line design has already been created and needs to be 

edited.  

Map Measure Tool 
The Map Measure Tool option allows you to determine the location, length, and direction of a span from 

the main line design area. This tool can be useful in determining the distances and angle between 

structures or other features visible in the main line design area. To use the Map Measure Tool complete 

these steps: 

1. Go to the Tools menu, click on the Map Measure Tool option. The data window appears in the 

upper right corner of the map area; it is currently blank.  

       

2.  To measure any distance and angle on the map, left mouse click and hold on the map at the 

start point and drag to the end point you need to measure, release the click.  

The red dotted line (visual reference) indicates the measurement on the map. The data window 

dynamically updates the values as you move the mouse around. As soon as you release the left mouse 

click the final measurement values are displayed in the data window. 
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3. To make use of the measurement information displayed, right-click in the data window and 

select the Copy start set of Lat/Lon. 

 
 

4. The Edit box appears; enter a name for the Lat/Lon values and click OK. 
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5. To use the Copy set name (Start) information you saved, go to the Edit menu in the main menu 

of O-Calc® Pro, select the Pole Coordinates option. 

 
 

6. In the Geolocation window, select the Named Coordinate button. 

 
 

7. From the list of Named Coordinates you created, select the name you need. The values are 

updated in the Geolocation window and may result in the select pole being moved to the new 

lat/lon location within the Named Coordinate selected. 

 
 

Note: To end use of the Map Measure Tool and make the Map Measure window disappear, simply go to 

the Tools menu and deselect the Map Measure Tool option. 
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Copy and Paste Latitude Longitude Data 
This tool allows you to copy and paste the latitude and longitude, and the distance and bearing of the 

coordinates displayed in the tool. To use the tool complete these steps: 

1. Open or create a Line Design. 

2. Go to the Tools menu, click the Map Measure Tool option. 

 
 

3. The tool is now enabled, and a blank Map Measure window appears in the upper right corner of 

the map area. 

 
4. Click on the map at the start point of the needed measurement, hold and drag your cursor to 

the end point of the needed measurement. This action creates a red dashed measure line on the 

map. Release the click to end the measure line. 
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5. Notice the Map Measure window is now populated with the results of the measurement. 

6. Right click inside the Map Measure window in the upper right corner. 

 

7. Select Copy start set of Lat/Lon and an Edit window appears. 

 

8. Give the Lat/Long values a name and then click OK. 

To use the saved named values, you can use these tools: 

• Edit > Pole Coordinates > Named Coordinates in the Geolocation window 

• Set Anchor Location using Get Coordinate option 
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Geolocation 
1. Go to View > Center on Coordinate.  

2. The Geolocation Window appears. 

3. On the bottom right corner of the popup window click Get Coordinate > Named Coordinate.  

 

4. A sub menu appears with the named Lat/Long value. Select the value and then click OK. 

 

 

Anchor Location 
1. Open a pole with an Anchor attached. 

2. In the Inventory, right-click on the Anchor. 

3. Select the Set Anchor Location option. 

 

4. A window named Edit anchor Location appears. On the bottom left corner select Lat Lon 
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5. Afterwards the Geolocation window opens. From there, click on Named Coordinate and select 

the named value. 

 

 

 

Copying the Distance and Bearing 
Like Copying and Pasting of the Latitude and Longitude Values, you can copy the distance and bearing 

values.  

The distance and bearing values from the map measure tool provides the length and direction directly 

from the user’s input measurement. This is useful to allow the user to accurately place a guy brace’s 

anchor a specific distance and direction away from a pole. 

To use this feature, complete these steps. 

1. Start with an existing Line Design. 

2. Enable the Map Measure Tool. 

3. Using the left click, draw a line in the Line Design Map from your desired start point to your 

desired endpoint (where you want your new pole to be or the end of your new span.)  
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4. Right click in the Map Measure Window to open the copy and paste dialog. Select Copy distance 

and bearing. 

 

 

5. Name the distance and bearing and click OK. 
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6. Select an anchor on your pole and with a right click open the menu and select Set Anchor 

Location. 

 

7. In the Edit Anchor Location window, select the Distance/Bearing button at the bottom. 

 

8. Select the named coordinate you created in a previous step to populate the desired location of 

the anchor. Select OK to finish.  
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Span Bay Linking Tool 
From the Tools menu select the Span Bay Linking Tool, click the Bay Linker option, this allows the 

yellow arrows to appear on the map for span that are not yet linked. Using the drag and drop method, 

users can click between span bays in a line design to link up the spans automatically. This feature is 

useful in the linking processes by allowing O-Calc to automatically match up the adjacent wire type for 

linking without needing to switch views or the selected pole.  

 

   

 

  

View PPLX Directory on Map 
The View PPLX Directory on Map option allows a user to choose a directory, or folder, of poles to 

display in the Map area. From this set of poles, a subset may be selected and used to generate a new 

Line Design File. To use this operation, complete these steps: 
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1. Set up a directory or folder of the poles you need to include, each must have pole coordinates. 

2. Ensure that a Line Design file is not open. 

3. In the Main Line Design area ribbon, select the Tools option. 

4. From the list, select the View PPLX Directory on Map option. 

5. In windows explorer, navigate to, and select the directory where the poles can be found, and 

click Select Folder. 

6. After processing, pole icons (dots) appear on the map to show where each of the poles are 

located. 

 

7. Select all the poles by clicking on each, or a subset by clicking on the desired poles. 

 

8. Under the File option, select New Line Design > Start Line with Current Pole(s) 

9. When prompted, enter a name for the Line Design, and click Save 

After the Line Design has been created, edits can be made including linking spans and reordering the 

poles.  
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Extend or Branch Line 
There are multiple scenarios where using this tool could be beneficial. Essentially, extending or 

branching a line means adding additional poles to a line design either in the same segment, or creating a 

branch segment from an existing line. In either case, a pole is selected as the origin of the extension, and 

additional poles can be added with spans linked to that origin pole. Additional examples of both 

scenarios can be found in Appendix A – Common Workflows.  

 

To extend or add a branch to a line, complete these steps: 

1. Open a line design file. 

2. Select a pole in the line to use as the starting point for the extension or branch. 

a. The selected pole should have a set of unlinked spans going in a single direction, with 

uniform length; if it doesn’t, this informational message is displayed: 

 

b. If this message is shown, click ‘OK’ and create an unlinked span set on the selected pole. 

3. From the Line Design menu, select the Tools option. 

4. From the list, place the cursor over the Extend or Branch Line option. Select from the two 

options; Add a Single Pole; Add a Line of Poles. Keep in mind that if the Terminate Line from 

Current Pole is checked, this option results in the spans being terminated automatically at the 

last pole you add. If unchecked, a set of unlinked spans remain when the last pole is added. 
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5. Continue this process until the line extension is complete, then click the yellow Extend (click 

here when done) prompt at the top of the map area. All the spans are linked automatically. 

 

Import 
The Import option can be used to import pole information and coordinates to extend or branch a line. 

The Import tool is outlined in full here.  

Perform Stringing 
The Perform Stringing function aims to speed up adding a new span (communication or electric) to an 

entire line of poles, or multiple poles in a line. This function requires that a stringing assembly be set 

before using this tool.  

Setting a Default Stringing Assembly 
A default stringing assembly is typically an assembly with an insulator or hardware object, and its 

associated conductor or communication bundle. For instance, a three-bolt with a communication 

bundle, or a dead-end insulator with a secondary span. This default stringing assembly must either be 

found in the Master Catalog or created and placed in the User Catalog. The setting of a default stringing 

assembly is only possible from within a catalog when right-clicking on the parent object (hardware or 

insulator) for the assembly. 

In the image below, you would right-click on the bolt within ‘1.5” Telco Assembly’. In the menu, select 

the Set Line Design Stringing Assembly option. Once a Line Design Stringing Assembly has been set, it 

remains the default stinging assembly until a different one is set.  
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Perform Stringing 
After the stringing assembly has been set, the Perform Stringing operation can be performed for All 

Poles, or only for Checked Poles.  Complete these steps to perform stringing: 

1. Open a Line Design. 

2. If necessary, check the poles listed in the Poles menu that you would like to perform stringing 

on. 

a. This step is not necessary if stringing is to be done on all the poles. 

3. Under Tools, hover the cursor over Perform Stringing, and select either All Poles or Checked 

Poles. 

 

4. The Stringing Height Settings window opens. 

 

a. Set – Users can choose where to set the stringing assembly; either using the top, center 

or bottom of the element being used as the parent (insulator or hardware) object. 

b. At – Users can choose the attachment height for the stringing element to be added on 

each pole.  
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c. Relative to – Users can choose where the placement height is relative to; groundline, tip 

of the pole, the top lower, bottom power, top comm or lowest comm. 

d. Saved settings - Any name entered here is used to store the selected settings for future 

use, this is optional. Use the ‘X’ to delete a Saved setting entry. 

5. When finished, click OK. 

When the operation is completed the chosen stringing assembly is placed on the intended poles. Refer 

to the 3D View area to inspect the results and perform any necessary edits. 

Add Drops to Current Pole 
The Add Drops to Current (pole in the Inventory) Pole feature allows a user to add multiple drops at 

once coming from one pole and extending in different directions. This feature also requires setting a 

Line Design Stringing Assembly, which is used for the service drop.  

Complete these steps to add drops to the current pole: 

1. Open a Line Design. 

2. Click on the pole to have the service drops added to it. 

3. Ensure that a default stringing assembly has been set from a catalog by right clicking on the 

parent (insulator or hardware) object within the assembly. 

4. Under Tools, click the Add Drops to Current Pole option. 
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5. The Stringing Height Settings dialog window opens. 

 
a. Set – Used to set the stringing assembly; either using the top, center or bottom of the 

element being used as the parent (insulator or hardware) object. 

b. At – Used to choose the attachment height for the stringing object to be added to each 

pole.  

c. Relative to – Used to choose where the placement height is going to be relative to; 

groundline, tip of the pole, the top lower, bottom power, top comm or lowest comm. 

d. Saved settings - Any name entered here is used to store the selected settings for future 

use, this is optional. Use the ‘X’ to delete a Saved setting entry. 

6. When finished, click OK. 

7. Now drops can be added by clicking on the map; the point that is clicked on the map is the end 

of the drop location. Hold the CTRL key while adding drops on the map to cause the drops to 

come off one insulator. Do not hold the CTRL key to cause each drop to have its own insulator. 

8. Click the Add Drops (Click Here when done) prompt at the top of the map area, when finished. 
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Fix Span Rolls 
The Fix Span Rolls operation is used to correct for spans that have been drawn as crossing over the top 

of one another. When spans are being linked, or generated crisscrossing spans can occur. See the 

crisscrossed spans in the 3D View and in the Map area below: 
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Crisscrossed spans can be corrected by completing these steps: 

1. Open a line design with spans that are crisscrossing. 

2. From Line Design, select the Tools option. 

3. Hover the cursor over the Fix Span Rolls option. 

4. Select from the two options; Fix Span Rolls and Rotate Arms or Fix Span Rolls (Do Not Rotate 

Arms). 

5. Next, select the poles to be included in the operation; Current Pole Only, All Poles in Line, or 

Checked Poles. 

 

 

Align Insulators 
The Align Insulators tool is used to realign insulator angles to their respective span angles. This 

operation can perform a bulk edit for an entire pole, subset of poles in a line design, or the entire line. 

Complete these steps to align insulators: 

1. Open an existing or create a new Line Design file. 

2. From Line Design go to the Tools menu then hover over the option Align Insulators, click on one 

of the three options.  
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3. In this example we used the current pole only option to align these insulators with the spans. 

See below the before and after results: 

 

 
 

Auto LOL/Merge 
The Auto LOL/Merge tool can be used when previously created .pplx files are used to create a line 

design. Creating a line design from existing .pplx files requires that the user manually link each of the 

spans from one span to another on each pole. To assist with this process, the Auto LOL/Merge tool 

attempts to link the spans for the user. This tool was a first-generation tool in Line Design. Subsequently, 

the Span Bay Linking tool was developed for the same purpose and has added visual features. To use 

Auto LOL/Merge, complete these steps: 

1. Open an existing .pplx file with coordinates. 

2. From the Line Design menu, select File > New Line Design > Start with Line with Current 

Pole(s). 

3. In the Create Line Design window, enter a File name, click OK. 

a. The line design pole appears in the map area; if not visible, go to View > Zoom to Poles. 
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4. Add additional poles to the Line Design. 

a. In the Poles menu, select File > Add PPLX Files to Line Design. 

b. Navigate to the stored .pplx files and select multiple poles or add one at a time. 

c. Once selected, click ‘OK’ to add the poles to the line design. 

i. If the selected poles had a pole image embedded, a warning message displays – 

click ok on the warning message. Multiple messages show if multiple poles were 

added that had images. 

ii. The poles are added to the line design, but the images are removed. 
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5. Next, under Tools, hover the cursor over Other Tools and click Auto LOL/Merge. 

 

6. The Auto LOL/Merge dialog opens, where several parameters can be set. 
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a. Set the target, for which poles are to be included in the merge; All Poles; Selected Pole 

Only; Checked Poles Only. 

b. Select the Operations to perform: 

i. Set LOL – is to determine a Line of Lead 

ii. Merge Spans 

iii. Merge Guys 

iv. Add Jumpers (up or down placement) 

v. Ignore Elevation 

c. The Auto LOL Merge > Settings > Edit Thresholds option contains the Bay and Merge 

Thresholds window for inputting the values used when merging spans, along with 

parameters pertaining to how other spans are merged during the operation. 

  

This tool only identifies situations that fit the thresholds set under the ‘Settings’ options; not all 

spans may be linked or merged if they fall outside the set thresholds, or there are multiple merge 
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options that satisfy the thresholds, and the program cannot decide which to use. So, while this tool 

may help expedite the process, it is a starting point. A user can use this tool, then continue the 

manual linking process or decide to use the newer feature; Tools > Span Bay Linking Tool > Bay 

Linker. 

 

7. Click OK when the desired values are entered.  

8. To return to the default values at any time click the Reset to Defaults option in Settings. 

Generate Differences 
The Generate Differences option allows a user to select a Line Design and then compare the results 

against one that is currently loaded. The output can be in the form of a .Json or .xml file along with 

several other output options. 

• With no Line Design open select a Line Design to compare against 

 

 
 

• Next load up another Line Design. Once loaded the option for output preferences and difference 
comparisons is populated.  
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• Save as Json or xml – this option allows the differences to output and get saved in either of 
these formats 

• Display Diffs After Creation – this allows the user to immediately see the generated differences 

• Save Diffs All Poles – this allows for the user to save the difference for all the poles in the Line 
Design  

• Save Checked Poles Only - this prompts the user to save the differences for only the checked 
poles in the Line Design  

• Save Current Pole Only - this prompts the user to save the differences for only the currently 
selected pole in the Line Design   

• Show Differences – this menu option contains 2 more options.  

▪ Checked Poles Only – Used to set the differences to be displayed with only the 
currently checked poles 

▪ All Poles – Used to set the differences to be displayed for all poles in the Line 
Design 

The Version Poles option allows a user to create a pole copy inside of their Inventory based on the 
Checked Pole Only or All Poles selection. 
 

Split Span Head Anchors 
The Split Span Head Anchors tool allows a user to generate individual anchors for span head guys that 

are modeled as being attached to one anchor. Below is an image of a set of span head guy wires, all 

attached to the same anchor, or stub pole.  
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It is common to see a stub pole with multiple guy wires attached to it. However, in O-Calc® Pro Line 

Design it is not possible to link guy wires when there is more than one attached to the same stub pole. 

For more information on guy linking, see this section. To split the span head anchors, complete these 

steps: 

1. Open a Line Design. 

2. Set a pole with an associated stub pole as the active pole; ensure that the stub pole has multiple 

guy wires attached to it. 

3. In the Main Line Design area, select the Tools drop-down menu and hover the cursor over Other 

Tools. 

4. Click on Split Span Head Anchors; a new stub pole should be generated for each of the span 

head guy wires. These stub poles must all be in the same location, so they appear to be one 

pole; in the image below, three stub poles are listed in the Inventory, but in the 3D View, they 

are rendered as overlapping; they must be moved to be seen.  



Osmose O-Calc® Pro 8.0  Line Design User Guide 

©2025 Osmose Utilities Services, Inc.      49 
 

 

5. Reposition the individual stub poles by adjusting the Lead Length and Lead Angle attributes in 

the Date Entry panel. Once each of the span head guys has been assigned to their own stub 

pole, guy linking can be used. 
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Remove All Pole Attachments 
Remove All Pole Attachments allows a user to easily remove all or selected attachments from a pole(s). 

Complete these steps to remove attachments: 

1. Open a Line Design. 

2. If desired, check a subset of the poles listed in the Poles menu. 

3. From Line Design, select the Tools > Other Tools > Remove All Pole Attachments. 

 

4. Make a choice from the options available: 

 

5. In the Pole Attachments window (shown below) users can isolate which attachments to 

Remove or Keep by checking or unchecking the corresponding boxes. Click OK when done.  

Note: Ctrl-Z can be used to undo the operation if desired. 



Osmose O-Calc® Pro 8.0  Line Design User Guide 

©2025 Osmose Utilities Services, Inc.      51 
 

 

Bulk Set Owners 
The Bulk Set Owners tool allows a user to easily set ownership for not only the components on an 

individual pole, but to set ownership and propagate that ownership across spans that are linked. For 

instance, ownership could be set for the spans on a pole, and then that ownership is carried down along 

the links to every other segment of that line. To set bulk ownership, complete these steps: 

1. Open a Line Design. 

2. From Line Design, select Tools > Other Tools > Bulk Set Owners. Select which poles ownership is 

going to be set for; Current Pole Only; All Poles in Line; Checked Poles Only. 

 
 

This tool allows you to edit Ownership easily and quickly for elements. In addition to this, new 

functionality has been added to the O-Calc® Pro Query tool, accessible from the Catalog or Inventory 

Menu. See the O-Calc® Pro user guide for information on this new functionality regarding ownership.  
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3. The Bulk Set Owner window appears listing the attachments on the pole as shown below. 

 

4. Enter the owner for each element, if desired. The Pole owner defaults to itself, but this can also 

be overridden. Once entered, click OK.  

 

5. Move to the next pole in the line and examine the ownership; if you had selected All Poles in 

Line, each owner should now be set.  

Bulk Description Operations 
The Bulk Description operations allow a user to modify the descriptions for elements on a single pole in 

a line, or for a selection of poles in a line. To use this tool, complete these steps: 

1. Open a Line Design. 

2. Select Tools > Other Tools > Bulk Descriptions Operations. 

a. Select either Clear Descriptions or Edit Descriptions 

b. Select the poles this action is to be performed on; Current Pole Only; All Poles in Line; 

Checked Poles Only. 

Each element in the O-Calc® Pro Master Catalog has a default description. This feature allows a user to 

enter a description that they understand or are more familiar with. 
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3. The Edit Descriptions window appears. 

 

4. Enter the descriptions for the desired elements and click OK. 

 

 

 

Bulk Pole Edit 
The Bulk Edit Poles window allows you to edit pole attributes. Complete these steps: 

1. Select one of the two options presented; Checked Poles Only or All Poles in Line. 
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2. In the Bulk Edit Poles window, enter the desired pole edits. Click OK. 
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View Menu 
The View menu in Line Design offers helpful features to assist the user in quickly viewing and navigating 

the line of poles to aid in a different perspective of the poles in the line design. Below we’ll explore each 

feature within the View menu. 

 

 

Center Map on Pole Location 
This option allows a user to center the Line Design map area on the selected pole (the one in the 

Inventory and at the center of the groundline compass in the 3D View) within a line design (.pplld) file.  

To Center Map on Pole Location, complete these steps: 

1. In the Line Design toolbar, click the View menu. 

2. In the submenu select the Center Map on Pole Location option. 

Refresh Map 
This option allows a user to refresh the map that is drawn in the Main Line Design Area. To use this 

option, complete these steps: 

1. Open a Line Design.  

2. In the Line Design View menu, click Refresh Map. 

This feature would be used when a change or edit has been made, that doesn’t appear to be reflected in 

the map view. This could also be used to redraw map or OMV tiles in the map view.  

Copy Viewport 
This option allows a user to take a screenshot of the main line design area’s current view of a map. To 

capture this view, complete these steps: 
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1. Open a Line Design 

2. Zoom in/out to the desired map scale 

3. Pan to desired map view 

4. Under View, click Copy Viewport 

5. Where desired, right-click and paste, or use CTRL+V to paste copied viewport in desired location, 

like the example shown here: 

 

This would be useful for taking a quick screenshot of a line design that is in progress to share with 

another user.  

Set/Hide Ground in 3D View 
Set Ground in 3D View is an option that alters the display of the ground that is normally seen in the 3D 

View. Below is an image of a line design, with the default appearance of the ground.  
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This default appearance just shows a green area to represent the ground. Results may vary depending 

upon the source used for the map information, and the degree of detail available. Complete these steps 

to set the map in Line Design as the ground area: 

1. Open a Line Design. 

2. Go to the View menu, click the Set Ground in 3D View option. 

3. From the 3D View the ground matches the appearance of the map around the line design. 

 

The intent is to allow you to see where the other map objects are in relation to the line of poles, without 

having to switch back to map view repeatedly. To revert to the green ground appearance, under the 

View menu, select the Hide Ground in 3D View option. 

Profile View > Profile Chart 
This option allows the user to view a profile of a line design showing basic information and relative 

elevation pole to pole, for any selection of poles in a line design. From the profile chart we can see basic 

information; pole number; pole height; attachment heights; span lengths and change in pole elevation 

relative from pole to pole.  

1. Open a Line Design file. 

2. Use the checkboxes in the Poles list to include which poles in include in the profile chart.  

3. From Line Design go to View > Profile View > select the Profile Chart option. 

Height in Feet 
In this chart, the height above ground line is shown on the Y-axis to the left-hand side. This allows a user 

to see the various heights for the poles and their attachments. This range adjusts to fit all the selected 

poles within the profile view.  
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Profile Length in Feet 
Along the X-axis, a length is shown to indicate the distances between poles in the profile view. This 

range adjusts to fit all selected poles within the profile view.  

 

 

Note: Draw order is extremely important for this tool – for more information on draw order, see the 

section Sort/Check Helper or Auto Order  Should the pole order within the Poles list not be consecutive 

the chart results may appear skewed as in this example: 
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Profile View > Profile Viewer 
The Profile Viewer display’s details of a selection of poles from a line design in profile, or a view from the 

side rather than from above. This chart offers the ability to resize the window, zoom to fit the window, 

zoom in and out on the chart to read details, and print. 

To view the details of selection of poles, complete these steps: 

1. Open a Line Design file. 

2. Use the checkboxes in the Poles list to include which poles in include in the profile viewer.  

3. From Line Design go to View > Profile View > select the Profile Viewer option. 

 

 
Note: Draw order is extremely important for this tool – for more information on draw order, see the 

section Sort/Check Helper or Auto Order 

 

Overhead View 
Overhead View is a tool that generates an overhead, or birds-eye view of the line of poles. The overhead 

view contains information for each pole in the line, including the Pole Number, the Latitude and 

Longitude and Elevation.  

From this window, there are two menus: a file menu and a view menu. The file menu contains options 

to Save, Print, or Exit. The view menu contains an option to Zoom to Fit.  

To generate this view: 

1. Open a Line Design. 

2. Go to View > Overhead View to generate an image like the one shown here: 
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Reset to Extents 
The Reset to Extents option sets the Main Line Design Area map to its widest area. It is helpful to use 

this tool when you must move to a new location on the map. 
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Zoom to Poles 
This view function focuses on the poles in the line design. This zoom option is ideal when a line design is 

opened, but due to zooming out and panning around, a user has lost sight of the poles in the Main Line 

Design Area. To use this function: 

1. Open a line design file 

2. Zoom out or pan away from where the poles are in the map view 

3. In Line Design, go to the View drop-down list 

4. Select Zoom to Poles 

This narrows the focus in map area to only the poles in the line design. 

 

Zoom to Shapefiles 
In the Line Design > GIS Files menu, users can display User Defined Data in various formats in Map area.  

Data formats used are Shapefiles; KML File; CSV Lat Lon File; GeoJSON File; GeoImage File; GPS NMEA 

File formats. For more information on how to incorporate User Defined data, see the GIS Files 

Tabsection. Zoom to Shapefiles focuses the Map area on the shapefile or shapefiles in the Map. If 

multiple shapefiles are loaded, the user must choose one of the files to use for the zoom feature.   

To easily navigate to where Shapefile or GeoJSON are displayed in the Map area, complete these steps: 

1. Open a line design file and add the User Defined Data as a shapefile or a GeoJSON File. 

Note: More information on adding shapefiles can be found in the Shapefiles section. 

2. Zoom out or pan away from where the shapefiles are in the Map view 

3. In the GIS Files menu, left-click on one of the shapefiles – should be highlighted 

4. In the Main Line Design Area, go to the View drop-down list 

5. Select Zoom to Shapefiles 

Note: this option is not available if a Shapefile has not been selected from the list. 

Center on Coordinate 
Rather than using an item in the Map as the focus, a user has the option to use latitude and longitude to 

center the map. To center the Map on a set of coordinates, complete these steps: 
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1. Open a line design file. 

2. From Line Design go to View > Center on Coordinate, the Geolocation window appears. Enter 

the values or select on the Map and click OK. 

 
 

3. Click the Set Convention button to choose a different Lat Lon Format if desired. 

 
4. Enter the coordinates to be centered on and click OK. 

Note: The red crosshair indicating the center of the Map area does not align with the coordinates 

selected. 

 

Filter by Height > Enable Filter by Height 
This setting is used to enable the height filter sliding scale in the Map are of Line Design. Enabling this 

option displays a height filter scale to the left-land side of the Main Line Design Area. In addition to the 

height filter scale, numeric values can be entered at the top and bottom of the scale. To enable the 

filter, complete these steps: 

1. From Line Design, select View > Filter by Height. 

2. Click to toggle on/off the Enable Filter by Height option. 
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Enabling this setting allows a user to edit the height filter on-the-fly, rather than having to adjust it in 

the Schematic view and copy it or set the max height from the View menu.  

For instance, when pole heights cover a range of values, it may be beneficial to enable this setting to 

easily adjust the height filter settings. 

Filter by Height > Copy from Schematic View 
The Schematic view has always enabled users to filter spans based on the span’s attachment height on 

the pole; spans that are not within the range selected are not shown in the 3D View. In O-Calc® Pro Line 

Design a user may adjust the height filter in the schematic view and apply those adjustments to the Map 

display in the Main Line Design Area. To apply the Schematic View height filter settings to the Main Line 

area, complete these steps: 
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1. Open a line design, select any pole and view it in the 3D View. 

2. In the Schematic panel, the pole is visible with the associated attachment heights displayed; the 

heights filter (vertical sliding bar) is on the left-hand side, controlled by a top and/or bottom 

slider control. 

 

3. The height filter can be adjusted at the top and bottom, to set the height range that is to be 

shown in the 3D View; adjust as desired. 

4. From Line Design, click on the View menu option. 

5. Select the Filter by Height list and click Copy from Schematic View. 

6. Any adjustments are applied to both the 3D View for each pole in the line, and for the Map 

area. 
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Note: This feature if helpful when edit operations to the spans are being made in the Map area, and you need 

to see only spans at certain heights. Hiding all spans that don’t fall within the set height range could make it 

easier to edit only those that are within the given range.  

Filter by Height > Set Max Height 
You can set a maximum height based on a selected value from a list. To filter by a maximum height, 

complete these steps: 

1. Open a line design, select any pole, and view in 3D View. 

2. From Line Design, select the View > Filter by Height, and hover the cursor over the Set Max 

Height option. 

 

3. From the drop-down list, select a maximum height value; any spans above this height are not 

going to be displayed in the 3D View or the Map area. 

By using this feature, only spans below the target height are going to be visible in 3D View or in the Map; 

this also enables you to easily edit spans that are lower on the pole, that would otherwise be difficult to 

edit in the Map area. This is particularly true for complex poles, or those with spans that overlap in the 

Map.  

Filter by Link Status 
This setting allows a user to filter the spans shown in the 3D View or the Main Line Design Area based on 

if those spans are part of a linked pair. To use this filter option, complete these steps: 

1. Open any Line Design. 

2. Select a pole in the line design and view it in the 3D View. 

3. In Line Design, select the View menu. 

4. Click the Filter by Link Status option to enable it. It is disabled by default. 
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5. In the Map area, a new All Spans drop-down is now visible in the bottom right corner; this 

option allows you to quickly filter by span status for; All Spans; Linked; Un-Linked. 

 

Enabling this feature allows you to easily determine if any spans are not linked correctly or identify poles 

that have spans that are not linked as they should be. 

Options Menu 
This menu item lists a series of settings that can be adjusted by the user, as well as several functions that 

can be performed.  

Draw Pole Labels/ Backgrounds/ Pole Notes 
This Map pole label setting allows you to enable or disable labels and notes that display the Pole 

Number in the Map area. To adjust these settings, complete these steps: 

1. Open a line design. 

2. Determine if the labels are needed; below is an example of the labels being displayed. 

 
3. To disable the labels, go to the Options menu in Line Design. Labels are enabled by default. 

4. Select the Rendering Options, click on the first option in the list, Draw Pole Labels. 
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5. A check mark indicates the option is enable, no check mark means it is disabled. 

 

The use of these labels in the Map area of the Main Line Design Area is determined by the user; they 

may be unnecessary if the Map area is crowded or cluttered but also may be helpful for identifying a 

specific pole in the line quickly.  

To draw pole label backgrounds, complete these steps: 

1. Open any Line Design 

2. Enable draw pole labels. If the labels are difficult to see, it would be helpful to draw pole label 

backgrounds. 

3. Go to Options > Rendering Options in the Main Line Design Area Ribbon and select Draw Pole 

Label Background. An example is shown below.    

4. A white box should appear behind the pole labels in the Map. 
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Draw Pole Notes on Map 
This setting allows a user to toggle on or off a label that displays the content of a Note associated with a 

pole in a Line Design on the Map area. To adjust this setting, complete these steps: 

1. Open a line design. 

2. Identify a pole with a note attached to it; this can be done by looking through the poles for one 

with a note item in the Inventory list. 

 

3. To turn the labels on, go to the Options menu in the Main Line Design Area Ribbon. 

4. Click on the second option in the list, Draw Pole Notes. 

5. When checked, the note is displayed in Map area. 

 

6. To turn off the notes in the Main Line Design Area, repeat steps 3 and 4. 
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The use of these notes in the Map area of the Main Line Design Area is determined by the user; notes 

may be useful if there are comments about a pole that need to be visible, but these notes may also be 

turned off if not needed.  

Notes have many uses. The two wiki page articles, Fun with Notes and More Fun with Notes provide 

additional information on how these can be used. Furthermore, when notes are displayed in the Map 

area of the Main Line Design Area, they can be adjusted from the Map area. Information on these 

adjustments can be found in Appendix B, under the Controlling Notes in Map View section.  

 

Drag Pole from Source on Map 
This menu allows users the ability to manage how they want to add poles to their Line Design. Drag Pole 

from Source on Map contains options to allow poles from the users catalogs or even from the existing 

line design to be drag and dropped onto the Map to create additional poles in the current line design. 

Additionally, there are options under the menu for controlling how and where poles are added. 

This menu is found in the Line Design Options menu, under the Editing Options menu.  

 

Add Pole to Line on Drag From Catalog 
Checking this option allows you to drag and drop poles from your catalogs to the Line Design Map to add 

them to the Line Design.  

http://o-calcpro.com/wiki/2017/05/16/fun-with-notes/
http://o-calcpro.com/wiki/2017/10/27/more-fun-with-notes-notes-and-the-dmt-process/
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Edit Coordinates on Drag from Source  
Checking this option allows the user to adjust the latitude and longitude of the new pole created from 

dragging and dropping a pole into the line design. 

 

When this option is enabled, the Geolocation window is generated after you drag and drops a pole in 

the Line Design Map. You must then specify the latitude and longitude for the pole and click OK. 

 

 

Extend Line on Drag from Existing Pole 
This option allows the user to drag and drop a pole into the line design using a pole that already exists in 

the line design. 

 

To use this option, complete these steps: 

1. Select a pole at the end of your line design in the Line Design Map. 
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2. Left click and hold drag your mouse to the needed location on the Map. A symbol appears on 

the Map indicating that a new pole is ready to be added to that location. 

 

3. Release the left mouse and a small dialog box appears.  

  
4. Select the Create Pole and Link option. 

 

Link on Drag from Existing Pole 
Checking this option allows the user to link spans on two poles from the line design Map by drag and 

drop from the selected pole to another pole. 

 

To use this option, complete these steps: 

1. Open or create a line design containing these conditions: 

a. Two or more poles 

b. Having the same span quantity, type, and construction type. 

c. At least 1 unlinked span bay on each pole 
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2. Enable the Link on Drag from Existing Pole option. 

3. In the Line Design Map, click on and drag away from the first pole you need to link onto the 

second pole. A symbol appears when you hover over the second pole indicating that you are 

ready to link the poles. 

  

4. Release the left mouse button while hovering over the second pole to be linked. The O-Calc® Pro 

linking operation then links the two poles together. 

 

5. Verify that the two poles are linked together as desired. 
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Drag and Drop on Map Enabled 
The Drag and Drop on Map Enabled option allows the user to do several pole loading operations 

directly from the Map area. The user can add additional crossarms, spans and insulators to a pole or 

crossarm, add extra equipment to the pole, and add additional guys and anchors to the pole. Complete 

these steps: 

1. Open and existing Line Design or create a new Line Design. 

2. The Line Design must contain the features you need to duplicate already attached to the pole. 

This can be done through any number of attaching procedures. 

3.  Select the component to be duplicated in the Map area (for spans the insulator must be 

selected) and drag it over to the pole or crossarm that you need to attach it to. 

 

The complexity of edits that can be made with this option is limited; however it allows you to quickly 

build a pole that can be easily edited for accuracy.   

Alternatively, edits made by the drag and drop method within the 3D View offer more options as 

presented below.   
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Map Drag Left Mouse Button 
This option allows the user to use the left mouse button to pan around the Map area instead of the right 

mouse button. To enable this option, go to Options > User Interface Options > Map Drag Left Mouse 

Button as shown below.  

 

Include Pole Note Images 
In addition to toggling on or off the display of pole notes in the Map area, a user can further control 

what is shown by deciding whether to show pole images that are included in pole notes. To adjust this 

setting, complete these steps: 

1. Open a line design and identify a pole with a note attached to it; this note should include an 

image file. 

 

2. Determine whether the Draw Pole Notes option is disabled; if this option is disabled, enable it.  

3. To display pole images in the note shown in the Map area, go to the Options > Rendering 

Options menu in Line Design. 

4. Click on the Include Pole Note Images option. 
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Note: If the Draw Pole Notes option is disabled, the note cannot display even when the Include Pole 

Note Images option is enabled. 

 

5. The image is added to the displayed note in the Map area; this note may need to be resized or 

moved to see the image 

 

Displaying the pole image in the note may be useful if a user needs to quickly determine whether a pole 

image is associated with a pole, or perhaps how many images are associated with each pole in a line 

design.  

Draw Terrain Mesh 
This setting allows a user to toggle on or off a visual in the Map area of the Main Line Design Area; this 

visual identifies the area where the poles in the line design are. It essentially identifies the area where 

the line design is by drawing a polygon around all the poles in the opened line design. To adjust this 

setting, complete these steps: 

1. Open a line design, zoom out until all the poles in the line design are visible in the Map area. 
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2. Go to the Options > Rendering Options menu. 

3. Click on Draw Terrain Mesh; a green polygon is be drawn around all the poles in the line design. 

This setting is useful when zooming out and attempting to identify all poles in the line. When zoomed 

out to a larger scale, the green polygon may be easier to see. 

Configure Elevation Provider 
To perform this configuration, complete these steps: 

1. From the Poles list in Line Design, go to Edit > Set Elevation(s) > Configure Elevation Provider. 

2. From the list, select Configure Geolocation Provider. 

 

3. Select a provider from the list. 

4. Enter an API Key, click OK. 

Note: API Keys are not provided; they must be obtained by the user from the Provider. 

Warn on Duplicate PPLX File 
Used to generate a notification when you are adding a pole to a Line Design that has already been 

added. It is possible to add existing PPLX files to a line design file; the steps for this process can be found 
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here. However, if this setting is enabled and a user attempts to add the same PPLX file more than once, 

a cautionary message displays: 

 

 

Show Center Marker 
This setting allows a user to toggle on or off the red crosshair that marks the center of the Map area in 

the Map area. To adjust this setting, complete these steps: 

1. From Line Design, click on the Options > Rendering Options menu. 

2. Click on Show Center Marker. 

 

3. This turns the red crosshair on or off; pictured above is the Map area when this is enabled. 

This crosshair assists the user with positioning when panning around the Map area.  

Draw Road Width (OMVT) 
This setting allows the user to control road width drawn on the Map area when using the Osmose Map 

Vector Tiles (OMVT) which can be downloaded to your device. OMVT is a highly optimized and compact 

land base format that may be used as an offline backdrop for utility structure placement and editing 

operations. This setting can be toggled on or off to adjust the appearance of road features in the OMVT 

Map. To adjust this setting, complete these steps: 
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1. Open a line design, in the Map area, note that with the option disabled, lines are used to 

represent roads, as shown below. 

  

2. To enable enhanced road drawing, go to Options > Draw Road Width (OMVT). 

3. This shows the road’s relative width in the Map area.  

Drawing the widths of the roads in the Map area may be beneficial when zoomed in to a smaller scale. 

Placement of poles in relation to roads would be easier if a user could see approximately where the road 

edges are. For larger scale Maps, this setting may cause the Map to look cluttered.  

Draw Map Scale 
This setting allows a user to toggle on or off the scale bar that is shown in the Map area of Line Design. 

To adjust this setting, complete these steps: 

1. From Line Design, click on the Options > Rendering Options > Draw Map Scale. 

2. Enabling this feature shows a scale bar in the Map area of Line Design. This scale bar adjusts 

dynamically as you zooms in/out, changing the units to fit the scale.  

 

3. To disable this feature, repeat steps 1 and 2 in this section. 

A scale bar is immensely beneficial when using the Map area of Line Design. Having a quick, accessible 

way to determine distances in the Map area is helpful for a reference. The scale bar stops increasing in 

unit size after 2500 miles and stops decreasing in unit size after 4 feet.  

OMVT Render Thresholds 
This setting allows you to adjust the settings used when displaying the OMV Tiles in the Map area of Line 

Design. 
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These thresholds control the zoom and scaling of each of the listed components of the OMV Tiles. If 

altered, these can be reverted to the default values by clicking on the ‘Reset’ button.  

Edit Rendering Colors 
Each element of a model created in O-Calc® Pro is drawn rendered or drawn in a specific color. A user 

can change those colors, should they desire. To set custom colors, complete these steps: 

1. In Line Design, select the Options menu, select the Rendering Options list. 

2. Click the Edit Rendering Colors option. 

3. The Edit Render Colors window opens to display all the Master Catalog element options and the 

corresponding color possibilities. The File menu is available with options to Save, Export, Import 

and Reset to Default colors. 

  
 

4. In the window that opens, use the ‘+’ sign next to each element listed to view the currently 

assigned colors. 
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5. To change a color, click once on the item you need to reassign the color for; the Color selector 

tool opens. 

 

6. Select or create a new color; use the ‘Add to Custom Colors’ option to save custom colors for 

repeated use. 
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7. Click ‘OK’ to see the new color choice in the Edit Render Colors window. 

Import/Export Custom Render Colors 
Once set, it is also possible to export these custom colors to other users, using these steps: 

1. From Line Design, go to Options > Rendering Options > Edit Rendering Colors. 

2. Select the File option, select Export. 

3. When prompted, enter a name for the Custom Colors file, and choose a Save location; the file 

type is .pplr file, click Save. 

This file can be sent to others who can then import the file using these steps: 

1. From Line Design, go to the Options > Rendering Options list. 

2. From the list, select Edit Rendering Colors. 

3. In the Edit Render Colors window, select the File option, select Import. 

4. When prompted, choose a .pplr file for the import. 

5. Click Open. 

Restore Default Colors 
Should you need to restore the default color selections, complete these steps: 

1. From Line Design, go to Options > Rendering Options list. 

2. From the list, select Edit Rendering Colors. 

3. In the Edit Render Colors window, select the File option. 

4. Select Reset to Defaults. 

5. When prompted, select ‘Yes’ on the warning message. 

6. When prompted, select ‘Yes’ to restart the program. 

Display MCU Flags 
This setting allows you to see an indication of a pole’s pass/fail status in the Poles menu, and in the 3D 

View. The MCU Flag appears in the Poles menu as a red or green dot, found beside the pole in the list. A 
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green dot indicates a pole that is passing based on the applied load parameters, while a red dot 

indicates that the pole is failing.  

 

In the 3D View, the same indication is given at the base of each pole in the line.  

 

 

MCU Flag Thresholds 
Adjusting this setting alters the values that are used to determine whether a pole is considered passing 

or failing. To access these thresholds: 

1. In the Main Line Design area, select Options > Rendering Options 

2. Click MCU Flag Thresholds 

3. The MCU Flay Thresholds dialog opens 
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The default values shown above indicate that a pole is going to be marked as green, or passing, if its 

Maximum Capacity utilization is less than or equal to 85%. Any pole with an MCU between 95.1% and 

95% is going to be marked in yellow, to indicate that the MCU value is approaching failure. Any pole 

with a MCU between 95.1% and 99.5% is going to be marked in orange, indicating that it is very close to 

failure. Any pole with a MCU beyond this value is going to be marked in red, as a failing pole. These 

thresholds can be edited to suit your needs. 

Edit Pole ID When Created 
This setting allows you to enable editing the Pole ID assigned to newly generated poles when the Line 

Wizard is being used. When the Line Wizard is used to create a line of poles, a Pole ID is automatically 

populated for each added pole. When this option is enabled, each Pole ID can be edited when the new 

pole is added. To enable this feature, complete these steps: 

1. Click on the Options > Editing Options menu in the Main Line Design Area Ribbon 

2. Click the eleventh option in the list, Edit Pole ID When Created 

3. Enabling this feature shows a prompt for a Pole ID to be entered when a pole is added using the 

Line Wizard feature 

 

4. To disable this feature, repeat steps 1 and 2 in this section 

If a Pole ID needs to be changed after the line design has been generated, this is possible in the Data 

Entry panel.  

Auto-Jumper Created Poles and Default Jumper Placement 
These two Options menu choices relate to the placement of Jumper in a Line Design. The Auto-Jumper 

Created Poles option ensures that Jumpers are placed automatically when a line design is created using 

the line design wizard. The second parameter here, the Default Jumper Placement, determines where 

the jumper is to be placed when the Auto-Jumper Created Poles option is enabled.  
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The above image shows that jumpers can be placed either above, below, or to either side of the 

insulators when they are placed automatically.  

Auto Fix Span Rolls 
When creating a line design using the Line Wizard, or when adding a series of poles to your current line 

design from the Extend or Branch Line tool, the spans may become crisscrossed or rolled. Enabling this 

tool automatically checks whether your spans are rolled and corrects them.   

 

For example, in this line design created with the Line Wizard, the spans are rolled as noted in the red 

circle: 
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To fix this I have several options. I can choose to fix the links manually, or I can go to the 3D View and 

right click on the crossarm and choose the fix span rolls option as shown below: 
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You can enable the Auto fix span rolls option prior to creating or adding additional poles to their line 

design. To do so, go to Options > Editing Options > Auto-Fix Span Rolls and check the option to enable 

it. Below is a Line Design created with the Auto-Fix Span Rolls option enabled without any additional 

edits made: 
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Drag Pole From Source To Map 

When using Drag Pole From Source To Map there are several options. 

 

• Add Pole to Line on Drag From Catalog - Use to drag a pole from the Catalog and drop it 

on the Line Design Map area. 

• Edit Coordinates on Drag From Source – Use to bring up a Geolocation dialog box once a 

pole is dropped in the Line Design Map. 

 

• Extend Line on Drag From Existing Pole – Use to select a pole while in Line Design Map 

area and drag/drop to a new location to make a new pole. 

• Link On Drag From Existing Pole - Use to select a pole while in Line Design Map area and 

drag/drop to a new location to make a new pole and link it to the origin pole. 

 

Storage Options 
Used to adjust when a Line Design is not open. This setting allows you to determine whether they’d like 

to back up or archive the work they are doing, and if so, how it should be stored.  
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To enable this feature: 

1. Ensure no Line Design Files are open. 

2. Under Options, hover the cursor over Storage Options. 

3. Click on Auto Backup/History. 

4. Set where the backup is to be stored; the options include. 

a. Storing all poles in a compressed archive folder 

b. Storing all poles in a high-performance archive 

c. Storing all poles in a Single Folder 

d. Leave the poles in the original location 

When enabling the option to store a backup or history, keep in mind that these files do take up 

additional storage space on your computer.  

Merge/Bay Thresholds 
Use to adjust the parameters associated with the Auto LOL/Merge tool. These parameters can also be 

accessed from the Settings button associated with the Auto LOL / Merge tool. Adjust these parameters 

by: 

1. From Line Design, select the Options > Editing Options > Merge/Bay Thresholds > Edit 

Thresholds. 

 

2. Adjust the parameters as desired to determine which spans are to be linked within the 

parameters defined when the Auto LOL/Merge tool is used. These parameters could be 

adjusted for accuracy of the Auto LOL/Merge tool. 
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Show Load Report on Reports 
This setting determines where the O-Calc® Pro Line Analysis Report is going to be displayed, after it has 

been generated using the steps outlined in the Calculate section. When is option is enabled, running an 

analysis on a Line Design displays the results under the Reports. When this option is disabled, a separate 

window opens to display the O-Calc® Pro Line Analysis Report. To adjust this setting: 

1. From Line Design, select Options > User Interface Options > Show Load Report on Reports. 

 

Mirror Poles Menu on Main 
Used to determine if the Poles menu in the Line Design auxiliary menus (Poles, GIS Files, Map, 

Clearance) area on left side of the Map area is duplicated in the Main Line Design menu area. This 

option is enabled by default. The Poles menu is the only menu duplicated in both the Main Line Design 

menu and the Auxiliary menu area. When this option is disabled, the Poles menu can only be accessed 

from the auxiliary area. To enable complete these steps: 

1. From Line Design, select Options > Editing Options > Mirror “Poles” Menu on Main. 

2. Verify that the Poles menu is added to the main Line Design menu. 
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Dock Line Design Tools 
This setting determines where the Line Design menu can be placed. When enabled, this setting creates a 

separate tab, beside the Line Design tab. Below are images of each arrangement.  

The image below shows the layout when this setting is enabled. The Line Design auxiliary menus (Poles, 

GIS Files, Map, Clearance) appear under the Line Design Info tab, rather than to the left of the Line 

Design Map area.  

 

When this setting is disabled, the Line Design auxiliary menus (Poles, GIS Files, Map, Clearance) appear 

to the left of the Line Design Map area.  

 

To adjust this setting: 

1. In the Main Line Design area, select Options > User Interface Options 

2. Click Dock Line Design Tools 

3. You are prompted to restart O-Calc® Pro. Click Yes.  

Dock Clearance Tools 
Use to add the Clearance tools as a tab to the Docking Layout of O-Calc® Pro. This tool works similarly to 

Dock Line Design Tools. To adjust this setting go to Options > User Interface Options in Line Design, click 

Dock Clearance Tools. You are prompted to restart O-Calc® Pro. 

Shortcut Keys 
You can view existing shortcut keys O-Calc® Pro. by pressing the ‘Alt’ key on their keyboards. Once the 

‘Alt’ key is pressed, several letters become underlined to indicate that a shortcut can be used to access 

those options.  

 

This functionality is for you to define your own shortcuts to perform many actions. To set up user 

defined shortcuts, complete these steps: 

1. From Line Design, select the Options > User Interface Options > Shortcut Keys. 
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2. This launches the Shortcut Key Editor window. 

 

3. Select the desired action that the shortcut is to perform. 

4. Set the keys that are be used in the shortcut. 
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5. Click Apply. 

6. Click File and Save. 

Shortcuts can be created, saved, exported, or imported from another user.  

 

For more information, see the section on the Shortcut Key Editor in Appendix B.  

 

Allow Pole Versions in Inventory 
Pole versioning functionality works with Line Design files. To enable this option in the Options menu, 

select User Interface Options, click Allow Pole Versions in Inventory. 

Once enabled, you can right-click on any pole and select the New > Version of This Pole option. 

 

In the Inventory, you now see a copy of the pole and its equipment and can make needed edits to make 

a different version of the pole. 
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Calculate Menu 
These functions allow you to ‘solve’ the line design by running the calculation engine with O-Calc® Pro 

once the line design is ready for analysis. The options here allow you to choose what is analyzed, and 

how the analysis is run.   

Auto Solve Enabled 
When this option is enabled, O-Calc® Pro automatically updates the line calculation after every edit. This 

feature saves time by eliminating the need to run a manual calculation to see the effect of the  edits by 

clicking the Ready button, located in the tool bar below the Capacity display. 

Re-Solve All 
This option recalculates all poles in the Line Design according to the specifications of the latest changes. 

Line Analysis 

Under this heading find various options for manual line calculation. 

Current Pole 
Running an analysis on the current pole in the line runs an individual pole loading analysis on the pole; 

the result would be equivalent to the result generated in previous versions of O-Calc® Pro. This 

calculation can also be obtained for a pole by clicking on the ‘Ready’ button in the lower left tool bar of 

the application, just below the Capacity display. 

 

Checked Poles Only 
Used to calculate a subset of poles from the entire line by checking the desired poles in the Poles menu 

then using the drop-down menu to run a fixed wind or sweep wind calculation. You can also Re-run the 

last angle set, clear the MCU flags, and View Mesh for the checked poles similarly to the Run Entire Line 

features above.  

It is important to note that O-Calc® Pro calculates for transferred loads in Line designs so if a subset of 

poles is calculated the line cannot account for the transferred load from a pole that is not calculated. 

 

Fixed Wind Calculation 
When running a calculation on an entire line of poles, there are two options. Set the wind parameters is 

used when running an analysis on the entire line of poles. To run a calculation on an entire line using a 

fixed wind direction, complete these steps: 

1. Open a line design. 

2. In the Main Line Design Area ribbon, select the Calculate option. 

3. Hover the cursor over the Entire Line menu. 

4. Select Fixed Wind. 

5. Enter a value for the Wind Angle Degree in the window, click OK. 
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6. A report is generated under the Reports panel. 

 

7. Once finished reviewing the report, modifications to the calculations can be made by beginning 

this process over again and selecting a different Wind Angle, or using the Sweep Wind method, 

outlined in the next section. 

More information on interpreting the results of this report can be found on the associated wiki page, 

found here. When setting the wind angle, it is important to remember that this is the direction the wind 

is coming from, not the direction the wind is going towards.  

Sweep Wind Calculation 
The other method available allows for a more dynamic analysis of the line design. To set the parameters 

for analyzing a line design with wind coming from different directions and outputting the results for the 

worst-case scenario. By using this method, you can easily determine the worst-case wind angle, and 

what that wind angle would do to the analysis of the entire line of poles. To use this method, complete 

these steps: 

http://o-calcpro.com/wiki/2018/12/18/understanding-the-o-calc-pro-line-analysis-report-2/
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1. Open a line design. 

2. From Line Design, select Calculate > Entire Line > Sweep Wind option. 

3. Use the default values or enter values for the Start Angle, End Angle, and the Increment to be 

used; click OK. 

 

4. This process can take a few moments longer than the Fixed Wind, a report is generated in the  

Reports panel. 

 

5. Once finished reviewing the report, modifications to the calculations can be made by beginning 

this process again and selecting different values for the Start Angle, End Angle, and Increment 

Parameters. 
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More information on interpreting the results of this report can be found on the associated wiki page, 

found here. When setting the Start and End Angles, it is important to remember that these are the 

angles that the wind is coming from. The Increment value determines which Wind Angles are also 

calculated between the Start and End Angles. 

Re-Run Last Angle Set 
Re Run Last Angle Set runs the same calculation that was previously run after making further alterations 

to the line design. 

Clear MCU Flags 
Clear MCU Flags is used to clear the green, yellow, orange, and red flags that visually show the MCU 

thresholds in the Line Design Poles list. The flags can only appear after a pole or Line Design is 

calculated. The flags are updated after every time the pole is calculated. Below is a before and after 

image of the Poles list when the Clear MCU Flags is completed.     

http://o-calcpro.com/wiki/2018/12/18/understanding-the-o-calc-pro-line-analysis-report-2/
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View Mesh   
Used to view the mesh on the active pole created by O-Calc® Pro used in the finite element analysis 

(FEA) calculation. This is helpful to visualize the loads acting on the pole and to view the pole deflection 

they cause. 

 

To bring up the mesh viewer window simply navigate to Calculate > Entire Line > View Mesh in the Main 

Line Design Area Ribbon.  

Fix Span / Head Anchors 
Used to change how O-Calc calculates span guys in line design. Normally when a pole is loaded and 

subsequently deflects, this deflection is applied to the span guy and is incorporated in the overall 

calculation of the line.  

By selecting the Fix Span / Head Anchors option, the deflection at the end of the span guy is not 

considered during the calculation of the line. 

Note: If this option is selected, O-Calc® Pro displays this warning in red on the analysis report: 

**WARNING** Span / Head Guy Anchor far end positions are locked. 

Understanding the Line Design Menu 

Poles Menu 
The Poles menu, found in the Line Design panel, is essentially the ‘Inventory’ of all the poles in a line 

design. The Poles list is empty unless a line design is being viewed or edited. Once a Line Design is open, 

you can make pole selections and edits to the poles in the Poles list. The available edits are outlined in 

subsequent sections.  
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The Poles menu can also be accessed from the Main Line Design area ribbon, provided that the Mirror 

‘Poles’ Menu on Main option has been checked in the Options > Editing Options menu. This option is 

enabled by default. 

File Menu 
The File submenu in the Poles menu is used to perform several functions when a line design has been 

opened. If a line design has not been opened, these menu options are not accessible.  

New Pole 
The New Pole option is used to generate a new pole while a line design is open. Additionally, you can set 

the coordinates for the new pole being created. Below is an image showing a line design with three 

poles.  

 

To add a new pole, complete these steps: 

1. Open any Line Design. 

2. In the Poles menu, select the File menu, select the New Pole option. 

3. Click the Wood Pole option, select any pole. 

https://osmose1934-my.sharepoint.com/personal/arose_osmose_com/Documents/Documents/O-Calc/O-Calc%20Documents/Mirror#_
https://osmose1934-my.sharepoint.com/personal/arose_osmose_com/Documents/Documents/O-Calc/O-Calc%20Documents/Mirror#_
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4. In the Geolocation window enter the coordinates for the new pole or click on the map to 

automatically load the lat/lon coordinates, the Elevation defaults to 0, click OK. 

a. Or key in the coordinates and elevation of the pole. 

5. The pole is displayed on the Map area, but it is not linked to the other poles in the Line Design 

since the new pole has no attachments. 

6. Attachments can be added and manually linked to the other poles in the Line Design; more 

information on linking spans manually can be found here. 

Add PPLX Files to Line Design 
The Add PPLX Files to Line Design option is used to add previously created PPLX files to a line design 

after the line design has been started. Regardless of the method used to create the line design, 

additional poles can be added using this method. Below is an image of a line design file.  

 

To add an additional pole to this line design, complete these steps: 

1. Open a line design file 

2. Go to the Poles menu, select the File menu, click Add PPLX Files to Line Design. 
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3. When prompted, select an existing .pplx file using the Windows Explorer window; once selected, 

click Open. 

4. Depending on if the coordinates for the selected pole have already been set, you may have to 

adjust the pole’s location. 

a. If the selected pole is far from the rest of the poles in the line, an error message is 

displayed; click OK on this warning to continue. 

 

b. When zooming out, it is possible to view all the poles in the line design, even those that 

are too far away from the rest of the line. 

 

c. If necessary, reposition the pole to a position closer to the line; see Position Selected 

Pole 

5. Once the pole has been positioned correctly, it is possible to link the spans on the added .pplx 

file to spans on another pole in the line design; for further instruction on linking, see the Linking 

Spans Workflow in Appendix A. 
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By using this feature, you can add any .pplx file that has already been created to a line design. This 

eliminates the need to rebuild the pole from scratch when the line design is being created, although you 

do have that option as well.  

Export to PPLX File 
The Export to PPLX File option is used to activate a pole in a line design, and export it as a standalone 

.pplx file, or a standalone pole model that is not part of a line design. To use this feature: 

1. Open a Line Design. 

2. Select the pole that needs to be exported; ensure that it is the active pole, or the pole shown in 

the Inventory window. 

3. In the Poles menu, select the File menu. 

4. Hover the cursor over the Export to PPLX File option, and select: 

a. Current Pole to PPLX 

b. Checked Poles to PPLX  

c. All Poles to PPLX 

5. When Prompted, enter a name for the PPLX file and set the location; then click Save. 

By using this feature, it is possible to generate a line of poles using the Line Design functionality and still 

be able to generate single .pplx models of each pole in a line.  

Edit Menu 
The Edit submenu in the Poles menu, allows you to adjust parameters for the poles in a line design.  

 

Move Pole 
The Move Pole option allows you to set the Geolocation, or the coordinates, of a pole in a line design. 

The Geolocation changes are shown in the Map area, where the poles in a line design are displayed. To 

use this feature: 

1. Open any Line Design. 

2. In the Poles menu, click Edit > Move Pole; a geolocation window opens. 
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3. Manually enter new coordinates or click on a spot in the Map area to update the coordinates. 

4. Click OK; the pole should be shown in its new location. 

Rotate Pole 
The Rotate Pole option is used to change the rotation, or line of lead, for a pole in a line design. This 

adjustment rotates the pole structure, including all elements attached to the pole. To use this feature:  

1. Open a Line Design, in the Poles menu, click Edit > Rotate Pole; a rotation window opens. 

 

2. Enter a value for the rotation and click OK. 

 

Advanced Moves 
The Advanced Moves option allow quick and simple short cuts to reposition multiple poles within a line 

design to ensure they are tangent. The functionality available at any given time depends on a set of 

rules, which are outlined below. Some options require that pole boxes are checked, and/or may require 

you to draw a polygon around the effected poles, etc.  

To use the Advanced Moves, complete these steps: 

1. In Line Design, click Poles > Edit menu (located in the Line Design menu, or in the Auxiliary 

menu to the left of the Map area). 

2. Select Advanced Moves from the menu. 
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Three options are available; Snap Poles to Tangent Line, Snap Poles to Arbitrary Line, and Repostion 

Pole along a Tangent Line. Whenever an option is greyed out the rule set is not in play for the command 

to function. Below is an explaination of what rule sets are necessary for each command. 

 

Snap Poles to Tangent Line – Rule: Two poles must be checked.  

1. When the command is initiated, a red dotted line appears between two checked poles. 

 

2. Click on the map to create a polygon around all the poles you need to be repositioned along the 

tangent line. The end and beginning poles must be included in the polygon. 

 

3. Use the ‘Click Here When Done’ (yellow banner at the top of the Map area) command. Press the 

Esc key if you need to cancel. 

 

 Snap Poles to Arbitrary Line – Rule: Only one pole must be checked.  

1. When the command is initiated, a red dotted tangent line can be seen attached to the checked 

pole. Drag the mouse and click at the desired arbitrary location on the map. Notice the red 

dotted line is now ended.  
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2. Click on the map to create a polygon around all the poles you need to be repositioned along the 

tangent line. The beginning pole must be included in the polygon. 

  
 

3. Use the ‘Click Here When Done’ (yellow banner at the top of the Map area) command. Press the 

Esc key if you need to cancel. 

 

 

Reposition Pole Along Tangent Line – Rule: Three Poles must be checked.  

1. When the command is initiated, a red dotted line appears between the two outer most poles.  

 

 

2. Between the end poles along the red dotted line a yellow sliding dot appears. It can be moved to 

the desired location by changing your cursor position. The pole in the middle is reposition by 

selecting one of three menu options; Use Cursor Position, Set Distance from (pole number) and 

Set Distance from (pole number). 

 
 

3. Select the Use Cursor Position to immediately position the pole to the cursor location. 
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4. Use the Set Distance from… option and enter the Distance (ft) from the selected pole in the Edit 

window, click OK. 

 

 
 

 

Set Elevation 
The Set Elevation option allows you to model the poles in a line design at their actual elevations, taking 

terrain and environmental conditions into account when making assessments. Before using this tool, a 

first Configure Elevation Provider, to identify where the elevation data is to be taken from. Complete 

these steps: 

1. Open any Line Design, in the Poles menu, click Edit > Set Elevation, then select Configure 

Elevation Provider. 

2. In the Elevation Provider window, select a Provider, click OK. If necessary, enter a valid API Key.  
Note: USGS does not require an API Key to use.  
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Once the elevation provider is set, you can modify the elevation for the Current Pole, Checked Poles, or 

All Poles.  

3. In the Poles menu, click on the Edit drop-down menu. 

4. Hover the cursor over Set Elevation, then click on the option from the list for the pole(s) that are 

to be affected. 

 
5. A prompt informs you when the elevation value(s) are completed. Click OK. 

 

Split Spans and Insert Pole 
The Split Spans and Insert Pole option is used to easily insert a new pole into an existing line design 

without having to tediously un-link spans and adjust each attachment. A new pole is added between 

two selected poles and automatically connects any attachments. This feature can be particularly useful 

when span lengths put an excessive amount of load on one or more poles; and inserting a pole could 

reduce the stresses being applied to the surrounding poles. Complete these steps: 

1. Open any Line Design. 

2. In the Poles menu, check the poles on either side of the spans that you’d like to split and insert a 

pole. For instance, to insert a new pole between pole 1 and pole 2, check those boxes. 

 
3. In the Poles menu, select Edit and click Split Spans and Insert Pole.  
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Note: A tool tip appears to remind you that you must check two connected poles. 

 

4. If enabled in Options > Editing Options > Edit Pole Number when Created, a prompt to enter the 

Pole Number appears, enter the pole and click OK. 

 
 

5. A new pole is placed between the checked poles, and is shown in the Poles menu, Map area and 

3D View. 

 

Split Spans and Connect To Existing 
Similar in functionality to the ‘Split Spans and Insert Pole’ command.  Split Spans and Connect To 

Existing allows you to add any pole to the map and automatically add the framing and spans existing in 

the line design. This feature avoids having to manually add the framing, link the spans, plus it lets you 

choose the pole. To use the command, complete these steps: 

1. Start with an existing Line Design. Add a pole of your choice (does not need to be a bare pole) to 

the Map area. The connection criteria limit is 200 feet from the two poles you plan to check, 

which should be the two closest poles on either side of the added pole. 
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2. In Poles, check the boxes of the two poles closest on either side of the added pole. 

 
 

 

3. Go to Poles > Edit select Split Spans and Connect To Existing, click the needed pole as it 

appears. If there are multiple pole candidates available within the connection parameters (less 

than 200 feet away from both checked poles) they appear in the list and can be selected. 

 

Note: A tool tip appears to remind you that you must check two connected poles. 
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4. View the results on the map or in the 3D View area. This feature automatically adds the 

necessary equipment to the pole to create the linked spans. Any pre-existence of equipment on 

the pole remains on the pole. 

 

 

Note: To undo the results, use Ctrl-Z or go to the Edit menu and click on Undo. 

 

Delete Pole and Merge Spans 
The Delete Pole and Merge Spans option is used to easily remove a pole in a line without tediously un-

linking each span associated with a pole, or the surrounding poles. This feature removes the selected 

pole and links the separated spans to new counterparts on the next pole in the line. To use this feature: 

1. Open any Line Design; below is an image of an existing line design. 

 

2. In the Poles menu, check the pole(s) that needs to be removed. 
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3. In the Poles menu, select Edit > Delete Pole and Merge Spans, select the desired option; 

Selected Pole, Checked Poles, Unchecked Poles.  

 

 

4. A confirmation prompt appears; Delete?  click Yes. 

 

5. The pole(s) that were checked are removed from the line design; the remaining spans are now 

linked. 

View Menu 
The View menu allows you to manage how the poles are ordered and displayed in the Map area, and 

within the Poles menu. The options here can be used to manage subsets of poles, sort the poles list, or 

reorder the list of poles.  
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Pole Set 
The Pole Set option allows you to view pole sets that have been created. A pole set is a subset of the 

poles in a Line Design. Selecting this option displays a list of Pole Sets that have been saved. See the next 

section in this document for information on how to save a pole set.  

Save Pole Set 
The Save Pole Set option allows you to flag a set of poles, essentially like a bookmark. This saved pole 

set can be selected to easily select the poles within that set. This would be particularly useful for larger 

line designs, where a subset would need to be selected. To create a pole set, complete these steps: 

1. Open a Line Design. 

2. From the Poles menu, check each of the poles to be included in the pole set. 

 

3. From the Poles menu, click on the View drop-down menu. 

4. Select the Save Pole Set option; a window opens prompting you to enter a name for the pole 

set. 

 

5. Enter a pole Set Name and click OK; now this named set of poles is available under the Pole Set 

option. 

Check All and Uncheck All 
These two options allow you to check all the poles in a line design or uncheck all the poles in a line 

design easily.  

Lasso 
This feature allows you to check and uncheck the boxes for poles in a line design by drawing a polygon 

around any poles in the Line Design Map area. Complete the steps below to use the Lasso: 

1. From Line Design select the Poles menu, select View, click on Lasso. The Pick Polygon Start 

Point message appears above the Map area. 
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2. Click in the Map area at various points to create the desired polygon around the poles you need 

to check or uncheck. 

 

3. The Polygon – Click Here When Done message appears above the Map area, click it when the 

polygon is completed and choose an option; Check Enclosed Poles, Un-Check Enclosed Poles, 

Cancel. 

 

This feature is most helpful when trying to select poles that are not next to each other in your line 

design or when you need to quickly select several poles at once using a visual method. 

Sort/Check Helper 
The Sort/Check Helper allows for quick reordering of poles in a Line Design. For certain features, like the 

Profile View tool, the order of the poles can be extremely important. The order number can be seen in 

the list of poles displayed in the Poles menu, indicated by the numbers in parenthesis.  
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To re-order the poles using the Sort/Check Helper, complete these steps: 

1. Open any Line Design. 

2. From the Poles menu, select View > Sort/Check Helper; a yellow prompt appears above the 

Map area. 

 

 

3. This message indicates that by holding down the ‘Shift’ key, you can check the poles in the Line 

Design Info Poles menu. 

4. Hold down Shift and hover the cursor over the pole that should be first in the new pole order; 

notice that the pole’s order number has changed, and it is displayed in green. 
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5. Continue to hold down Shift and move the cursor over the next pole in the new order; continue 

to do so until all the poles have been assigned a new order number and the boxes are checked. 

Note: When the boxes are checked a gold ring appears around the pole dot icon on the map. 

 

6. When finished, click in the yellow prompt above the Map area Hover to Select, Hold ‘Shift’ to 

check, Click here when done.  

7. When all the poles in the line design are re-ordered (by hovering over the pole icons on the 

map) the Sort/Check Helper closes automatically. 

Refresh 
The Refresh option forces all panels and windows of the application to redraw. This can be helpful when 

the MCU Flags (pole dot icons) within the Poles menu list appear as grey boxes instead of color dots 

(meaning the calculation has not completed) a Refresh operation causes the redraw and completion of 

any outstanding pole calculations. 

Clear MCU Flags 
The Clear MCU Flags option is used to remove any MCU Flags that are displayed in the Poles menu. 

Below is an image of a Line Design, with the MCU Flags displayed.  

 

These MCU Flags are generated when a pole’s Maximum Capacity Utilization is calculated, either 

manually or by using the options under the Calculate menu in the Main Line Design Area. By clearing the 
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MCU Flags, you removes the Pass/Fail indicator that was generated the last time the pole was solved. 

This option can be found under the View drop-down menu, under the Poles menu.  

Reset 
The Reset option restores the original pole order, if any manipulation has been made using the 

Sort/Check Helper or the Auto-Order option. This option can be found under the View drop-down 

menu, under the Poles menu.  

Auto-Order 
The Auto-Order option organizes the poles list in an order, going from one end of a line design to the 

other. This option can be found under the View menu, in the Poles menu. 

Distances and Bearings 
By clicking on the Distances and Bearings option under the View drop-down menu, you can see a list of 

the distances and directions, or bearings, from one pole to the next pole nearest to it. Below is an 

example of this list.  

 

GIS Files Menu 
The GIS Files menu is used to preview and add user defined data to line designs. Initially GIS Data can be 

previewed before a line design has been created. Once a line design has been created, GIS data in the 

form of polylines and polygons can be added and viewed in the Line Design Map area.  

File Menu 

The File menu allows you to preview or add several types of GIS files. File type and how to add them are 

listed below. 

Preview Shapefile 
Before a line design has been started, Shapefile’s can be previewed. Once a line design has been 

created, shapefiles can then be added to the line design. This feature is useful to determine which 

shapefiles are ideal to be added to a line design. To preview a shapefile, complete these steps: 

1. Click on the GIS Files menu. 

2. Select the File option and click Preview Shapefile. 

3. A session of windows explorer opens; navigate to the desired shapefile, select it, and click Open. 

4. The shapefile is added to the GIS Files list with a description of the type and an assigned 

number; in the example below, the type of shapefile is a polygon. 
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5. If the shapefile is outside the current Map area, go to the View menu in the GIS Files menu and 

select Zoom to Bounds. 

Note: Multiple GIS Files can be added at the same time; when selecting a file in the windows explorer 

window, hold down the Ctrl key to select multiple files, then click Open.  

Preview KML file 
Before a line design has been started, KML files can be previewed. Once a line design has been created, 

KML Files can then be added to the line design. This feature is useful to determine which KML Files are 

ideal to be added to a line design. To preview a KML File, complete these steps: 

1. Click on the GIS Files menu. 

2. Select the File drop-down list and click Preview KML File. 

3. A session of windows explorer opens; navigate to the desired KML file, select it, and click Open. 

4. The KML File is added to the GIS Files list with a description of the type and an assigned number; 

in the example below, the type of KML File is a polygon. 

 

5. If the KML File is outside of the current Map area, go to the View menu in the GIS Files menu, 

and select Zoom to Bounds. 

Preview CSV Lat Lon file 
Before a line design has been started, a CSV Lat Lon file can be previewed. Once a line design has been 

created, a CSV Lat Lon file can then be added to the line design. This feature is useful to determine 

which CSV Lat Lon files are ideal to be added to a line design. To preview a CSV Lat Lon file, complete 

these steps: 

1. Click on the GIS Files menu. 

2. Select the File option and click Preview CSV Lat Lon File. 

3. A session of windows explorer opens; navigate to the desired CSV Lat Lon file, select it, and click 

Open. 

4. The CSV Lat Lon file is added to the GIS Files list with a description of the type and an assigned 

number. 
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5. If the CSV Lat Lon file is outside the current Map area, go to the View menu in the GIS Files 

menu and select Zoom to Bounds. 

Preview GeoJSON file 
Before a line design has been started, GeoJSON files can be previewed. Once a line design has been 

created, GeoJSON files can then be added to the line design. This feature is useful to determine which 

GeoJSON files are ideal to be added to a line design. To preview a GeoJSON, complete these steps: 

1. Click on the GIS Files menu. 

2. Select the File drop-down list and click Preview GeoJSON. 

3. A session of windows explorer opens; navigate to the desired GeoJSON, select it, and click Open. 

4. The GeoJSON file is added to the GIS Files list with a description of the type and an assigned 

number. 

5. If the GeoJSON file is outside of the current Map area, go to the View menu in the GIS Files 

menu, and select Zoom to Bounds. 

 

Preview GPS NMEA file 
Before a line design has been started, a GPS NMEA file can be previewed. Once a line design has been 

created, GPS NMEA files can then be added to the line design. This feature is useful to determine which 

GPS NMEA files are ideal to be added to a line design. To preview a GPS NMEA file, complete these 

steps: 

1. Click on the GIS Files menu. 

2. Select the File drop-down list and click Preview GPS NMEA File. 

3. A session of windows explorer opens; navigate to the desired GPS NMEA file, select it, and click 

Open. 

4. The GPS NMEA file is added to the GIS Files list with a description of the type and an assigned 

number. 

5. If the GPS NMEA file is outside the current Map area, go to the View menu in the GIS Files menu 

and select Zoom to Bounds. 

Clear Preview 
Any number of GIS Files can be previewed prior to starting a line design. Once you are finished 

previewing GIS files, they can all be removed simultaneously from the GIS Files list. To do so: 

1. Select the File drop-down menu from the GIS Files menu. 

2. Select Clear Preview. 

Note: Clearing a preview cannot be undone. 

Add Shapefile to Line Design 
Adding shapefiles to a Line Design can only be done after the Line Design has been started. To add this 

type of GIS data to a Line Design, complete these steps: 

1. Create or open a Line Design file. 

2. Click on the GIS Files menu. 

3. Select the File option and click Add Shapefile to Line Design. 
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4. A session of windows explorer opens; navigate to the desired Shapefile, select it, and click Open. 

5. The Shapefile is added to the GIS Files list with a description of the type, and an assigned 

number. 

6. Ensure that the Display GIS files box is checked. 

7. If the Shapefile is outside of the current Map area, go to the View menu in the GIS Files menu, 

and select Zoom to Bounds. 

Add KML File to Line Design 
Adding KML files to a Line Design can only be done after the Line Design has been started. To add this 

type of GIS data to a Line Design, complete these steps: 

1. Create or open a Line Design file. 

2. Click on the GIS Files menu. 

3. Select the File drop-down list and click Add KML file to Line Design. 

4. A session of windows explorer opens; navigate to the desired KML file, select it, and click Open 

5. The KML file is added to the GIS Files list with a description of the type, and an assigned number 

6. Ensure that the Display GIS files box is checked. 

7. If the KML file is outside of the current Map area, go to the View menu in the GIS Files menu, 

and select Zoom to Bounds. 

Add CSV Lat Lon file to Line Design 
Adding CSV Lat Lon files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, complete these steps: 

1. Create or open a Line Design file. 

2. Click on the GIS Files menu. 

3. Select the File drop-down list and click Add CSV Lat Lon file to Line Design. 

4. A session of windows explorer opens; locate the desired CSV Lat Lon file, select it and click 

Open. 

5. The CSV Lat Lon file is added to the GIS Files list with a description of the type, and an assigned 

number. 

6. Ensure that the Display GIS files box is checked. 

7. If the CSV Lat Lon file is outside of the current Map area, go to the View menu in the GIS Files 

menu, and select Zoom to Bounds. 

Add GeoJSON file to Line Design 
Adding GeoJSON files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, complete these steps: 

8. Create or open a Line Design file. 

9. Click on the GIS Files menu. 

10. Select the File drop-down list, and click Add GeoJSON file to Line Design. 

11. A session of windows explorer opens; navigate to the desired GeoJSON file, select it, and click 

Open. 

12. The GeoJSON file is added to the GIS Files list with a description of the type, and an assigned 

number. 

13. Ensure that the Display GIS files box is checked. 
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14. If the GeoJSON file is outside of the current Map area, go to the View menu in the GIS Files 

menu, and select Zoom to Bounds. 

Add GeoImage file to Line Design 
Adding GeoJSON files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, complete these steps: 

1. Create or open a Line Design file. 

2. Click on the GIS Files menu. 

3. Select the File drop-down list and click Add GeoJSON file to Line Design. 

4. A session of windows explorer opens; navigate to the desired GeoJSON file, select it, and click 

Open. 

5. The GeoJSON file is added to the GIS Files list with a description of the type, and an assigned 

number. 

6. Ensure that the Display GIS files box is checked. 

7. If the GeoJSON file is outside of the current Map area, go to the View menu in the GIS Files 

menu and select Zoom to Bounds. 

Add GPS NMEA file to Line Design 
Adding GeoJSON files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, complete these steps: 

1. Create or open a Line Design file. 

2. Click on the GIS Files menu. 

3. Select the File drop-down list, and click Add GeoJSON file to Line Design 

4. A session of windows explorer opens; navigate to the desired GeoJSON file, select it, and click 

Open. 

5. The GeoJSON file is added to the GIS Files list with a description of the type, and an assigned 

number. 

6. Ensure that the Display GIS files box is checked. 

7. If the GeoJSON file is outside of the current Map area, go to the View menu in the GIS Files 

menu and select Zoom to Bounds. 

Remove Selected GIS file 
Any number of GIS Files can be added to a line design. If you have added a GIS File that needs to be 

removed, each GIS File must be removed individually. Complete these steps: 

1. Highlight the GIS File. 

2. Select the File menu. 

3. Select Remove Selected GIS File. 

4. On the prompt, select Yes to delete the file. 

5. Repeat steps 1-4 until all unnecessary GIS Files have been removed. 

Note: The ‘Remove a GIS File’ command cannot be undone. 

View Menu 
Listed below are the features included under the View menu. 
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Zoom to Bounds 
This option allows you to select a previewed or loaded GIS File and zoom to the selected file’s extent.  

Embed GIS in Line Design 
This checkbox allows the GIS files to be saved with the line design, so they are available when the .pplld 

file is shared or opened on another computer. 

Tools Menu 
The following tools are used to create files in O-Calc® Pro such as GeoImages and other GIS file types. 

Create GeoImage 
This tool is used to create a geoimage file manually in O-Calc® Pro by selecting the bounding area of the 

geoimage you need to create then adding an image to that area from a file on your computer. 

 

Manually Create Poly 
Like creating a Geoimage file in O-Calc® Pro, this option is manually designating an area in O-Calc® Pro 

where you can save as a .geojson file. 

Display GIS Files 
This checkbox is used to toggle on or off the display of all GIS Files being previewed or drawn in a line 

design.  

GIS File Attributes 
GIS files that are previewed or added to a line design are drawn using a set of default attributes. These 

attributes can be altered, to adjust how a GIS file is rendered in the Map area of Line Design. Below is an 

example of the attributes for a polygon GIS file.  
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The left column indicates the attribute that can be adjusted, while the right column indicates the values 

associated with each attribute.  

Displayed The Displayed attribute indicates whether the selected GIS File is going to be 
rendered in the Map area.  
 
Rather than remove a GIS File, you can adjust this attribute to prevent a GIS 
File from being drawn.  

Line Color The Line Color attribute is the defined color used for the perimeter of a 
polygon or for polyline features. 

Fill Color The Fill Color attribute indicates the color used for the fill of polygon features. 

Line Width The Line Width attribute indicates the thickness of the line used in rendering 
the selected GIS File.  

Easement The Easement attribute indicates whether the selected GIS File is going to be 
used as an easement file. 

 

Map Area 

Display OMV Tiles 
In O-Calc® Pro Line Design, Open Map Vector Tiles (packets of geographic data) can be displayed.  This is 

an emerging method for delivering styled web maps, combining certain benefits of pre-rendered raster 

map tiles with vector map data. 

OMVT Folder Path 
Displaying the OVM Tiles shows a map with simplified roads and labels. Complete these steps: 

1. Click the Map menu. 

2. Click into the check box labeled Display OMV Tiles. 

3. If the map path is not displayed in the OMVT folder path, proceed to step 4. 

4. Click the ellipse button to navigate to the file location, add file as prompted. 
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Display Map Tiles 
Additionally, the Map area in Line Design can read and display map tiles from many sources such as 

OpenStreetMap or Google Maps. You can also display map tiles created from formatted LiDAR. 
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Tile Source 
For some maps, a key may be required that must be obtained/purchased from the host’s website. You 

can select the provider using the dropdown menu under tile source. 

Cache Tiles to Disk 
You can cache map tiles to a location on their computer by selecting this option and choosing a file 

location. 

Display GeoImages 
The display GeoImages checkbox allows the display of GeoImage files from their computer on the Line 

Design Map. 

 

GeoImage Folder Path 
You must enter a valid folder path containing O-Calc consumable GeoImage files in this field to display 

GeoImages on the Line Design Map. 

Clearance 
In the Line Design auxiliary area (on the left side of the Map area) locate the Clearance menu. It can be 

used to assess clearance violations between the attachments on any pole in a line design, and 

environmental objects like the ground line, surfaces, structures, and foliage. The clearance analysis tool 

in Line Design allows an analysis to be performed in a broader way, rather than strictly in profile.  
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Violations 
The violations tracks any clearance rule violations that have occurred across the length of a line design. 

Once the rules and environmental objects have been created, the violations lists for the you where the 

violations are, and what they are.  

Violations 
The Violations button lists any violations to the clearance rules that have been created. You can filter 

the results based on All Poles, Checked Poles, or the Current Pole. When no violations are found, the list 

remains blank. When Violations are found, a list of each of the poles with a violation is generated. 

Within this list are the attachments on each pole that are associated with a rule violation.  

Un-Tagged Spans 
The Un-Tagged Spans button lists any spans within the line design that have not been marked with a 

clearance group. When clearance rules are generated, you must also assign a clearance group tag to 

each span that is considered when the analysis is run – any spans that are not tagged with a clearance 

group are not to be considered in the analysis. To easily identify if a span has not been tagged, complete 

these steps: 

1. Open any Line Design. 
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2. Set the Clearance Rules; this includes the rules, the clearance groups, and the clearance objects 

like structures, surfaces, and foliage.  

3. Run the clearance analysis. 

4. Under the Clearance menu, go to the Violations section. 

5. Click on the Un-Tagged Spans option; a list of poles is generated. 

6. From this list of poles, each span that does not have a clearance group tag is shown. 

 

The Un-Tagged Spans list can be used to easily identify spans that may have been overlooked when 

clearance group tags were placed.  

Obstructions 
In the Line Design auxiliary area (on the left side of the Map area) locate the Obstructions menu. It 

allows you to set up the parameters for the clearance analysis that is being performed. Here, the rules 

that are to be used can be created. Additionally, the environmental objects that are to be considered in 

the analysis can be created in Obstructions. 

Add Menu Options 
The Add menu is used to add surfaces, structures, or foliage to the landscape around a line design, to be 

considered when a clearance analysis is being run. Adding clearance objects to the landscape of a line 

design allows them to be considered when the analysis is run.  

Clearance objects can be created by importing a csv file with a list of locations and measurements. To 

import the csv file you must navigate to add menu options > … > Import from file after creating the 

appropriate clearance rules. 
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Clearance objects can also be created manually. The first type of object that can be added is a structure. 

Any type of structure can be created in the Clearance Rules Editor. Then, all created structures are listed 

under this Add Menu option. For instance, if I were to add a shed to my line design, I could consider it 

when the analysis is run.  

                

Once the structure object is selected, it can be placed in the Map area. The cursor shows the object 

being placed, along with the latitude and longitude for where it is going to be placed.  
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Choose the location for the shed and left click on the map. A prompt requires the dimensions for the 

object.  

Continue clicking on the map to place more of the object and then finish adding by clicking the yellow 

Add Shed (Click here when done) button. The object is shown in the Map area, and 3D View.  
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Additional prompts allow you to set the elevations for objects based on any elevation provider that has 

been set up.  

A similar process can be used for adding foliage; the type of foliage is selected, and a left-click in the 

Map area is used to place it.  

 

Adding a surface is slightly different; the surface type is selected, and a left-click in the Map area is used 

to place it. However, when it is drawn, it typically would not have a height value, just a width.  

 

Rules > Violations Report 
By selecting the Violations Report option, you see a report that lists all the clearance violations that 

have been found in a line design.  
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Rules > Show Clearance Rules 
The Show Clearance Rules option is used to view a report that lists all the rules that have been created, 

or are currently active in the open session of O-Calc® Pro. This file lists the rule name, clearance 

requirement, source, and target information for each rule.  
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Rules > Edit Clearance Rules 
The Edit Clearance Rules option opens the Clearance Rules Editor; this is the first step in running a 

clearance analysis. The rules, clearance group tags, and clearance objects can all be created in this 

window.  

Clearance Rules indicate the distances that must be between various objects. A typical clearance rule 

required that the required amount of clearance (in feet) be entered first. Then the rule can be named 

and given a description. In the image below, a clearance rule has been generated called Comm to 

Ground which indicates that there must be 18 feet of clearance between communication spans and the 

ground.  

 

Next, the Sources and Targets that the rule is to be applied to need to be set. This can be done by 

clicking the ‘…’ button next to the (Collection) area.  

 

This opens another window, where the sources and targets can be set. The sources are the upper limit 

of the rule; these are the objects that, in this case, must be 18 feet above the ground. The targets are 

the lower limits; these are the objects that must be 18 feet below the sources. The lists for sources and 
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targets are populated based on the Clearance Groups and Clearance Objects that have been created. For 

more information on creating clearance groups and objects, see the associated article.  

 

Once the sources and targets are selected, click OK. The last step for creating a rule is to assign a 

violation name, severity, and if desired a location. This process can be repeated to create any number of 

rules. These rules must be carefully created for an accurate clearance analysis report.  

Rules > Import Clearance Rules 
The Import Clearance Rules option allows you to take a generated file of clearance rules from a source, 

and import them into their own session of O-Calc® Pro.  

Rules > Export Clearance Rules 
The Export Clearance Rules option allows you to take the clearance rules they have created and share 

them with others by exporting them as a standalone file.  

Edit > Select by Position 
The Select by Position option opens a geolocation window where coordinates can be entered. Objects 

at that location can be selected, or the nearest object to that point can be selected.  

Edit > Dimensions 
The Dimensions in the edit menu allows you to change the dimensions of the clearance object after it 

has already been set. For instance, the width and height of any clearance object can be adjusted. Simply 

select the item from the list of clearance objects, and under the Edit menu, select this option.  

http://o-calcpro.com/wiki/2017/05/23/clearance-analysis-process-and-report/
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Edit > Set Elevation 
Under the Edit menu in the Obstruction menu, which allows you to set the elevation for one or more 

clearance objects. When a clearance object is added, a prompt to set the elevation is given. You may 

choose not to or to edit the elevation later. There are several choices available for setting the elevation:  

 

You can set the elevation for either a selected obstruction, or all obstructions at once. If an elevation 

provider has not yet bene configured, there is an option to do so from this menu item. Lastly, you can 

enable the Auto Apply Elevation option to automatically set the appropriate elevation for an object if an 

elevation provider has already been configured.  

Edit > Set Position 
The Set Position option is used to adjust the position of a clearance object after it has already been 

placed. It is used to open a geolocation window, where a user can manually type in the coordinates for a 

new position or click in the Map area to set the location.  

Edit > Delete 
The Delete option is used to remove a clearance object from the list, and therefore the clearance 

analysis. 

Easement 
In the Line Design auxiliary area (on the left side of the Map area) locate the Easement menu. It allows 

you to define a polygon that can be labeled as an easement. Once an easement polygon has been 

defined, O-Calc® Pro Line Design can list pole, anchors, etc. that have coordinates that are outside of the 

easement polygon. 

To add an easement polygon to your Line Design, use the GIs Files menu to load a Shapefile, KML file, or 

other supported file to the Line Design. Once loaded, select the file, and change the Easement attribute 

from False to True. If no file is loaded this prompt appears: 
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Violations 
Within the Easement menu, when one or more easement polygons have been defined and the 

Violations button is selected, all objects (poles, anchors, push braces, or stub poles) that are not located 

in at least one easement polygon are listed. 

Understanding the 3D View Controls 
Many of the features outlined in this document pertain specifically to the Line Design functionality. 

However, there are enhancements related to Line Design that can be found in other parts of the 

program’s interface, including the 3D View panel. The 3D view controls are periodically updated or 

enhanced to work intuitively to help you fully realize the advantages of working in Line Design.  
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3D View Controls 
In the upper left corner of the 3D View window notice 3 buttons: (R), (B), and grey space between them 

is the options menu. 

 

The 3D view options menu provides save, copy, or print an image of the 3D view options. 

 

Camera Look Point 
Previous 3D View Controls included in our older versions of O-Calc® Pro, restricted the camera to a 

cylindrical orbit 20,000 inches away from the centerline of the pole. Traditionally, the camera could 

move to a point on that cylinder only, and zooming was accomplished by changing the camera’s field of 

view. Panning was only possible along a vertical axis. But depending on field of vision (FOV), this made 

the ability to visualize other locations, i.e. adjacent poles, limited and hard to understand. 

In the new camera system, the camera look point is now adjustable, allowing the you to be able to 

visualize their workspace more effectively.  

The “ball” icon represents the camera “look point”. The camera always looks at this point and therefore 

this ball always remain in the middle of the 3D View. 

 

You can select a point on the screen where you need to place the camera look point by utilizing the Alt 

Key Controls enumerated below. 

1. Hold Alt key and left click mouse on any object to move to that selected point. 
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2. When a span is selected these menus appear as soon as the Alt button is released. 

 

   



Osmose O-Calc® Pro 8.0  Line Design User Guide 

136   ©2025 Osmose Utilites Services, Inc.  
 

Changing the Control Scheme 
There are two new control sets, Default and Alternate, to choose from. To change the active control 

scheme, complete these steps: 

From the Options menu, select Camera, click the Use Alternate Control Scheme option.    

 

Default Control Scheme 
Press Left mouse button and move mouse: 

• Left-Right mouse movement orbits the camera around the look point (orbit) 

• Up-Down mouse movement moves the camera AND look point up or down equally 

• While holding "Alt" key down: 

o Left-Right mouse movement does nothing 

o Up-Down mouse movement works normally 

• While holding "Left Shift" key down: 

o Left-Right mouse movement works normally 

o Up-Down mouse movement moves ONLY the camera (tilt)  

• You may hold "Shift" and "Alt" together 

Press Right mouse button and move mouse: 

• Left-Right mouse movement orbits the look point around the camera (pan) 

• Up-Down mouse movement moves the camera AND look point up or down equally 

• While holding "Alt" key down: 

o Left-Right mouse movement does nothing 

o Up-Down mouse movement works normally 

• While holding "Left Shift" key down: 

o Left-Right mouse movement works normally 

o Up-Down mouse movement moves ONLY the look point (reverse tilt)  

• You may hold "Shift" and "Alt" together 

Mouse Wheel 

• Scrolling Forward on the mouse wheel moves camera towards look point (zoom in) 

• Scrolling Backward on the mouse wheel moves camera away from look point (zoom out) 

• If the option Invert Mouse Wheel is selected, then the previous settings are reversed. To check 

this setting go to Options > Misc Options > User Interface Conventions … > Invert Mouse Wheel 
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• While holding "Alt" key down: 

o Scrolling Forwards on the mouse wheel moves camera towards look point (dolly) 

o Scrolling Backwards on the mouse wheel moves camera towards look point (reverse 

dolly) 

o If the option Invert Mouse Wheel is selected, then the previous settings are reversed. 

Alternate Control Scheme 
Although the alternate control set is based on current 3D modeling standards, it was a significant 

deviation from traditional O-Calc controls, therefore it was decided against being the default control set. 

 

Left Mouse Click and Drag: 

• Left and Right to Orbit Camera around Look Point 

• Up and Down to Raise and Lower Camera and Look Point 

Left Mouse Click and Drag with the Alt Key Held Down: 

• Left and Right to Orbit Camera around Look Point 

• Up and Down to Raise and Lower Camera only but NOT Look Point 

Left Mouse Click and Drag with the Shift Key Held Down: 

• Left and Right to Orbit Look Point around Camera 

• Up and Down to Raise and Lower Camera only but NOT Look Point 

Left Mouse Click and Drag with Both the Shift and Alt Key Held Down together: 

• Left and Right to Orbit Camera around Look Point 

• Up and Down to Raise and Lower Look Point but NOT Camera 

Right Mouse Click and Drag: 

• Left and Right to Move Camera and Look Point Perpendicular to Look Direction 

• Up and Down to Move Camera and Look Point Parallel to Look Direction 

Right Mouse Click and Drag with Shift Held Down 

• Left and Right Movement has no action 

• Up and Down to Move Camera Towards or Away from Look Point (Zoom) 

Mouse Wheel 

• Moves Camera Towards or Away from Look Point (Zoom) 

• Hold the Shift Key to Raise and Lower the Camera and the Look Point 

• Hold the Alt Key to Raise and Lower the Look point but Not the Camera 

• Hold Both the Shift and Alt Keys to Raise and Lower the Camera but Not the Look Point 
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Wind Direction Arrow 
When a pole or Line Design is calculated in O-Calc® Pro the Wind Direction Arrow is displayed in the 3D 

View.  O-Calc® Pro makes distinctions between the Groundline Capacity Utilization(GCU) and the 

Maximum Capacity Utilization (MCU). The text underneath the gold arrow icon displays a ‘W’ for wind, 

plus the wind angle in degrees, and wind pressure in pounds per square foot (psf). 

 

 

Pole Filter Options 
In Line design you can see many poles at a time in the 3D view. However, at times, you may need to 

view only focus on a smaller number of poles rather than the entire line. 

On the lower right corner of the 3D View you can access a dropdown with pole filter options to only 

display the checked poles, unchecked poles, or the selected pole only. 

 

By default, the selection in this list is set to ‘All Poles’, which means that all Poles present in the line 

design are shown in the 3D View. 
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Span Visualization Options 
Used to adjust the visual thickness of the spans in the 3D View by adjusting the value in a dropdown box 

in the lower right corner of the 3D View. Options include 1X x, 2X, 4X, 8X, and 16X the actual thickness of 

the span. 

 

Filtering Spans by Linked Status 
The 3D View window displays a rendering of the currently open pole, or the active pole in an open line 

design. When a line design is open, each of the poles are displayed in the 3D View above is an example 

of a line design visible in the 3D View.  

A new drop-down menu in the bottom-right corner of the 3D View window allows you to filter what is 

displayed in the 3D View by looking at certain characteristics of spans. Specifically, the drop-down menu 

allows you to view spans based on if they are linked to other spans in a line design.  

 

By default, the selection in this list is set to ‘All Spans’, which means that all spans present in the line 

design, regardless of linked status, are shown in the 3D View. This selection can be changed to any of 

these options: 

Linked Select to display the ‘Linked’ spans, which are linked to another span. 

Un-Linked Select to display the ‘Un-Linked’ spans, those that are not linked to any other span. 

Sel Pole Select to display only the ‘Selected Pole’ spans and no other spans or poles in the Line 
Design. The ‘selected pole’ is always the pole at the center of the groundline compass 
in the 3D View, and it is displayed in the Inventory. 

 

Scaling Rendered Poles 
The 3D View renders a single pole or the active pole in an open line design. When a line design is open, 

each of the poles in the line is displayed in the 3D View.  

A new numeric field in the bottom-right corner of the 3D View allows you to change the scaling of the 

line design shown in the 3D View.  
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By default, the value is set to 100, which corresponds to the standard scale used when rendering in the 

3D View. When using the up or down arrows, the scaling can be changed incrementally. Doing this 

renders the poles closer together, allowing you to see more poles in the line at the same time. In the 

image below, the scaling has been set to 25, so poles appear closer together without adjusting the span 

length between poles.  

 

Distance Filtering 
Used to filter poles by their distance from the selected pole. A numeric field is placed in the bottom right 

corner of the 3D View which allows you to adjust the range, in 50ft increments, in which poles are 

rendered.  

For example, if an adjacent pole in a Line Design is 60ft away from the selected pole, it cannot be 

rendered in the 3D view if the distance filtering range is set to 50ft. It is rendered if the range is set to 

100ft.  
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Understanding Line Design Reports and Charts 
The automatic calculation functionality for a single pole is disabled in Line Design Mode. Instead, when a 

line design is completed, you have the option to run a calculation on a single pole or the entire line of 

poles. The Line Analysis report analyzes an entire line of poles based on the wind parameters set by the 

user. To generate a report, read the Calculate Options section of this document. 
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Line Analysis with Fixed Wind Report 

 

The name of the Line Design file is provided in the upper left-hand corner of the report. The date the 

report was generated is shown under the O-Calc® Pro Line Analysis title. The wind angle of 0° shown 

above the pole data is the value inputted for the Fixed Wind Angle parameter when calculating. 

The first section of the report indicates the worst wind angle for each pole in the line with regards to 

MCU (Maximum Capacity Utilization) and GCU (Groundline Capacity Utilization). In the example above, 

the greatest MCU for pole 1 occurs at a wind angle of 0° and is 29.6%.  

In the next section of the report each pole in the line is addressed indicating each pole’s GCU 

(Groundline Capacity Utilization), VCU (Vertical Capacity Utilization), TCU (Transverse Capacity 

Utilization), and MCU (Maximum Capacity Utilization). The values are provided as percentages and are 

color coded based on pass/ close to failure/ fail basis. Values in red indicate failure or exceed 100%. 

The O-Calc® Pro Line Analysis Report also provides information on any guying on the poles in a line, if 

present. Each guy wire present in the line design is shown, with an indication of which pole it is attached 

to. Additionally, the tension and capacity of each guy wire is shown. These values may change based on 

the wind angle being analyzed, so these guy wires are included under each wind angle section. 
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Line Analysis with Sweeping Wind Report 
The image below shows the values that would be found with a wind angle of 0° and 10°. When 

calculating using the sweep wind option the report displays the values according to the min, max, and 

interval the user inputs. 

Other than reporting multiple wind angles, the sweeping wind report is organized the same way as the 

fixed wind report. 

Partial Line Analysis Report 
Instead of calculating for every pole in a line design, you can choose the poles in the line design you 

need to analyze and run either a fixed or sweeping wind calculation. 

The report would look the same as the reports above but would only include the designated poles. 

Violations Report 
The Violations Report was discussed in a previous section of this document. See this section 

Profile Chart 
The Profile Chart was discussed in a previous section of this document See this section 

Appendix A – Common Workflows 
This section of the Line Design User Guide outlines some common scenarios that would be encountered 

while working with the new features of Line Design. While these workflows are centered on specific 

examples, the steps outlined could be applied to a similar situation encountered by a user. 
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Linking Spans 
Linking spans refers to the process of taking two poles in a line design and connecting them through a 

connection of the spans on one pole, to corresponding spans on another pole. There are several rules 

that must be followed when spans are going to be linked; those rules are listed here: 

1. Spans that are going to be linked must be the same span type; for instance, a primary span can 

only be linked to another primary span, and a communication messenger only to another 

communication messenger 

2. Spans can only be linked to one other span; one span cannot be linked to multiple spans on 

another pole in the line design 

3. When linking communication bundles, the number and type of communication conduits that are 

included in the bundle are determined by the span that acts as the origin of the link. For 

instance, a communication bundle with two conduits being linked to a communication bundle 

with three conduits – The bundle on the active pole when the linking occurs is the format that 

would be used 

4. Unlinking spans must be done on both segments involved in the initial link 

Linking Single Spans 
The most basic aspect of linking spans is linking one span to another. In the image below, two poles in a 

line design are not linked.  

 

This image shows the pole on the left having three primary spans, a secondary, and a communication 

bundle. The pole on the right has three primary spans, a secondary, and a communication span. At this 

stage, both poles are in the line design, but they are not linked. To link the primary spans from one pole 

to those on the other pole, complete these steps: 
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1. Determine which is the selected (at the center of the groundline compass) pole in the 3D View, 

it’s also displayed in the Inventory. In this example, the pole on the left is the selected pole.  

2. Click on one of the primary wires on the selected pole.  

 

3. Left-click and hold on the primary wire, drag-and-drop it to a span on the other pole that it 

should be linked to. This can be done from the Inventory window, or from the 3D View.  

a. If performing from the Inventory find the selected span, click and hold onto the span. 

 
 

b. Drag-and-drop, placing the cursor overtop of the span to be linked to, in the 3D View; 

the symbol of the cursor shows a small curved arrow, used to indicate that a link is 

possible. 
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c. Let go of the mouse click, and the spans automatically link. 

 

d. If performing from the 3D View, find the selected span, and left click and hold onto that 

span. 

e. Drag-and-drop, placing the cursor overtop of the span to be linked to in the 3D View; 

the symbol of the cursor shows a small curved arrow, used to indicate that a link is 

possible. 

f. Let go of the mouse click, and the spans automatically become linked. 
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Now that the primary wires are linked, any changes that occur on one of the spans can be applied to all 

of the spans that are linked to it; this concept is called Connectivity. 

Linking Span Guys 
Span guys can also be linked similarly to linking single spans, however there is an extra rule. As span 

guys are modeled like other types of guys in O-Calc® Pro, they are attached to the pole with an anchor 

and guy brace. For span guys to successfully link, there must only be one guy per anchor.  

The Split Spans Head Anchors tool described in this document allows you to quickly prepare span guys 

for Linking. 

When the span guys are prepared for linking, you can easily link the span guys following the procedure 

for linking single spans in the previous section. 

Unlinking Spans 
Another common scenario may be that two spans were linked together that should not have been. 

These spans would have to be unlinked before the corrections could be made. In the image below, two 

of the spans that were linked are incorrect; they must be unlinked before the corrections can be made.  

 

To unlink the spans in this image that are crossing, complete these steps: 

1. Open a line design with linked spans that must be unlinked. 

2. Select one of the poles in the line with spans that must be unlinked; using the same example, 

the pole on the right is selected as the active pole. 

3. Select the span to be unlinked. 

4. Right-click on the span, either in the 3D View or the Inventory, and in the menu select Un-Link 

Span. 

http://o-calcpro.com/wiki/2019/01/02/connectivity-in-o-calc-pro-line-design/
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a. This operation un-links the two spans involved in the original link, but that does not 

complete the process; both segments of the link must be Un-linked.  

5. Switch to the other pole with the span to be unlinked; switch to this pole by either clicking on it 

in the 3D view, or selecting it from the Poles list in Line Design. 

6. Select the span that was part of the link; it needs to be Un-Linked as well; right-click on it and 

select Un-Link Span from the menu. 

a. Now both segments are free to be linked to other spans. 

Again, Un-Linking spans is vital if those spans need to be Linked to another span. Both sides must be Un-

Linked before new Links can be formed.  

Linking Communication Bundles 
When communication bundles need to be linked together, there are a few more factors to keep in mind. 

Communication bundles on poles may have different messenger wire sizes, and different conduits 

included in each bundle.  

In the image below, the pole on the left has a communication bundle with a with a 5/16” EHS 

Messenger wire and a Telco conduit. 
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When communication bundles are linked together, the selected pole determines the final contents of 

the linked communication bundle. So, if the pole on the left is selected when the Linking is performed, 

the linked communication bundle is now going to have a 5/16” messenger. If the pole on the right is 

selected when the linking is performed, the linked communication bundle may have a different sized 

messenger. To link communication bundles, complete these steps: 

1. Open a line design with communication spans to be linked. 

2. Select one of the poles in the line with spans that need to be linked; using the same example, 

the pole on the right is active and selected. 

3. Select the messenger wire of the bundle to be linked. 

4. Left click and hold on the messenger wire, either in the 3D View or in the Inventory. 

5. Drag-and-Drop the selected messenger, placing the cursor overtop of the messenger wire for 

the bundle it’s to be linked to; the curved arrow symbol appears to indicate that a Link can 

occur. 

6. Release the mouse click, and the bundles become linked. 
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7. Look at the Inventory; it shows that the active pole has a communication bundle with 5/16” EHS 

Messenger wire and a Telco conduit 

8. Switch to the pole on the right; the non-active pole when the Linking occurred 

 

9. Look at the Inventory; it shows that the active pole has a communication bundle with the 5/16th 

messenger wire; it has taken on the properties of the communication bundle on the active pole 

when the Linking was performed 

Linking to Insulators 
In some cases, such as when using the Add PPLX Files to Line Design function, it may be necessary to link 

the spans of a new pole to an existing line. However, there may not be spans to link to. In the image 
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below, the pole on the left needs to be linked to the rest of the line design, but there are no available 

spans on the pole on the right.  

 

In these situations, it is possible to link spans to an insulator rather than another span. Compete these 

steps: 

1. Open a line design with spans to be linked. 

2. Select one of the poles in the line with spans that need to be linked; using the same example, 

the pole on the left is active and selected. 

3. Select the messenger wire of the bundle to be linked. 

4. Left click and hold on the messenger wire, either in the 3D View or in the Inventory. 

5. Drag-and-drop the selected messenger wire, placing the cursor over the insulator on the 

adjacent pole, where the link should occur. 

6. Release the mouse click to link the selected span to the insulator. 

7. Continue this process for each span that needs to be linked to an insulator on the adjacent pole. 
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When linking to an insulator, the span that is being linked is effectively created on the neighboring pole. 

So, when Un-linking these spans, the Un-Link operation is to be done to the original spans, and the span 

that was generated on the neighboring pole. Think of it as unlinking both ends on the conductor or 

cable. Un-linking does not remove the span that was created on the adjacent pole.  

For a reminder on the Un-linking process, see this section.  

Making Edits in the Line Design Map area 
In select circumstances you may need to edit poles in a Line Design directly from the overhead Line 

Design Map area. To satisfy this need O-Calc® Pro allows you to drag and drop elements from any 

Catalog, Inventory, or from the selected pole in the Line Design Map and attach elements to another 

pole in the Line Design.  

This functionality works like the drag and drop method works in the 3D view, with these exceptions: 

1. The Line Design Map setting for the Map Drag Min Zoom level is 18. This is because it is difficult 

to accurately see where you are dragging elements if you are too far away. You must zoom in 

closer. 

 

2. Since the drag and drop feature is always on, you might accidentally invoke this feature in the 

Line Design Map area when moving the cursor around. Therefore, a Perform Operation 

message shown below appears, click it to confirm your selection intent. 
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Spacer Cable Construction to Standard Framing 
It may be necessary to model poles whose construction type transitions from standard construction to 

spacer cable construction. Spacer cable construction is used primarily in areas where clearance space is 

limited.  

To model this scenario and maintain connectivity in Line design, O-Calc® Pro utilizes a series of terminal 

objects and jumpers. Start with a line design containing a series of poles with spacer cable construction. 

Be sure the pole spans are linked.  

1. Switch the framing on half of the pole to standard framing with dead-end insulators. 
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2. Add a terminal object to each conductor of the spacer cable. To do this, you have several 

options. In the 3D View you can click on the desired span and in the resulting menu choose App 

Other > Terminal. You can perform similar steps from the Inventory panel as well. And you can 

drag and drop a terminal object from the catalog. 

 

3. Next you can choose to trim the spacer cables away from the pole for visual clarity when 

jumpering to the dead-end insulator. First, click on the terminal object in the Inventory to view 

its details in the Data Entry Panel. In the Data Entry Panel, edit the Rel Offset (in) attribute. 

Then, on the span object go to the Trim to Terminal attribute and change the value from no to 

yes. 
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Now, the spans can be jumpered together. The best way to do this is to left click on the terminal and 

drag and drop onto the dead-end insulator. 

 

Appendix B – Miscellaneous Topics 

Create a Line Design from CVS File 
When using a pole data file to generate a line of poles, the pole data file must be generated in a very 

specific way. To see the required format, complete these steps: 

1. Under the File option, select New Line Design. 

2. From the options, select the Import list and the Show Expected Format. 
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3. Review the pole data format requirements, as shown above. 

4. The Generate sample button is used to obtain an example you can use as a template when 

creating your data. 

5. Create or modify a pole data sheet in .csv format to be used for the Create Line from Data 

process. 

6. Once the pole data sheet has been created and saved in .csv format, open a single pole file, a 

.pplx file, in O-Calc® Pro. 

This process is useful for creating a line of poles based on a list of pole information. For instance, 

modeling the first pole in the line and then having a spreadsheet of subsequent pole data. This would be 

faster than individually placing each pole with the line wizard, as all poles would be generated at once.  

Using the Shortcut Key Editor 
This tool gives the you a great amount of control over how the software responds to user defined 

commands. Use this option to make tasks more efficient. Complete these steps: 

1. Navigate to Options > Shortcut Keys in the Main Line Design Menu. This opens a window with a 

list of all the Line Design Menu features.  

2. Select the feature or option that you need to create shortcut for. It should be highlighted when 

selected. 

3. Create a unique combination of keys that become the shortcut using the tools in the window. 

4. Select Apply and close the window. 

Controlling Notes in Map View 
This section outlines how note objects can be edited when they are being displayed in the map view of 

the Main Line Design Area.  
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Clearing Cache Tiles 

Clear the local cache 
This clears the local display cache for the selected layer, but none of the other layers in the cache. 

Clearing the cache for a service affects all the layers in all your maps that reference this service: local 

caches are stored on a service-by-service basis, and if you have multiple layers that reference a cached 

map service, they all utilize the same caches of tiles in your Windows temporary folder. 

The local cache for on your machine is always stored in a folder called MapCacheV1, and like all 

temporary data, this folder is stored under your Windows temporary folder. Inside the MapCacheV1 

folder a separate subfolder is maintained for each cached map service, and this is the last part of the 

path you see. 

Tip: Caches being used by basemap layers cannot be cleared while in use. To clear the cache, remove 

the basemap layers from the map. 

If you normally draw maps for only a few areas, such as your agency’s local study area, the cache won’t 

become large, because the tiles you draw are likely already in your cache. If you draw maps for many 

different areas, your cache can grow. Whenever you draw a new area, new tiles are stored in the local 

cache. 

View Layer Cache Size and Storage Location 
The dialog box shows the display cache size of the current layer and path of the cache location on disk. 

This helps you monitor its use. 

 

Setting Conventions for Geolocation Tools 
The Geolocation tools used by O-Calc® Pro control how information about a pole or related object’s 

location is entered or displayed. Setting up Geolocation preferences controls the format for how 

coordinates are entered, and what units are used for elevation. To set up Geolocation tools, complete 

these steps: 

1. In the main menu of O-Calc® Pro select the Edit menu. 

2. Click the Pole Coordinates option; this opens the Geolocation window. 
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3. In the above image, the conventions being used are signed degrees as the unit for latitude and 

longitude, with meters being used as the convention for elevation. These parameters can be 

changed by clicking on the Set Convention option. 

 

4. Hover the cursor over the Lat Long Format option and select a different convention. 

a. Select the Degrees convention 

 

 
 

b. Select the Degs and Mins convention. 

 
c. Select the Degs, Mins, Secs convention. 

 
 

5. Hover the cursor over the Elevation Format option and select a different convention. 

a. Select the Decimal Feet convention. 
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b. Select the Feet and Decimal Inches convention. 

c. Select the Feet and Inch Fraction convention. 

6. Once all selections are made, click OK.  

 

Setting Pole Coordinates from the Map View 
When a pole is modeled from scratch, you have the option to input the pole coordinates for that pole. 

However, this is not mandatory.  

When a pole without coordinates is open, it is possible to set coordinates for it interactively in the Map 

area of Line Design. Complete these steps: 

1. Open a .pplx file that does not have coordinates set. 

2. Go to the Line Design Map area. 

3. Left click anywhere in the Map area; a Set Pole Coords? prompt appears. 

 

4. Select ‘Yes’ to set the pole’s coordinates to the selected location on the map. 

**Note: To reposition the pole after the coordinates have been set, set the instruction under Position 

Selected Pole 

 

Display Unit Options  
The O-Calc® Pro display units can be set to either the Scientific metric system (meters) or the English 

system (feet). In addition to these two options, select a different format for how the units are displayed 

in O-Calc Pro. To change these options, complete these steps: 

1. In the main menu select the Options menu, select Units Convention. 
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2. Begin by selecting either the English or Scientific units from the first dropdown list. 

 
 

3. Then, use the second drop-down list to select the display format for the units; choose from the 

options. 

 
 

4. Use the Format Feet in DEP option to toggle on or off in the data entry panel. 

 

Jumpers  
The ability to model Jumpers in O-Calc® Pro Line design is an essential component of many new features 

and concepts that require linking. Jumpers ensure connectivity between spans that run from one pole to 

the next in Line Design. There are several ways in which Jumpers can be generated and modified; those 

methods outlined here. For example, if the pole has a double crossarm using dead-end insulators, the 

spans in the different directions are not connected until a jumper cable is attached between the two 
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insulators. The two images below show the spans without and with jumpers. There are several ways in 

which jumpers can be generated and modified; those methods are outlined here. 

To add jumpers to the insulators manually complete these steps: 

Option A: 

To manually create a jumper cable between two insulators, within the 3D View left click and hold on one 

insulator, then drag and unclick on the second insulator. In the fly-out window, pick the option ‘Add 

Jumper’. Be sure to verify that the jumper cable is correctly drawn. The jumper can be modified in the 

data entry window.  

Option B: 

1. Create a pole construction like the image captioned “Dead-end Insulators without Jumper 

Cable” 

 

2. Select the insulators you need to jumper together, then, in the Data Entry use the filters to see 

the following screen.    

 

3. In the Jumper ID row enter unique IDs for each Jumper. In the Jumper Target ID row enter the 

Jumper ID of the other Jumper. You only need to enter the target ID for one Jumper. Otherwise 

you do get duplicate jumpers. Use the next three rows to modify the properties of the jumper. 

Below is an example of how the data can be filled out.   

Dead-end Insulators without Jumper Cable 
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4. The example above generates the jumper shown in the image “Dead-end Insulators with Jumper 

Cable”. 

 

 

Split and Jumper Insulators 
Another helpful “jumper” operation is the Split and Jumper Insulators option available when you right 

click on the insulator.  

In the scenario where a double crossarm with dead-end insulators is replacing single crossarm with 

single pin insulators, this is an easy and fast way to accomplish the task. Complete these steps: 

1. Select the Pin insulators and substitute them for dead-end insulators using the drag and drop 

from the catalog. 

Before 
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After 

 
 

2. Select the Crossarm, in the Data Entry increase the single Crossarm Arm Count from 1 to 2. 
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3. Right click on one Jumper at a time, select the Split and Jumper Insulators option. 

  
 

 

4. Select from the jumper position options offered. 

 
5. Repeat until the operation is completed for all the insulators you need to jumper. 

 

Jumpers can be placed either above, below, or to either side of the insulators when they are placed 

automatically. 

 Jumpers can also be drawn between an insulator and an object by using what is called a Terminal. The 

terminal is a point where the jumpers are going to end. Typically, it is placed at a point near equipment, 

such as a transformer. Jumpers can go from one insulator to another but cannot loop around back to the 

original insulator. 
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Delete a Jumper 

There are options for deleting. In the Data Entry remove a jumper easily by deleting the Jumper ID and 

Jumper Target ID. Additionally, you can right-click on an existing jumper and a menu appears with the 

option to delete the jumper.  

 

 

Auto-Generated Jumpers 
O-Calc® Pro Line Design can auto-generate jumpers when needed while building a line from scratch with 

each new created pole. This option can be toggled on and off by either checking or unchecking the 

option ‘Auto-Jumper Created Poles’ found under the Options menu within Line Design. When this option 

is checked, then the jumper is created in one of four modes based on the selection in the drop down 

below the ‘Auto-Jumper Created Poles’. 

• Jumper Up – jumper is attached to insulators above the insulators 

• Jumper Down – jumper is attached to insulators below the insulators 

• Jumper Street – jumper is attached to side of insulators toward the 90-degree side 

• Jumper Field – jumper is attached to side of insulators toward the 270-degree side 

• Do Not Change – jumper is attached using the last used jumper orientation 

• Auto – jumpers is attached automatically in an orientation determined by the algorithm to 

create the shortest jumper 
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The Auto-Jumper Created Poles option ensures that jumpers are place automatically when a line design 

is created using the line design wizard. The Default Jumper Placement option determines where the 

jumper is going to be placed when the Auto-Jumper Created Poles option is enabled. 


