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O-Calc Pro Clearance Analysis Report User Guide 
Overview 
The O-Calc Pro Clearance Analysis Report is intended to provide users with a detailed or worst-
case clearance analysis report to evaluate the clearances and obstruction needed for any spans or 
equipment attached to the pole. Analysis is based upon pole loading regulations and clearance 
rules such as the NESC, GO95, or CSA.  However, they can be configured to your explicit needs. 
Two report options are available; Osmose Clearance Analysis (Detailed) and Osmose Clerance 
Analysis (Worst Case).  

 

Note: A Line Design (.pplld) file or Pole Model (.pplx) file must be open in O-Calc Pro to access the Clearance 
Analysis Reports. 
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Loading the Configuration 
The configuration criteria from which the report evaluates the pole clearance violations, 
obstructions, and easements must be defined for the Clearance Analysis Report to produce 
results.  Within the Clearance Report Config File menu, you can import a predefined configuration 
.CCFG file(s). The .CCFG file must contain clearance cases and minimum clearance details. You 
can use an existing configuration file and make customized updates to the configuration based on 
any pole loading scenario. Shown below are the readymade 2023 NESC configuration files currently 
available within O-Calc Pro: 

 

Note: Future updates to include the readymade GO95 and CSA configuration files. 

    

Complete these steps to load the configuration data: 

1. From the Line Design menu, select the Clearance tab in the auxiliary area to the left of the 
map. 

 
 

2. Click the Report Configuration tab, click the Load Configuration button. 

 
 

3. The Clearance Report Config window opens. 
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Clearance Report Config   
The Clearance Report Config window provides access to all the tools needed to create and display 
the Clearance Analysis Report such as the Header, Clearance Cases, Minimum Clearance spacing 
information, and an additional Options menu. Within the File menu, you can import or export 
configuration data, begin a new report, make updates to an existing one and most importantly, Save 
the configuration information so that the Clearance Analysis Reports will use this information. 

 

File and Clearance Case Menus 
See the File and Clearance Case menu description below. 

Clearance Report 
Config Menu 

Description 

File > Save 
 

 

Use the File menu Save option to save the Clearance Report 
Configuration file. There is only one saved configuration that the 
Clearance Reports use at this location:  
[C:\Users\<username>\AppData\Roaming\ClearanceReport\Def
ault.xml] 
If closed and reopened, the Clearance Report Configuration will appear 
as the last saved report. Once the file is saved, click OK in the 
confirmation window. 

File > Import 
 

Use the File menu Import option to select various other pre-
configured clearance configuration (.CCFG) files and click Open. 
This will load the .CCFG file into the Clearance Report Config 
window for making updates or changes.   
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Note: unless Saved to the Defualt.xml file, these configurations will 
not be applied to the Clearance Reports.  
 

        
 
 

File > Export 
 

 
 

Use the File menu Export option to export (save to a CCFG file)  the 
Clearance Config file using the file name and location of your choice.  

File > Update Structures 
and Surfaces 
 

 

Use to update structures and surfaces that you have added, in the 
Min Clearance tab. See the confirmation message, click OK. 

 
 

File > New (Default) 
 

 

Use the File menu New (Default) option to return to the default 
values. Returns the Clearance Cases and Min Clearance (ft) tab to their 
default setting. Any edits done to the settings in the Header and Options 
tab will remain the same. 
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Clearance Case 
 

 

Use the Clearance Case menu to manipulate the existing entries 
displayed in the Clearance Cases window and add new ones. 
 
To perform these operations: Remove, Move Up, Move Down, first 
select the number in the first column (as highlighted above) for the 
row of data you want to affect.  Use as follows: 

a. Add – Adds a row to the bottom of the list of clearance 
cases. 

b. Remove – Removes the currently selected clearance 
case.  Multiple cases can be removed at once using the 
shift key to select clearance case rows.  

c. Move Up – Moves highlighted clearance cases up the 
numbered list 

d. Move Down – Moves highlighted clearance cases down 
the numbered list 

 
 

Report Header Block 
Selecting the Header tab displays the Report Header Block, which enables customizing of the 
clearance reports title.  Customization options include the header size (Width and Height), and 
content within the header.  The text content within the header can be adjusted with the options 
such as Edit, Font, Paragraph, Bullets, and Tokens.  Use the Preview Header option to inspect the 
layout of the Header you design.  All O-Calc Pro Tokens are available which should be encapsulated 
with percent signs (%).  
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See the menu descriptions below for the Header options. 

Report Header Block Menu 
Edit To perform these operations use as follows: 

 
Undo – Revert the last action the user performed. 
Redo – Repeat the last action that was undone. 
Find – Search for a specific text.  
Find and Replace – Search for specific text and replace it with a new text. 
Select All – Use to select (highlight) everything in the text area. 
Copy – Duplicates selected text. 
Cut – Removes selected text. 
Paste – Inserts copied text. 
Import… – Use to import Text, XML, and Ike files. 
Insert Image – Insert images with a Bitmap, JPEG, or GIF format. 
  

Font 
 

Select Font – Use to select the font, font style, and size. 
Font Color… – Use to select a font color from a ‘basic color’ pallet or select 
‘define a custom color’ pallet. 
Bold – Use to make the selected text darker and thicker to add emphasis.  
Italic – Use to slant the selected text.  
Underline – Use to add a line beneath the selected text. 
Normal – Remove special formatting and return text to the default style. 
 
Note: Bold font may cause the header to appear bury. 
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Paragraph Indent – Indent the line the curser is on or multiple highlighted lines. Indent 
options are None, 5 pts, 10 pts, 15 pts, or 20 pts. 
Align – Use to shift text to Left, Center, or Right. 
 

Bullets Add Bullets – Use to adds bullet point to the line where the curse is or to 
multiple highlighted lines. 
Remove Bullets – Use to remove bullet point to the line where the curse is 
or to multiple highlighted lines. 
 

Tokens Use to open a file in NotePad named HeaderTokens.txt containing a list of 
Tokens/commands to copy and paste into the report header. 

 
 

Preview Header Click to open a .png file displaying the current Header you have designed, 
after you have clicked the Save button in the File menu.  
 

 
 

 
 
Note: The height of the Header Block determines how many rows of text are 
displayed in the preview. 
 

Width/ Height The Width is the horizontal size of the Header information block. 
The Height is the vertical size of the Header information block. 
 

 
 

 

Clearance Cases and Minimum Clearance Tabs  
The Clearance Cases and the Minimum Clearance tabs contain the values used in defining the 
regulation data for the pole loading analysis results. Clearance cases and minimum clearances can 
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be defined as stipulated by a governing body such as the NESC, GO95, etc. Additionally, 
customized case values can be manually entered and saved for importing along with the minimum 
clearance values for use by the clearance report. Each value can be edited and saved to create a 
custom clearance case for use in any pole loading scenario. 

In the two examples of data displayed below are the NESC Grade C Heavy regulations imported 
from the pre-built configuration file, shown below: 

 

 

Clearance Cases Tab 
The Clearance Cases tab lists all the defined clearance cases as rows within a table.  There are 12 
standard columns that list the name of the clearance case, the standard reference being used, the 
various temperatures and ice thicknesses that should be used for various wire types (Primary, 
Secondary, Neutral, and Communications).  And finally, a wind pressure column.  

The Clearance Case menu, as described above in the section “File and Clearance Case Menus” 
enable the adding, removing, and reordering of these Clearance Cases.  One can select an 
individual cell within this table to edit a name, temperature, ice thickness, or wind pressure.  Be 
sure to either hit the enter key or move to another cell for the edit to take effect.   
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Min Clearance (ft) Tab 
The Min Clearance (ft) tab enables the user to adjust the minimum vertical spacing in feet between 
different span types (Primary, Neutral, Secondary, and Comms).  It also always for adjusting 
minimum vertical spacing between these span types and any defined obstructions.  The 
obstructions are defined within the Line Design Obstructions tab under the Rules menu.   

Note: See the O-Calc Pro Line Design User Guide for explicit instructions regarding 
Obstructions.  

To refresh the list of Obstructions, use the File -> Update Structures and Surfaces within the 
Clearance Report Config dialog.  To chance an actual minimum clearance value, select the cell and 
type in the required value.  Be sure to either hit the enter key or move to another cell for the edit to 
take effect.   
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Options Tab 
The Options tab allows for additional general Clearance Analysis Report configurations.  How the 
O-Calc Pro Clearance Report (Detailed) and O-Calc Pro Clearance Report (Worst Case) are 
displayed to the user when reports are run.  The various options listed below and their detailed 
descriptions are outlined in the table below.  

 

 

Profile View Labels at ends – Labels for spans are on the ends of the 
poles to the side in reports pole diagrams.  
Label in Body – Places the labels for spans in between 
poles in reports pole diagrams. 

Profile View vertical scale factor Maximum value is 3.00, moves down in increments of 10. 
Min Height Moves up or down in increments of 10. 
Max Height Moves up or down in increments of 10. 
Overhead View – The first page of 
the report, below the header 
block, is an overhead view of the 
pole in question within the Line 
Design. This option configures 
how that overhead view is 
displayed 
 

Schematic – Displays line design like the view in the Line 
Design tab. 
Render – Display is like the top view in the 3D View tab. 
Not Displayed – Does not display an overhead view in the 
report. 

Groundline Source Registered Source Only – Only the registered/default 
groundline data source is used, ignoring structure/surfaces 
data.  
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Structure Surface Only -  Only structure/surfaces data is 
used for groundline calculations, ignoring the default 
groundline 
Both – Default and Structure/Surfaces data is used. 

Layout Portrait – Displays report vertically. 
Landscape – Displays report horizontally. 

 

Add Obstructions 
The O-Calc Pro Clearance Analysis Report also utilizes the existing functionality of obstructions in 
O-Calc Pro. By defining obstructions in the report configuration and placing them in the line design, 
O-Calc Pro can determine if the obstructions violate any of the defined clearance rules in the 
configuration file.  

Note: See the Clearance topic listed in Line Design User Guide for instructions on adding 
obstructions and surfaces. 

 

Note: Be sure to click the Update Structures and Surfaces in the File menu after any updates are 
added to the line design. 

Run the Report 
Once the configuration and any potential obstructions are added to the line design and saved the 
next step is running the report. You can find the report in the Reports panel. In the Reports drop-
down menu there are two options; select the one you need: 

O-Calc Pro Clearance Analysis (Detailed) – Includes the full Clearance analysis report including 
all clearance cases for that pole.  
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O-Calc Pro Clearance Analysis (Worst Case) – Includes just the information for the worst-case 
scenario so it’s a much shorter report. 

  

  

Understanding the Report  
Understanding the O-Calc Pro Clearance Analysis Report structure and the various information it 
contains is vital to effectively using the report. The Report is separated into several different types of 
data. Color-coded pages (purple, orange, blue) are useful in identifying immediately the type of data 
contained within them. The colors are as follows: 

Purple – General pole information  

Orange – Worst clearance case scenario 

Blue – Individual clearance cases 

Purple - General information for the pole, plus the attached equipment being evaluated 

The O-Calc Pro Clearance Analysis (Detailed) report reveals information pertaining to the selected 
pole.  We will examine the report page by page to understand each of the results displayed. 
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Page 1 – Purple: General pole information 

 

Page 1 top of the page see the following details: 

1. Pole ID: in the upper left corner. 
2. Report Created: in the upper right corner date and time stamp. 
3. Header Information: Pole_5 is the selected pole. 

 

 
 

4. Graphic on the left displays a plan view of the pole (red dot icon) and any adjacent poles. 
5. Bays at pole information displays the degree and length of the wires. 
6. Obstructions and Surfaces displays the added items latitude and longitude data. 
7. On page 1 next section shows the Poles Properties: 

a. Pole Number (ID) 
b. Length (ft), Class, Species, Length AGL (ft), Latitude, Longitude, Elevation (ft) 
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8. On page 1 next section shows the Clearance Cases: 

a. ID (column number) 
b. Clearance Case Name, Code Ref (NESC) 
c. Ambient Temp (f), Primary Temp, Secondary Temp, Neutral Temp, Comms Temp 
d. Primary Ice (in), Secondary Ice, Neutral Ice, Comms Ice, Wind Pressure (psf) 

  
 

9. On page 1 next section shows the Allowed Clearances: 
a. Category 
b. Primary (ft), Neutral (ft), Secondary (ft), Comms (ft), 
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Page 2 – Purple: General pole information continued 

 

At the top of page 2 see the following details: 

1. At the top of the page, the graphic shows the selected pole (red dot icon) has a length of 209’6” 
(ft)  and an angle of 89.72 degrees. 

  
 
2. On page 2 the next section shows details about the Spans Between Pole_5 and Demo 1: 

a. Key – Type with a number designation, Type – Electrical or communication 
b. Owner – Ownership of the individual wire(s), Name – Includes type, length, angle, size 

and name of the conductor or cable 
c. Span Length (ft) – length of the conductor or cable, Tension Type – As defined by O-Calc 

Pro tension mode types 
d. Initial Tension (lbs) – amount of wire tension in pounds, Initial Sag (ft) – amount of wire 

sag in feet 
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3. One page 2 the next section shows Poles Properties: 

a. Pole Number 
b. Length (ft), Class, Species, Length AGL (ft), Latitude, Longitude, Elevation (ft) 

 
 
4. One page 2 the next section shows Spans Properties: 

a. Name of the conductor or cable 
b. Diameter (in), Weight (lbs/ft), MOE (psi), Thermal Coeff., Creep Coeff. 

 
 

Page 3 – Orange: Worst clearance case scenario 
You will see a table containing a list of the spans defined in the previous page and the amount of 
clearance they have. Green cells mean the equipment is compliant with the rule set up in the 
configuration and Red cells mean the equipment is in violation of the clearance rules. 
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Page 3 top of the page see the following details: 

1. At the top of the page, the graphic shows the Worst Case Pole_5 to Demo 1 which contains 
a profile view of the heights of attachment. 

 
 

2. On page 3 the next section shows details about the conductors and their clearances and 
distances between poles. 

 
 

3. On page 3 the next section shows details about the span sag and tension amounts. 

 
 

Page 4 – Blue – Individual clearance cases 
These pages evaluate clearances on an individual case by case basis and show the clearances for 
the equipment under those loading conditions. Similar to the Orange pages these will also provide 
the user with the clearances of the euipment and show cells in green or red for compliance or 
violations of the rules, respectively. 
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Page 4 top of the page see the following details: 

1. The graphic shows the Clearance Case: ID# 1 Current Conditions for Pole_5 to Demo 1 
which contains a profile view of the heights of attachment. 

2. On page 4 the next section shows details about the conductors and their clearances and 
distances between poles. 

 
3. On page 4 the next section shows details about the span sag and tension amounts. 
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